Справочники.Валюты.ПустаяСсылка() в проводках у не валютных счетов или зависшие развернутые остатки по счетам

Публикация № 873005

Администрирование - Администрирование данных 1С - Обработка документов

обработка Справочники.Валюты.ПустаяСсылка Справочники.ПодразделенияОрганизации.ПустаяСсылка

Описана причина появление пустых ссылок валюты по невалютным счетам. Пример решения этой проблемы. Платформа - 8.3.10.2580. Конфигурация - БП 3.0.60.46.

Похожие статьи:

//infostart.it-titan.ru/public/349891/

//infostart.it-titan.ru/public/348852/

//infostart.it-titan.ru/public/158661/

В этой статье даны пояснения причины и приведен более универсальный код.

Столкнулся с проблемой у клиентов - неожиданно появились зависшие остатки, причем остатки развернутые. Долго не могли понять что происходит, грешили на итоги, но пересчет не помог.

Причина: если оборотки формировать с выводом валюты, тогда становится все понятно - у невалютных счетов вместо значения NULL появилась пустая ссылка валюты.

Что произошло? Оказалось, что перед этим выполнялась процедура поиска и замены. Именно она делает такой беспорядок.

Кто виноват? В типовом коде допущена ошибка:

Процедура ЗаменитьВКоллекцииСтрок(ВидКоллекции, ИмяКоллекции, Объект, Коллекция, Знач СписокПолей, Знач ПарыЗамен)
	РабочаяКоллекция = Коллекция.Выгрузить();
	Модифицировано = Ложь;
	
	Для Каждого Строка Из РабочаяКоллекция Цикл
		
		Для Каждого КлючЗначение Из СписокПолей Цикл
			Имя = КлючЗначение.Ключ;
			ЦелеваяСсылка = ПарыЗамен[ Строка[Имя] ];
			Если ЦелеваяСсылка <> Неопределено Тогда
				ЗарегистрироватьФактЗамены(Объект, Строка[Имя], ЦелеваяСсылка, ВидКоллекции, ИмяКоллекции, РабочаяКоллекция.Индекс(Строка), Имя);
				Строка[Имя] = ЦелеваяСсылка;
				Модифицировано = Истина;
			КонецЕсли;
		КонецЦикла;
		
	КонецЦикла;
	
	Если Модифицировано Тогда
		Коллекция.Загрузить(РабочаяКоллекция);
	КонецЕсли;
КонецПроцедуры

Проблема в параметре "Коллекция", там сидит набор записей. У набора записей, если у валюты стоит NULL, то в момент выгрузки в таблицу значения вместо NULL будет Справочники.Валюта.ПустаяСсылка. ВАЖНО! Такое поведение будет только если поиск и замену выполнять в режиме ОбменДанными.Загрузка = Истина!! То есть, если набор записей записать в обычном режиме, то проблемы не будет.

Но почему такое поведение? Логика платформы ясна: если данные приходят в режиме обмена данными, то значит проверять ничего не надо, ведь по идее такие же данные должны быть в другом узле и мы не может допустить рассинхронизацию. Но в данном случае это конечно ошибка платформы. Возможно в более новых версиях эту ошибку устранили.

 Как исправить? 

&НаСервере
Процедура ИсправитьНаСервере()
	
	Запрос = Новый Запрос;
	Запрос.Текст = 
		"ВЫБРАТЬ
		|	ВложенныйЗапрос.Регистратор КАК Регистратор
		|ИЗ
		|	(ВЫБРАТЬ
		|		ХозрасчетныйДвиженияССубконто.Регистратор КАК Регистратор
		|	ИЗ
		|		РегистрБухгалтерии.Хозрасчетный.ДвиженияССубконто(
		|				,
		|				,
		|				ПодразделениеДт = ЗНАЧЕНИЕ(Справочник.ПодразделенияОрганизаций.ПустаяСсылка)
		|					И СчетДт <> ЗНАЧЕНИЕ(ПланСчетов.Хозрасчетный.ПустаяСсылка)
		|					И НЕ СчетДт.УчетПоПодразделениям,
		|				,
		|				) КАК ХозрасчетныйДвиженияССубконто
		|	
		|	СГРУППИРОВАТЬ ПО
		|		ХозрасчетныйДвиженияССубконто.Регистратор
		|	
		|	ОБЪЕДИНИТЬ ВСЕ
		|	
		|	ВЫБРАТЬ
		|		ХозрасчетныйДвиженияССубконто.Регистратор
		|	ИЗ
		|		РегистрБухгалтерии.Хозрасчетный.ДвиженияССубконто(
		|				,
		|				,
		|				ПодразделениеКт = ЗНАЧЕНИЕ(Справочник.ПодразделенияОрганизаций.ПустаяСсылка)
		|					И СчетКт <> ЗНАЧЕНИЕ(ПланСчетов.Хозрасчетный.ПустаяСсылка)
		|					И НЕ СчетКт.УчетПоПодразделениям,
		|				,
		|				) КАК ХозрасчетныйДвиженияССубконто
		|	
		|	СГРУППИРОВАТЬ ПО
		|		ХозрасчетныйДвиженияССубконто.Регистратор
		|	
		|	ОБЪЕДИНИТЬ ВСЕ
		|	
		|	ВЫБРАТЬ
		|		ХозрасчетныйДвиженияССубконто.Регистратор
		|	ИЗ
		|		РегистрБухгалтерии.Хозрасчетный.ДвиженияССубконто(
		|				,
		|				,
		|				ВалютаДт = ЗНАЧЕНИЕ(Справочник.Валюты.ПустаяСсылка)
		|					И СчетДт <> ЗНАЧЕНИЕ(ПланСчетов.Хозрасчетный.ПустаяСсылка)
		|					И НЕ СчетДт.Валютный,
		|				,
		|				) КАК ХозрасчетныйДвиженияССубконто
		|	
		|	СГРУППИРОВАТЬ ПО
		|		ХозрасчетныйДвиженияССубконто.Регистратор
		|	
		|	ОБЪЕДИНИТЬ ВСЕ
		|	
		|	ВЫБРАТЬ
		|		ХозрасчетныйДвиженияССубконто.Регистратор
		|	ИЗ
		|		РегистрБухгалтерии.Хозрасчетный.ДвиженияССубконто(
		|				,
		|				,
		|				ВалютаКт = ЗНАЧЕНИЕ(Справочник.Валюты.ПустаяСсылка)
		|					И СчетКт <> ЗНАЧЕНИЕ(ПланСчетов.Хозрасчетный.ПустаяСсылка)
		|					И НЕ СчетКт.Валютный,
		|				,
		|				) КАК ХозрасчетныйДвиженияССубконто
		|	
		|	СГРУППИРОВАТЬ ПО
		|		ХозрасчетныйДвиженияССубконто.Регистратор) КАК ВложенныйЗапрос
		|
		|СГРУППИРОВАТЬ ПО
		|	ВложенныйЗапрос.Регистратор";
	
	РезультатЗапроса = Запрос.Выполнить();
	
	ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();
	
	Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
		
		Набор = РегистрыБухгалтерии.Хозрасчетный.СоздатьНаборЗаписей();
		
		Набор.Отбор.Регистратор.Установить(ВыборкаДетальныеЗаписи.Регистратор);
		Набор.Прочитать();
		
		Модифицирован = Ложь;
		
		Для Каждого ЗаписьНабора Из Набор Цикл
			
			Если НЕ (ЗначениеЗаполнено(ЗаписьНабора.СчетДт) И ЗаписьНабора.СчетДт.Валютный) Тогда
				ЗаписьНабора.ВалютаДт = NULL;
			КонецЕсли;
			Если НЕ (ЗначениеЗаполнено(ЗаписьНабора.СчетКт) И ЗаписьНабора.СчетКт.Валютный) Тогда
				ЗаписьНабора.ВалютаКт = NULL;
			КонецЕсли;
			
			Если НЕ (ЗначениеЗаполнено(ЗаписьНабора.СчетДт) И ЗаписьНабора.СчетДт.УчетПоПодразделениям) Тогда
				ЗаписьНабора.ПодразделениеДт = NULL;
			КонецЕсли;
			Если НЕ (ЗначениеЗаполнено(ЗаписьНабора.СчетКт) И ЗаписьНабора.СчетКт.УчетПоПодразделениям) Тогда
				ЗаписьНабора.ПодразделениеКт = NULL;
			КонецЕсли;
			
		КонецЦикла;
		
		Набор.ОбменДанными.Загрузка = Истина;
		Набор.Записать();
		
	КонецЦикла;
	
	
КонецПроцедуры

Как защититься от этой проблемы? Либо помнить чем грозит поиск и замена в режиме обмена данными, либо в процедуре "ПередЗаписью" регистра бухгалтерии добавить проверку, обмен конечно немного замедлится, но так точно больше проблем на возникнет (вдруг еще какой сюрприз притаился):

	Если ОбменДанными.Загрузка Тогда
		//<-- Wadus
		Для каждого Проводка из ЭтотОбъект Цикл
			Если НЕ (ЗначениеЗаполнено(Проводка.СчетДт) И Проводка.СчетДт.Валютный) Тогда
				Проводка.ВалютаДт = NULL;
			КонецЕсли;
			Если НЕ (ЗначениеЗаполнено(Проводка.СчетКт) И Проводка.СчетКт.Валютный) Тогда
				Проводка.ВалютаКт = NULL;
			КонецЕсли;
			
			Если НЕ (ЗначениеЗаполнено(Проводка.СчетДт) И Проводка.СчетДт.УчетПоПодразделениям) Тогда
				Проводка.ПодразделениеДт = NULL;
			КонецЕсли;
			Если НЕ (ЗначениеЗаполнено(Проводка.СчетКт) И Проводка.СчетКт.УчетПоПодразделениям) Тогда
				Проводка.ПодразделениеКт = NULL;
			КонецЕсли;
			
			
			//для забалансовых, иначе по незаполненному счету будут пустые ссылки
			//некритично, но не по фэн-шую
			Если Не ЗначениеЗаполнено(Проводка.СчетДт) Тогда
				Проводка.ВалютаДт = NULL;
				Проводка.ПодразделениеДт = NULL;
			КонецЕсли;
			
			Если Не ЗначениеЗаполнено(Проводка.СчетКт) Тогда
				Проводка.ВалютаКт = NULL;
				Проводка.ПодразделениеКт = NULL;
			КонецЕсли;
		КонецЦикла;
		//--> Wadus
		Возврат;
	КонецЕсли;

Либо изменить функцию в модулях поиска и замены. Пример приводить уже не буду.

Если помог - смело ставь + ! Буду благодарен )

Спасибо фирме 1С за такие интересные задачки! ))

 

P.S. добавил еще подразделения.

P.S.S. добавил забалансовые счета для обработки

Скачать файлы

Наименование Файл Версия Размер
Ремонт валюты/подразделений в проводках
.epf 6,52Kb
24.07.18
7
.epf 6,52Kb 7 Скачать

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо развёрнутое
Свернуть все
1. ZOMI 427 23.07.18 17:50 Сейчас в теме
Баян, и баян недоделанный. Там еще обычно каша по счетам со счетами где нет учета по подразделениям начинается.

В комментах к теме https://infostart.ru/public/158661/ правильные причины возникновения такой проблемы
3. Wadus161 26 23.07.18 20:22 Сейчас в теме
(1)Могли бы Вы пояснить почему баян "недоделанный"? Статья на которую Вы ссылаетесь не объясняет причину, а я объяснил. Статья на которую Вы ссылаетесь вообще не приводит пример кода, а я весь код выложил. Вообще я нигде не нашел объяснения, поэтому и решил поделиться с сообществом.
5. ZOMI 427 23.07.18 20:39 Сейчас в теме
(3) "недоделанный" в смысле, что обычно проблема и с валютой и с подразделением...
Причины как я и указал в (1) озвучены в комментах - ваше объяснение неполное тк данная проблема есть в базах, которые вообще ни с кем не обмениваются данными...
6. Wadus161 26 23.07.18 21:09 Сейчас в теме
(5) Согласен, с подразделениями такая же история. Сейчас дополню. Что касается обмена данными, скорее всего Вас смутила фраза "Такое поведение будет только если поиск и замену выполнять в режиме ОбменДанными.Загрузка = Истина". Обмен данных тут не причем. Имеется ввиду следующее:
Прикрепленные файлы:
2. MSK_Step 19 23.07.18 19:25 Сейчас в теме
Я делал проще,
ДвиженияДокумента = о.Движения.Хозрасчетный;
ДвиженияДокумента.Прочитать();
	
ДвиженияДокумента.Записать();

все встает на свои места

в запросе только искал на <> null
4. Wadus161 26 23.07.18 20:33 Сейчас в теме
(2)Ваш способ не подойдет в том случае если надо сделать запись в режиме ОбменДанными.Загрузка = Истина, В этом режиме лучше писать для скорости, чтобы пропустить обработчики события в модуле объекта регистра бухгалтерии.
7. MSK_Step 19 24.07.18 12:02 Сейчас в теме
(4) Ваш не подойдет в других случаев, когда тип Неопределенно. а не ссылка, так же когда подразделение,а не валюта.
Мой способ универсальный и простой, подойдет всем, насчет скорости - думаю ошибок не так много
А так данная ошибка возникает из за того,что в таблице значений нет типа NULL, если сделать ТЗ = о.Движения.Хозрасчетный.выгрузить() а потом Движения.Загрузить(ТЗ) у вас вознинут такие ошибки. Это ошибка платформы.
код
РабочаяКоллекция = Коллекция.Выгрузить();

в этом месте как раз ошибка
8. Wadus161 26 24.07.18 13:51 Сейчас в теме
(7) В валюте и подразделении Неопределенно не может быть, значение неопределенно устанавливается только у составных типов.

Мне кажется Вы невнимательно прочитали эту публикацию, я как раз и написал что проблема в Коллекция.Выгрузить()

Тут нюанс в следующем: Вы правильно подметили, что у ТаблицыЗначения NULL не может быть. Когда выгружается набор записей регистра бухгалтерии, у которого в валюте и в подразделении сидит NULL, то NULL превратиться в пустую ссылку. Главная изюминка , если написать так:
ДвиженияДокумента = о.Движения.Хозрасчетный;
ДвиженияДокумента.Прочитать();
    
ДвиженияДокумента.Записать();

то платформа сама пустую ссылку валюты и подразделения преобразует в NULL если по счету не ведется валютный учет и учет по подразделению, а если написать так:
ДвиженияДокумента = о.Движения.Хозрасчетный;
ДвиженияДокумента.Прочитать();
    
ДвиженияДокумента.ОбменДанными.Загрузка = Истина;
ДвиженияДокумента.Записать();

то платформа оставить пустые ссылки.
9. dspdsp 22.05.19 11:15 Сейчас в теме
Платформа 8.3.13.1644, бух 3.0.70.50
Проблема осталась, цветет и пахнет, код исправления работает
10. BaronDevil 11.08.19 23:04 Сейчас в теме
Модифицирован = ложь видимо хотели использовать для случаев когда не было изменений?
11. Wadus161 26 12.08.19 16:28 Сейчас в теме
(10)да, точно. Спасибо, позже поправлю.
12. shoy 19 02.10.19 13:12 Сейчас в теме
Платформа 1С:Предприятие 8.3 (8.3.15.1565), Бухгалтерия предприятия КОРП, редакция 3.0 БИТ.ФИНАНС 3.1 (3.0.73.38/3.1.42.11)

Проблема компанией 1С даже не думает исправляться, поэтому ГОЛОСУЮ за эту публикацию.

Автор дал точное объяснение, кроме того привёл варианты ремонта, и предотвращения повторной ошибки.
13. Nicholas 747 24.11.19 17:46 Сейчас в теме
По одной номенклатуре была ошибка "Для целей учета НДС не списано..." при проведении требования-накладной. Несколько часов ломал голову, пока случайно не заметил, что запрос по проводкам в некоторых случаях возвращает пустое подразделение, а в некоторых - NULL.
После этого решил погуглить и нашел вашу публикацию. Спасибо!
14. mihenius 83 25.04.20 21:56 Сейчас в теме
Вроде проблему наконец исправили, но это не точно )

https://bugboard.v8.1c.ru/error/000066639
15. svb404 20.05.20 14:27 Сейчас в теме
В случае этой проблемы кроме "ВалютаДт" и "ВалютаКт" (пустые ссылки) реквизиты "ВалютнаяСуммаДт" и "ВалютнаяСуммаКт" имеют значения = "0", а должны быть тоже NULL. Т.о. и этим реквизитам ("ВалютнаяСуммаДт", "ВалютнаяСуммаКт") надо присвоить значение NULL.
Оставьте свое сообщение

См. также

Отчет производства за смену (ОПЗС) - из Комплектаций номенклатуры Промо

Обработка документов Производство готовой продукции (работ, услуг) Производство готовой продукции (работ, услуг) v8 v8::БУ v8::УФ БП3.0 БУ Абонемент ($m)

Отчет производства за смену БП 3.0 - из Комплектаций номенклатуры УТ 10.3 - после обмена УТ-БП. Внешняя обработка.

2 стартмани

01.03.2019    8739    7    Rustig    0    

Сворачивание взаиморасчетов на 60 и 62 счетах

Обработка документов Дебиторская и кредиторская задолженность v8 v8::БУ БП3.0 Россия БУ Абонемент ($m)

Создаем операцию, которая закроет сальдо по субсчетам. Можно подключить как внешнюю обработку.

1 стартмани

17.03.2020    1314    8    Pira    0    

Изменение последовательности документов для Бухгалтерии 3.0 без проведения документов

Обработка документов v8 v8::БУ БП3.0 Россия БУ Абонемент ($m)

В бухгалтерии 3.0 иногда приходится бороться с датой последовательности, особенно если месяц закрыт, а надо провести один документ задним числом. Бухгалтерия 3.0 позволяет пропустить проведение документов, но как говорится следы редактирования задним числом остаются. Данная обработка показывает, какие документы портят последовательность и позволяет убрать нарушения последовательности.

1 стартмани

21.01.2020    2683    8    p.ugrumov    2    

Отображение дополнительных сведений на форме документа как реквизитов

Обработка документов Работа с интерфейсом v8 v8::БУ БП3.0 Россия Абонемент ($m)

Расширение позволяет редактировать дополнительные сведения не в отдельно открываемом окне, а непосредственно на форме документа.

1 стартмани

05.11.2019    7968    17    9269477065    15    

Универсальное закрытие счетов для 1С:Бухгалтерия предприятия 3.0 Промо

Обработка документов Закрытие периода Закрытие периода Закрытие периода v8::БУ БП3.0 Россия БУ Абонемент ($m)

Внешняя обработка позволяет закрывать счета бухгалтерского учета в ноль, распределять, переносить остатки, обороты бухгалтерского, налогового учета, количества, валютные суммы. Позволяет настроить и сохранить алгоритмы для периодического формирования бухгалтерских операций.

3 стартмани

13.12.2017    28828    228    leha2403    32    

Заполнение табличной части документа СЗВ-КОРР на основании документа СЗВ-СТАЖ для Бухгалтерии и ЗУП

Зарплата Обработка документов v8 v8::БУ v8::СПР БП2.0 ЗУП2.5 БП3.0 ЗУП3.x Россия БУ ФОМС, ПФ, ФСС Абонемент ($m)

Выполняет заполнение документа "Данные о корректировке сведений застрахованных лиц, СЗВ-КОРР" на основании документа "Сведения о страховом стаже застрахованных лиц, СЗВ-СТАЖ". Автоматически подключается как внешняя обработка табличной части документа. Предназначена для: Бухгалтерия 2.0, Бухгалтерия 3.0, ЗУП 2.5, ЗУП 3.1.

1 стартмани

18.09.2019    3385    9    machnef    0    

Формирование записей КУДиР из проводок для ленивых бухгалтеров

Обработка документов Закрытие периода Закрытие периода v8 v8::БУ БП3.0 Россия БУ НУ УСН Абонемент ($m)

Формирование записей КУДиР из проводок для ленивых бухгалтеров или Корректировка записей Книга учёта доходов и расходов УСН для ленивых бухгалтеров. Однажды у бухгалтерии возникла ситуация в новой базе делать "правильные"(по мнению бухгалтеров) записи в КУДиР УСН . Остатки по КУДиР не вносились и не было у них желания вносить. У меня мнение другое , но сделал как просили.) .. Была поставлена задача сформировать "правильные" записи в КУДиР из проводок. Для всех реализаций содержание записи меняется на Списание себестоимости и сумма берется из проводки при списании товаров. Вторая задача - заменить в уже сформированных записях КУДиР на содержание удобное для бухгалтера. Процесс работы построен на переводе затронутых документов в режим Ручная корректировка и замены в них реквизита записи Содержание проводки по заранее подготовленному шаблону Данная обработка будет интересна тем, кто хочет поменять в отчете КУДиР содержание. Для программистов - как шаблон по возможным корректировкам регистров. Проверено на конфигурации Бухгалтерия предприятия, редакция 3.0 (3.0.68.61) . Код открыт

1 стартмани

23.07.2019    3723    8    МимохожийОднако    4    

Создание счетов, актов и массовая рассылка документов по email

Обработка документов Email Документооборот и делопроизводство Производство готовой продукции (работ, услуг) Документооборот и делопроизводство Производство готовой продукции (работ, услуг) v8::БУ БП3.0 Россия БУ Абонемент ($m)

В своей практике пришлось столкнуться с необходимостью отправки электронных копий документов на оплату услуг для клиентов по email. Все письма должны были содержать одинаковые документы: счет на оплату, акт выполненных работ и отчет. Счета выставлялись на услуги с почасовой оплатой. Раньше каждое письмо приходилось собирать отдельно. Сохранять акт в файл, затем крепить его к письму. На рассылку уходил день или два. Теперь все делается двумя кнопками: Создать документы, Отправить сообщения.

1 стартмани

03.07.2019    3887    11    user707895_587363    1    

Загрузка УПД в Бухгалтерию 3.0 Промо

Обработка документов Загрузка и выгрузка в Excel Оптовая торговля Оптовая торговля v8 v8::БУ БП3.0 Россия БУ Абонемент ($m)

Загрузка УПД из Excel в Бухгалтерию предприятия 3.0, с добавлением номенклатуры, ГТД, стран происхождения.

3 стартмани

20.10.2015    18925    16    teyana    12    

Печать на чеке РКО, кому выданы денежные средства (мини-расширение для БП 3.0)

Кассовые операции Обработка документов Кассовые операции v8 v8::БУ БП3.0 Россия БУ Абонемент ($m)

Доработка типовой конфигурации Бухгалтерии предприятия для вывода информации на чек, кому выданы денежные средства и основание выдачи.

1 стартмани

30.05.2019    3814    3    ifal    4    

Автоматическое формирование актов сверки (Бухгалтерия предприятия 3.0)

Дебиторская и кредиторская задолженность Обработка документов Дебиторская и кредиторская задолженность v8 v8::БУ БП3.0 Россия БУ Абонемент ($m)

Внешняя обработка для автоматического формирования актов сверки по контрагентам. Причиной создания стало не удовлетворительное качество имеющихся на инфостарте обработок и желание закрыть этот вопрос навсегда. Возможности: формирование по оборотам в периоде и по справочнику договоров; управление дополнительными настройками заполнения актов сверки; представителей организации и контрагента; формирование актов по договорам и сводно по контрагентам; возможность убрать не нужные договоры; перезаполнение существующих актов сверки.

3 стартмани

16.05.2019    5377    47    Black-fog    1    

Исправляем пересортицу на 41 счете, легко и быстро. Для Бухгалтерии 3.0 и Бухгалтерии 2.0

Обработка документов Учет ТМЦ Учет ТМЦ v8::БУ БП2.0 БП3.0 БУ Абонемент ($m)

В жизни так иногда случается, что в справочнике Номенклатуры неизвестным образом появляются дубликаты некоторых позиций номенклатуры. И однажды бухгалтер видит печальную картину в Анализе 41 счета - Оприходован один товар из справочника, а списывается  другой. Да, он точно так же называется и они оба имеют одинаковые Артикулы, но в системе это два разных элемента Справочника и ..... надо исправлять, говорит Бухгалтер. 

5 стартмани

14.05.2019    5528    12    VPanin56    4    

Перенос НФА (ОС и МЗ) между учреждениями/базами через документы списания и поступления [БГУ 1.0] Промо

Перенос данных из 1C8 в 1C8 Обработка документов Учет ОС и НМА Учет ОС и НМА v8 v8::БУ БГУ Государственные, бюджетные структуры Россия БУ Госбюджет Абонемент ($m)

Обработка выполняет перенос основных средств/материалов между учреждениями/базами через документы списания НФА и безвозмездного получения в другом учреждении/базе данных.

10 стартмани

18.09.2014    38783    46    qwinter    31    

Отображение остатка дней отпуска в документе начисления отпуска. БП 3.0

Обработка документов Зарплата Управление персоналом (HRM) Зарплата Управление персоналом (HRM) v8::БУ БП3.0 Россия БУ Абонемент ($m)

Расширение конфигурации для БП 3.0, которое показывает остаток дней отпуска в документе начисления отпуска.

1 стартмани

30.04.2019    5459    7    itmind    7    

Групповое формирование актов сверки взаиморасчетов и рассылка по электронной почте (БП 3.0)

Обработка документов Email Дебиторская и кредиторская задолженность Дебиторская и кредиторская задолженность v8::БУ БП3.0 Россия БУ Абонемент ($m)

Внешняя обработка, которая позволяет формировать акты сверки расчетов с контрагентами, делать рассылку файлов актов с печатью и подписью, контролировать возврат оригиналов документов.

1 стартмани

12.04.2019    5888    34    andy23    15    

Заполнение документов поступления (акты, накладные) на основании документов, полученных через ЭДО (УПД и товарная накладная)

Обработка документов Оптовая торговля Оптовая торговля v8 v8::БУ БП3.0 Россия БУ Абонемент ($m)

Обработка позволяет заполнять номенклатуру (товары) документа Поступления (акты, накладные) на основание входящих документов ЭДО.

1 стартмани

10.04.2019    3643    2    piskunov.maksim.a    3    

Формирование платежных поручений на заданную в поступлениях товаров дату Промо

Обработка документов Банковские операции Банковские операции v8::БУ БП3.0 Россия БУ Абонемент ($m)

Данная обработка предназначена для автоматического формирования платежных поручений на выбранный день на основании документов "Поступление товаров и услуг" и "Счета от поставщиков". Для определения срока оплаты документов используется "Срок оплаты", указанный в документах. Предполагается, что эти документы еще не оплачивались. При этом, если есть несколько документов от поставщика с одним договором, которые необходимо оплатить в один день, будет создано одно платежное поручение, в назначении которого будут перечислены все оплачиваемые документы.

8 стартмани

09.11.2016    20815    20    INTECH1    9    

Замена КОСГУ/КЭК по приказу 209н для БГУ ред.1 и ред.2

Обработка документов v8::БУ БГУ Государственные, бюджетные структуры Россия Госбюджет Абонемент ($m)

Обработка замены КОСГУ/КЭК в проводках групп 340/560/660/730/830 по приказу 209н для БГУ ред.1 и ред.2

2 стартмани

16.03.2019    13979    124    user716289    32    

Заполнение плановой себестоимости продукции в документе "Отчет производства за смену" для Бухгалтерии 3.0

Обработка документов Производство готовой продукции (работ, услуг) Производство готовой продукции (работ, услуг) v8 v8::БУ БП3.0 Россия БУ Абонемент ($m)

Заполнение значения Плановая стоимость продукции для документа "Отчет производства за смену" для Бухгалтерии предприятия 3.0 по данным списания материалов.

1 стартмани

13.03.2019    5003    8    aleksandr_leiman    4    

Обработки замены КОСГУ групп 340/560/660/730/830 по приказу 209н для БГУ ред.1

Обработка документов v8::БУ БГУ Государственные, бюджетные структуры Россия Госбюджет Абонемент ($m)

Обработки замены КОСГУ групп 340/560/660/730/830 по приказу 209н для БГУ 1.0.56: 1. Замена по группам 340/440. В зависимости от счета учета МЗ присваивается соответствующий КОСГУ (341, 342... 441, 442...). 2. Замена по группа 560/660/730/830. В зависимости от типа контрагента присваивается соответствующий КОСГУ (731,732,561,562...)

1 стартмани

12.03.2019    6555    84    pavel_vrn    9    

Ночное восстановление последовательности документов (фоновым заданием) для БП 3.0 Промо

Обработка документов v8 v8::БУ БП3.0 Россия Абонемент ($m)

Внешняя обработка служит для восстановления последовательности документов в БП 3.0 за месяц, по расписанию, фоновым заданием на сервере 1С. Подключается как дополнительная обработка в режиме пользователя.

5 стартмани

25.02.2016    32570    82    SmArtist    8    

Аналоги материалов в "Отчёте производства за смену"

Обработка документов Производство готовой продукции (работ, услуг) Производство готовой продукции (работ, услуг) v8 v8::БУ БП3.0 Россия БУ Абонемент ($m)

С помощью данного расширения в документе "Отчёт производства за смену" можно автоматически заменить отсутствующие материалы на их аналоги.

2 стартмани

05.03.2019    4529    4    Andrey_Fokin    0    

Контроль корреспонденций счетов при проведении документов в "1С:Бухгалтерия предприятия 3.0" (расширение)

Обработка документов v8::БУ БП3.0 Россия БУ Абонемент ($m)

Конфигурация "Бухгалтерия предприятия, редакция 3.0" предоставляет большую свободу при выборе счетов и аналитики в документах. Вашему вниманию предлагается механизм контроля корректных корреспонденций и аналитики при проведении документов, что может быть полезно для обеспечения "порядка" в учете, особенно при большом и разнообразном документообороте.

3 стартмани

14.02.2019    6177    2    alex15650    6    

Нумерация документов с префиксом по дате

Обработка документов v8 v8::БУ УНФ БП3.0 УТ11 КА2 ЗУП3.x Россия Абонемент ($m)

Расширение конфигурации позволяет настроить нумерацию документов Заказ клиента, Счет, Реализация, Счет-фактура и Оказание производственных услуг и кадровых документов префиксом по дате документа. Т.е. в течении дня документы одного вида будут иметь сквозную нумерацию. На пример документы за 10 февраля нумеровать как 1002-0001, 1002-0002 и т.д. Возможны различные варианты настройки формата даты, в том числе с сохранением префиксации по организации и узлу информационной базы. Для конфигураций 1С:Бухгалтерия 3.0, Управление торговлей 11.4, Комплексная автоматизация 2, Зарплата и управление персоналом 3.1, Управление нашей фирмой 1.6 (УНФ 1.6)

2 стартмани

11.02.2019    13418    86    de0nis    35    

Загрузка Счета покупателя из PDF Промо

Обработка документов Файловые протоколы обмена, FTP Оптовая торговля Оптовая торговля v8 v8::БУ БП3.0 Абонемент ($m)

Обработка позволяет загрузить счет покупателя из pdf-файла в документ Счет на оплату покупателю (Бухгалтерия 3.0)

2 стартмани

23.05.2016    13936    16    John_d    0    

[ПР] Бухгалтерия: полезные инструменты

Универсальные обработки Обработка документов v8 v8::БУ БП3.0 БУ Абонемент ($m)

Небольшое расширение для типовой Бухгалтерии Предприятия, ред.3.0 с несколькими полезными функциями: 1. Быстрое формирование стандартных бухгалтерских отчетов из движений любых документов. 2. Открытие ссылок в табличных частях в документах в закрытом периоде. 3. Редактирование реквизитов в закрытом периоде без перепроведения документа. 4. Настраиваемый запрет пустых субконто в проводках при записи документов.

2 стартмани

31.01.2019    5466    10    magv    0    

Групповое создание актов сверки "Бухгалтерии предприятия" ред. 3.0

Обработка документов Дебиторская и кредиторская задолженность Дебиторская и кредиторская задолженность v8 v8::БУ БП3.0 Россия БУ Абонемент ($m)

Простая, но полезная обработка по массовому созданию документов актов сверок за период в "Бухгалтерии предприятия 3.0". Есть отборы по группе контрагентов, остаткам и оборотам на счетах, доп.опции. В базе создаются документы "Акт сверки расчетов".

1 стартмани

19.01.2019    7027    39    maxx    1    

Управление последовательностью документов (обработка для БП 3.0)

Обработка документов Универсальные обработки Закрытие периода Рабочее место v8::БУ БП3.0 УХ БУ Абонемент ($m)

Наиболее универсальная и удобная обработка по управлению последовательностью документов в конфигурациях на базе "1С:Бухгалтерия 3.0". Быстрое отображение, гибкие динамические отборы, изменение состояний документов, удаление из последовательности, групповые действия, удобная навигация по периодам.

2 стартмани

14.01.2019    6800    38    mbreaker    0    

Групповая замена субконто для БП 3.0, УФ Промо

Обработка документов v8::БУ v8::УФ БП3.0 БУ Абонемент ($m)

Внешняя обработка-отчет с произвольным отбором документов за период, по счету, по субконто и т.п. Позволяет менять аналитику в проводках - заменять значения субконто, подразделение в движениях документов.

2 стартмани

20.05.2015    28414    151    MaxS    15    

Склады в табличной части. Расширение для 1С:Бухгалтерия Предприятия 3.0

Учет ТМЦ Обработка документов Учет ТМЦ v8 v8::БУ БП3.0 Россия БУ Абонемент ($m)

Позволяет оформлять поступление и реализацию товаров с разных складов одним документом.

5 стартмани

05.12.2018    7328    42    RuzAleks    41    

Просмотр и печать содержимого ГТД по импорту в БП 3.0, УТ 11 и КА 2

Обработка документов Печатные формы документов Внешнеэкономическая деятельность (ВЭД) Оптовая торговля Внешнеэкономическая деятельность (ВЭД) Оптовая торговля v8 v8::БУ v8::ОУ БП3.0 УТ11 КА2 Россия БУ Абонемент ($m)

Внешняя обработка позволяет просмотреть "внутренности" документа "ГТД по импорту", а также распечатать его содержимое – отдельно разделы, отдельно товары и документ в целом.

1 стартмани

23.11.2018    9270    12    accounting_cons    12    

Загрузка в Бухгалтерию предприятия, ред 3.0, данных о движениях наличных денежных средств, а также операций по платежным картам из Excel с портала ОФД

Обработка документов Банковские операции Кассовые операции Загрузка и выгрузка в Excel Банковские операции Кассовые операции v8 v8::БУ БП3.0 Россия БУ Абонемент ($m)

Если ФР, поддерживающие ОФД, по каким-то причинам отделены от ПК с базой 1С, а ввод приходов (ПКО), возвратов (РКО) и оплат по карте занимает много времени - поможет данная обработка загрузки из Excel-я. Сия зарисовка реализовывалась под конкретный файл с данными (пример приложен).

2 стартмани

30.10.2018    4197    33    kartyz    14    

КЛОНИРОВАНИЕ БУХГАЛТЕРА - ОТ ФАНТАСТИКИ К НАУКЕ Промо

Обработка документов Учет ОС и НМА Учет ТМЦ Учет ОС и НМА Учет ТМЦ v8::БУ БП2.0 Россия БУ НУ Абонемент ($m)

Российско-японской группе учёных удалось найти в ископаемых останках мамонта необходимый генетический материал, который требуется для клонирования доисторического животного. Насколько данная методика подходит для клонирования человека? Нас более интересует прикладная задача – клонирование бухгалтера. Специалисты дают научно обоснованный ответ. См. так же "Создание документов поступлений по отгрузке"

2 стартмани

02.06.2011    23448    7    director04    62    

Заполнение начальных остатков при переходе на раздельный учет НДС

Обработка документов v8::БУ БП3.0 Россия БУ НДС Абонемент ($m)

При переходе на раздельный учет НДС, в Бухгалтерии предприятия 3.0, не формируются автоматически остатки по спец. регистру "Раздельный учет НДС" материалов и не проводятся документы Требования-Накладная и Списание с ошибкой "Для целей учета НДС не списано N товара". Данная обработка позволяет решить эту проблему.

1 стартмани

18.10.2018    8951    107    BigTaur    7    

Групповая обработка справочников и документов (Управляемые формы) 1С:Предприятие 8.3 (8.3.13.1513)

Обработка документов Обработка справочников v8 v8::БУ v8::УФ БП3.0 Абонемент ($m)

В Бухгалтерии 1С 2.0 Была такая обработка, она была очень полезной, в новой версии Бухгалтерии 3.0 без нее как "без рук", в интернете полно таких обработок, но они не устаивали либо по интерфейсу (пользователи привыкли к такому интерфейсу) либо по скорости работы (отбор осуществлялся очень медленно), поэтому было принято решение написать такую обработку включая все возможности обработки старой и добавив возможность регистрации изменений в планах обмена. Тестирование производилось на 1С:Предприятие 8.3 (8.3.13.1513) Бухгалтерия 3.0

1 стартмани

21.09.2018    11741    188    o.kovalev    25    

Заполнение табличной части документа "Инвентаризация товаров на складе" по счетам МЦ.02, МЦ.03 и МЦ.04 по материально ответственному лицу для БП 2.0 / БП 3.0

Обработка документов Учет ТМЦ Учет ТМЦ v8::БУ БП2.0 БП3.0 БУ Абонемент ($m)

Заполнение табличной части документа "Инвентаризация товаров на складе" по счетам МЦ.02, МЦ.03 и МЦ.04 по материально ответственному лицу. Есть возможность инвентаризировать МЦ.02, МЦ.03 и МЦ.04 как вместе, так и каждый отдельно.

1 стартмани

18.08.2018    7501    44    prime9    7    

Заполнение по остаткам ТМЦ на складе Промо

Обработка документов Учет ТМЦ Учет ТМЦ v8::БУ БП3.0 БУ Абонемент ($m)

Заполнение по остаткам ТМЦ на складе для документа "Перемещение товаров" по указанным счетам 07.02.2015 Обработка исправлена. Теперь работает в БП 3.0 вне зависимости от способа оценки МПЗ (по средней или ФИФО)

1 стартмани

05.02.2015    15660    23    portal2011    3    

Учет лома металлов и шкур в БП 3.0 Проф и КОРП с корректным отражением НДС

Оптовая торговля Обработка документов Оптовая торговля v8::БУ БП3.0 Оптовая торговля, дистрибуция, логистика Россия БУ НДС Абонемент ($m)

Расширение для конфигурации Бухгалтерия предприятие Проф 3.0, позволяющее корректно отражать НДС при операциях с покупкой и продажей лома металла и шкур. Исправляют выявленные ошибки типовой конфигурации. Начиная с релиза 3.0.65.72 работает на версии КОРП !!!!

2 стартмани

09.07.2018    10526    37    Aleksey81    21    

Корректировка расчетов с контрагентами для Бухгалтерии 3.0

Обработка документов Дебиторская и кредиторская задолженность Дебиторская и кредиторская задолженность v8 v8::БУ БП3.0 Россия БУ Абонемент ($m)

Обработка помогает скорректировать остатки по документам расчета по выбранному контрагенту. Работает со счетами 60.01, 60.02, 62.01, 62.02.

1 стартмани

25.06.2018    5692    17    niko11s    1    

Замена КПС в движениях и реквизитах документов для ОС и МЗ. БГУ 1.0

Обработка документов Учет ОС и НМА Учет ОС и НМА v8 v8::БУ БГУ Государственные, бюджетные структуры Россия БУ Госбюджет Абонемент ($m)

Обработка заменяет КПС в документах по счетам 101.00, 104.00, 105.00 без их проведения.

1 стартмани

17.05.2018    8722    22    zadoy    13    

Реестр договоров для 1С:Бухгалтерии Промо

Обработка документов Обработка справочников Документооборот и делопроизводство Документооборот и делопроизводство v8 v8::БУ БП3.0 Россия БУ Абонемент ($m)

Реестр договоров для 1С:Бухгалтерии - дополнительная обработка для конфигурации "Бухгалтерия предприятия", версия 3.0

5 стартмани

28.10.2014    41102    63    RespectSoft    24    

Учет расходов на автотранспорт

Бухгалтерия Учет ОС и НМА Учет ТМЦ Обработка документов Учет ОС и НМА Учет ТМЦ v8 v8::БУ БП3.0 Россия БУ Абонемент ($m)

Расширение конфигурации для "Бухгалтерия Предприятия 3.0" позволяет вести учет расходов (приобретаемые услуги и списываемые материалы) в разрезе основных средств.

4 стартмани

15.05.2018    9958    16    rilmir    15    

Перенос ОС до 10000 на забалансовый учет для БГУ 1.0

Обработка документов Учет ОС и НМА Учет ОС и НМА v8 v8::БУ БГУ Государственные, бюджетные структуры Россия Госбюджет Абонемент ($m)

Обработка позволяет массово перенести ОС, принятые к учету до 1 января 2018 года, стоимостью до 10000 рублей, с балансового на забалансовый учет.

1 стартмани

10.05.2018    21106    54    CAIN    18    

Загрузка зарплатных документов из ЗУП 3.1 в БП 2.0

Зарплата Перенос данных из 1C8 в 1C8 Обработка документов Зарплата v8 v8::БУ БП2.0 Россия БУ Абонемент ($m)

Загрузка в 1С8 БП 2.0 из ЗУП 3.1 документов: отражение зарплаты и ведомость на выплату зарплаты через банк и кассу.

1 стартмани

24.04.2018    6344    23    ruslan42    14    

Перенумерация документов Промо

Обработка документов v8 v8::БУ БП2.0 Россия БУ Абонемент ($m)

Обработка перенумеровывает документы выбранные Вами, с номера который установлен в левом нижнем углу. Добавлена возможность создания номера с префиксом.

2 стартмани

10.04.2012    12097    30    gen1024    34    

Исправление пустых значений субконто (Null, Неопределено) в проводках, возникающих при изменении настройки видов субконто на счете

Обработка документов v8 v8::БУ БП3.0 Россия БУ Абонемент ($m)

Обработка для исправления пустых значений субконто (Null, Неопределено) в проводках, возникающих при изменении настройки видов субконто на счете.

1 стартмани

23.04.2018    4975    33    tezin    4    

Замена ссылок на документы расчетов с контрагентом после свертки базы бухгалтерии

Свертка базы Обработка документов v8 v8::БУ БП3.0 Абонемент ($m)

Как окончательно избавиться от груза прошлых лет после свертки конфигурации Бухгалтерия 3.0? Данная обработка позволит вам автоматизировать процесс замены ссылок с документов прошлых лет на документ расчетов с контрагентом.

2 стартмани

16.04.2018    7962    52    insurgut    14    

Групповое перепроведение Закрытия месяца в Бухгалтерии 3.0

Закрытие периода Закрытие периода Обработка документов Закрытие периода v8 v8::БУ БП3.0 Россия БУ Абонемент ($m)

Обработка пригодится для тех, кто закрывает несколько месяцев подряд. В стандартной вы делаете закрытие одного месяца, потом переходите к следующему. В данной обработке вы указываете период, за который вам необходимо провести закрытие месяца.

1 стартмани

09.04.2018    9417    35    sambush    8    

Закрытие отрицательных остатков на 41 и 10 счете (БП 3.0 и Бух 7.7)

Обработка документов Закрытие периода Закрытие периода Учет ТМЦ Закрытие периода Учет ТМЦ v8 v77::БУ v8::БУ 1С7:Бух БП3.0 БУ Абонемент ($m)

Предлагаемые обработки позволят сформировать документ "Поступление товаров и материалов" по отрицательным остаткам ТМЦ (счета 41 и 10) за выбранный период. Для БП 3.0 и Бух 7.7.

1 стартмани

02.04.2018    14865    86    Ant10    0    

Автоматическое отражение документов в регламентированном учете

Обработка документов v8::БУ ERP2 КА2 БУ Абонемент ($m)

Расширение для автоматического отражения документов в регламентированном учете.

2 стартмани

29.03.2018    7747    25    zavladaev    18    

Заполнение документа Требование-накладная остатками на складе с фильтром по счету (Расширение для БП 3.0)

Обработка документов Учет ТМЦ Учет ТМЦ v8 v8::БУ БП3.0 Россия БУ Абонемент ($m)

Расширение конфигурации для БП 3.0. Суть - заполнить табличную часть остатками на складе, с указанием счета учета остатков.

1 стартмани

21.03.2018    5851    19    Guyer    9    

Отладка отражения в регламентированном учете (формирования проводок)

Обработка документов v8 v8::БУ 1cv8.cf БУ НУ Абонемент ($m)

Переформировать проводки бух. учета для документа в базе 1С или отладить код программисту если есть ошибки в дополнительном коде создания проводок. Обработка вызывает формирование проводок документа напрямую, что дает возможность остановиться в конфигураторе на ошибке или точке останова (без дополнительных действий по установке документа к отражению и подключению отладки фоновых заданий).

1 стартмани

17.03.2018    11327    12    sapervodichka    5