Скачивание обновлений 1C 8, 7.7, Айлант ЖКХ

Публикация № 275151

Администрирование - Администрирование данных 1С

обновление

Конфигурация для скачивания и установки обновлений 1С 8. Также может скачивать обновления для 1С 7.7, Айлант ЖКХ.

Данная конфигурация скачивает все доступные обновления с сайтов:

  • https://releases.1c.ru/ (Обновления 1С предприятие 8)
  • http://techsupp.1c.ru/ (Обновления 1С предприятие 7.7)
  • http://ujkh.ru/ (Айлант ЖКХ)
  • http://1c-osa.ru/ (Отраслевая сервисная автоматизация)
Версии начинают скачиваться с даты, указанной в настройке (для каждой конфигурации можно указать свою дату).
 
Есть возможность искать в файле Reedme информацию по требуемой платформе (касается только https://releases.1c.ru ). При данной настройке в путь сохранения скачанного файла добавляется редакция платформы (8.2, 8.3). Для каждой конфигурации редакцию платформы можно указать вручную. 
 
В конфигурацию встроена обработка построения цепочки обновлений с релиза  (с учетом возможности обновления с редакции на редакцию), в которой можно скачать обновления (в папку установленную в настройках) или просто скачать и установить обновления только на текущем компьютере.
 
 
 Изменения в версиях

Скачать файлы

Наименование Файл Версия Размер
Загрузка обновлений v1.0.4.6

.cf 1,12Mb
55
.cf 1.0.4.6 1,12Mb 55 Скачать

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. ankorobov 08.07.14 19:45 Сейчас в теме
https://users.v8.1c.ru/ (Обновления 1С предприятие 8) не работает
2. qwinter 628 08.07.14 20:41 Сейчас в теме
(1) olesha, очередное обновление сайта от 1с)) обновите процедуру в общем модуле UPD_ЗагрузкаКонфигураций:
Процедура РекурсивныйПарсингСпискаКонфигураций(ДокументHTML)

	ТекИмяГруппы = "";
	
	Для Каждого ЭлДок Из ДокументHTML.ДочерниеУзлы Цикл
		
		Если СокрЛП(ЭлДок.ТекстовоеСодержимое) = "Название" Тогда
			
			//количество строк в таблице дистрибутивов
			СписокУзловHTML = ЭлДок.РодительскийУзел.РодительскийУзел.РодительскийУзел.ДочерниеУзлы[1].ДочерниеУзлы;
			КолЭлементов = СписокУзловHTML.Количество();
			
			Для А=0 По КолЭлементов-1 Цикл
					
				Если СписокУзловHTML[А].ДочерниеУзлы.Количество() = 1 Тогда
					ТекИмяГруппы = СокрЛП(СписокУзловHTML[А].ДочерниеУзлы[0].ДочерниеУзлы[0].ТекстовоеСодержимое);	
					Группа = НайтиСоздатьГруппу(ТекИмяГруппы, Справочники.UPD_Программы.v8, Истина);
				ИначеЕсли СписокУзловHTML[А].ДочерниеУзлы.Количество() = 2 Тогда
					ТекИмяГруппы = СокрЛП(СписокУзловHTML[А].ДочерниеУзлы[0].ДочерниеУзлы[0].ТекстовоеСодержимое);	
					Группа = НайтиСоздатьГруппу(ТекИмяГруппы, Справочники.UPD_Программы.v8, Истина);	
				КонецЕсли;
				
				Если СписокУзловHTML[А].ДочерниеУзлы[0].ДочерниеУзлы.Количество() > 1 Тогда
					ТекЯчейка = СписокУзловHTML[А].ДочерниеУзлы[0].ДочерниеУзлы[1];
					Если ТипЗнч(ТекЯчейка) = Тип("ЭлементЯкорьHTML") Тогда
						
						Название = СокрЛП(ТекЯчейка.ТекстовоеСодержимое);
						ГиперСсылка = НайтиИмяФайлаПоСсылке(ТекЯчейка.ГиперСсылка);
						
						НайтиСоздатьПрограмму(Название, Группа, ГиперСсылка, ,Перечисления.UPD_СайтОбновлений.UsersV81C, ТекИмяГруппы);
						
					КонецЕсли;
				КонецЕсли;
			КонецЦикла;
			Возврат;
		КонецЕсли;
			
		Если ЭлДок.ЕстьДочерниеУзлы() Тогда
			
			РекурсивныйПарсингСпискаКонфигураций(ЭлДок);
			
		КонецЕсли;
		
	КонецЦикла;
	
КонецПроцедуры
Показать
ankorobov; BigB; +2 Ответить
3. ankorobov 09.07.14 16:57 Сейчас в теме
4. maksa2005 336 10.12.14 19:03 Сейчас в теме
А бесплатно можно скачать обновление или нужен логин и пароль?
EvgenURNN; +1 Ответить
5. qwinter 628 10.12.14 19:36 Сейчас в теме
(4) maksa2005, нужен логин и пароль.
6. CheBurator 3439 10.12.14 20:46 Сейчас в теме
а обработка скачивает только минимально необходимый набор обновлений от текущей конфигурации (как задать версию?) до актуальной? - например - купил я коробку БП3 корп - в ней диск с весрийе аж в районе февраля - ручками пришлось скачивать все (миниамльно необходимые) обновления - 10 штук (обновлений же гораздо больше...).
???
7. qwinter 628 10.12.14 21:10 Сейчас в теме
(6) CheBurator,
программа скачивает с указанной в настройках даты. Для каждой конфигурации можно указать свою дату начала скачивания. Соответственно скачиваться будут только релизы, которые вышли позже указанных дат.

P.S. Данное касается естественно только релизов с users.v8.1c.ru, т.к. на остальных сайтах или нет полного списка релизов.
8. pallid 16.12.14 11:17 Сейчас в теме
Как работает скачивание 7.70 конфигураций?
Их нет в списке...
9. qwinter 628 16.12.14 12:07 Сейчас в теме
(8) white_sochi, вводите пароль от http://techsupp.1c.ru в настройках. Затем обновляете список программ. После можно установить, что будет загружаться.
_LkMaksimka_; +1 Ответить
10. zato1c 04.08.15 14:21 Сейчас в теме
11. qwinter 628 04.08.15 14:33 Сейчас в теме
(10) zato1c, обрадовало нас 1С обновленным сайтом)) Обновление будет сегодня-завтра.
12. qwinter 628 04.08.15 17:42 Сейчас в теме
13. zato1c 05.08.15 11:04 Сейчас в теме
(12) эх только $ потратил, все равно не пашет, https://releases.1c.ru/ да же не показывает Релизы 8x втабл части, хотя выбор в настройках сайт появился!
14. qwinter 628 05.08.15 11:21 Сейчас в теме
(13) zato1c, действительно ошибка в получение конфигураций.

В общем модуле: "UPD_ЗагрузкаКонфигураций" в процедуре "РекурсивныйПарсингСпискаКонфигураций"

Если СокрЛП(ЭлДок.ТекстовоеСодержимое) = "Название" Тогда
			
			//количество строк в таблице дистрибутивов
			СписокУзловHTML = ЭлДок.РодительскийУзел.РодительскийУзел.РодительскийУзел.ДочерниеУзлы[1].ДочерниеУзлы;
			КолЭлементов = СписокУзловHTML.Количество();
			
			Для А=0 По КолЭлементов-1 Цикл
					
				Если СписокУзловHTML[А].ДочерниеУзлы.Количество()=1 ИЛИ СписокУзловHTML[А].ДочерниеУзлы.Количество()=2 Тогда
					ТекИмяГруппы = СокрЛП(СписокУзловHTML[А].ДочерниеУзлы[0].ДочерниеУзлы[0].ТекстовоеСодержимое);	
					Группа = НайтиСоздатьГруппу(ТекИмяГруппы, Справочники.UPD_Программы.v8, Истина);
Показать

Замените на:
Если СокрЛП(ЭлДок.ТекстовоеСодержимое) = "Название" Тогда
			
			//количество строк в таблице дистрибутивов
			СписокУзловHTML = ЭлДок.РодительскийУзел.РодительскийУзел.РодительскийУзел.ДочерниеУзлы[2].ДочерниеУзлы;
			КолЭлементов = СписокУзловHTML.Количество();
			
			Для А=0 По КолЭлементов-1 Цикл
					
				Если СписокУзловHTML[А].ДочерниеУзлы.Количество() = 1 ИЛИ СписокУзловHTML[А].ДочерниеУзлы.Количество() = 2 Тогда
					ТекИмяГруппы = СокрЛП(СписокУзловHTML[А].ДочерниеУзлы[0].ТекстовоеСодержимое);	
					Группа = НайтиСоздатьГруппу(ТекИмяГруппы, Справочники.UPD_Программы.v8, Истина);
Показать
15. zato1c 05.08.15 12:03 Сейчас в теме
{Справочник.UPD_Программы.Форма.ФормаЭлемента.Форма(37)}: Значение не является значением объектного типа (Ссылка)
СтруктураВозвращаемыхДанных = ПолучитьТекстНовогоВВерсии(Элементы.Версии.ТекущиеДанные.Ссылка);
там так и потянется. ладно не замарачивайся, а вот если бы вот это подшаманил (если смог бы), было бы респект http://infostart.ru/public/287082/ видно хозяин пропал, а весЧ не плоха
16. qwinter 628 05.08.15 12:12 Сейчас в теме
(15) zato1c, замените процедуру.
&НаКлиенте
Процедура ВерсииПриАктивизацииСтроки(Элемент)
	
	ТекДанные = Элементы.Версии.ТекущиеДанные;
	Если ТекДанные <> Неопределено Тогда
		СтруктураВозвращаемыхДанных = ПолучитьТекстНовогоВВерсии(.Ссылка);
		Если СтруктураВозвращаемыхДанных.ФайлНайден Тогда
			Элементы.НовоеВВерсии.Видимость = Истина;
			НовоеВВерсии = СтруктураВозвращаемыхДанных.ТекстНовоеВВерсии;
		Иначе
			Элементы.НовоеВВерсии.Видимость = Ложь;
		КонецЕсли;
	КонецЕсли;
	
КонецПроцедуры
Показать
17. qwinter 628 05.08.15 12:16 Сейчас в теме
(15) zato1c, моя конфа значительно превосходит эту обработку.
18. qwinter 628 05.08.15 12:19 Сейчас в теме
блин в предыдущем посте ошибка. Вот правильный код.
&НаКлиенте
Процедура ВерсииПриАктивизацииСтроки(Элемент)
    
    ТекДанные = Элементы.Версии.ТекущиеДанные;
    Если ТекДанные <> Неопределено Тогда
        СтруктураВозвращаемыхДанных = ПолучитьТекстНовогоВВерсии(ТекДанные.Ссылка);
        Если СтруктураВозвращаемыхДанных.ФайлНайден Тогда
            Элементы.НовоеВВерсии.Видимость = Истина;
            НовоеВВерсии = СтруктураВозвращаемыхДанных.ТекстНовоеВВерсии;
        Иначе
            Элементы.НовоеВВерсии.Видимость = Ложь;
        КонецЕсли;
    КонецЕсли;
    
КонецПроцедуры
Показать
19. zato1c 05.08.15 13:00 Сейчас в теме
Вроде начал крутится, по наблюдаем, спасибо за ранее!
20. zato1c 05.08.15 15:00 Сейчас в теме
Скачал пару релизов и сказал, что все задания выполнены, так что увы!
21. qwinter 628 05.08.15 15:14 Сейчас в теме
(20) zato1c, а Вы точно все настроили?))) Проверьте даты начала загрузок.
22. zato1c 06.08.15 13:43 Сейчас в теме
Сутки крутил. Итог бухгалтерия и зуп нет! как 8,2 так 8,3 все перебрал. Было бо не плохо прописывать пути кача релизов. Люди привыкли к определенному порядку. ну и для гурманов) оповещение на @ хотя бы, что вышло и с качалось(это так на всякий))
23. qwinter 628 06.08.15 14:43 Сейчас в теме
(22) zato1c, я не понимаю, что именно у вас вызывает такие проблемы с настройкой. У меня все прекрасно скачивается. Да и пути тоже можете прописывать какие хотите.
Прикрепленные файлы:
24. zato1c 07.08.15 14:19 Сейчас в теме
молодец конечно, что написал. Но как то все живет отдельной жизнью, что качает, сколько качает, ХЗ
25. AvtoBuhgalter 123 24.09.15 06:31 Сейчас в теме
Возник такой вопрос:
Я не Франч и общего доступа к сайту обновлений нет.
Есть доступ у различных клиентов к разным конфигурациям. Т.е. к одному и тому же сайту обновлений нужна привязка какую конфигурацию под каким пользователем нужно качать.
Есть такая возможность? Или возможно ли её реализовать?
26. qwinter 628 24.09.15 07:46 Сейчас в теме
(25) AvtoBuhgalter, есть возможность ввести несколько пользователей. Для каждого пользователя будут качаться доступные ему обновления.
27. pallid 14.10.15 17:34 Сейчас в теме
Обработка UPD_ПостроениеЦепочкиОбновлений

СТР 77

ПутьКФайлу = ЭлементСписка.Значение + "\1c\" + ИмяПапкиШаблона + "\" + ИмяВерсии + "\1cv8.cfu";


строка "\1с\" не во всех случаях такая, например у отраслевой БСО, должно быть "\IMPULS-IVC\"
28. qwinter 628 14.10.15 18:59 Сейчас в теме
(27) white_sochi, если подскажите, где это можно в автоматическом режиме взять с сайта релизов 1с буду благодарен.
29. pallid 15.10.15 10:21 Сейчас в теме
(28) а вот нигде к сожалению.
Давайте в справочнике просто всем типовым проставим директорию "1С", а остальным, чтобы пользователь сам указывал где искать
30. qwinter 628 15.10.15 20:24 Сейчас в теме
(29) white_sochi, так и сделаем) напишите почту свою, я вам обновленную версию вышлю.
31. Snork 312 21.07.16 13:51 Сейчас в теме
Можно добавить еще скачивание релизов КАМИН?
Сайт:
http://www.kaminsoft.ru/component/kaminsupport/?Itemid=50
33. qwinter 628 23.07.16 11:31 Сейчас в теме
(31) Snork, у меня нет ни одной учетной записи камина, что бы даже посмотреть как там устроено.
32. Snork 312 22.07.16 12:25 Сейчас в теме
В отчете по последним версиям не хватает режима, когда выводит только измененные за последние Х дней конфигурации
34. qwinter 628 23.07.16 11:31 Сейчас в теме
(32) Snork, так можно поставить отбор))
35. EvgenURNN 95 31.08.16 14:39 Сейчас в теме
при попытке развернуть с пустой базы 1.0.3.6. пытается вполнить обновление (похоже на то, что там начальное заполнение) выдает ошибку
{ОбщийМодуль.UPD_ОбновлениеБазыДанных.Модуль(209)}: Ошибка при вызове метода контекста (ПрочитатьXML)
ЗаписанноеЗначение = ПрочитатьXML(ЧтениеXML);
по причине:
Ошибка преобразования данных XML: [sfile://C:/Users/Evgenu/AppData/Local/Temp/UPD_КонфигурацииИВерсииV8.txt][202566,3]

Версия платформы 1С:Предприятие 8.3 (8.3.8.1933)
36. qwinter 628 31.08.16 22:43 Сейчас в теме
(35) EvgenURNN, странно. Попробуйте на 8.3.5 развернуть начальный вариант.
37. EvgenURNN 95 07.09.16 17:54 Сейчас в теме
(36) Поразбирался маленько, ошибка из-за того, что в конфигурации больше реквизитов: ПорядокГруппы, ВыводитьВОтчет и КаталогПоставщика. В макете нет таких реквизитов. Сериализатор валится с ошибкой из-за этого.
Сейчас все работает.
38. Alex_E 2182 22.09.16 08:32 Сейчас в теме
(35) EvgenURNN, Та же ошибка, скачал и установил сегодня.... Автор, исправлять бум?
39. qwinter 628 22.09.16 10:09 Сейчас в теме
(38) Alex_E, будем). просто хотел и все версии обновить в начальном заполнении, но все руки не доходят. Если срочно лечится очень просто. У справочника UPD_Программы удаляете реквизит КаталогПоставщика. И в общем модуле UPD_ОбновлениеБазыДанных в функции ВерсияКонфигурации устанавливаете версию 1.0.3.5. Запускаете 1С. Как прошло начальное заполнение накатываете конфигурацию.
40. Alex_E 2182 22.09.16 10:14 Сейчас в теме
41. qwinter 628 22.09.16 14:24 Сейчас в теме
(40) Alex_E, все поправил) если еще сами не делали напишите почту, я вам вышлю конфигурацию.
43. SERJ_1CC 48 17.11.16 08:33 Сейчас в теме
(41) qwinter, Павел, Ваша конфигурация сейчас работает или нет, а то что-то не понятно по отзывам, вроде опять что-то поменялось на сайте 1С?
44. qwinter 628 17.11.16 20:21 Сейчас в теме
(43) SERJ_1CC, работает, проблемы только у тех, кто использует несколько логинов к сайту релизов.
45. SERJ_1CC 48 18.11.16 07:29 Сейчас в теме
(44) qwinter, Понял, спасибо, сегодня скачаю посмотрю, а вообще я имел ввиду то что сайт releases.1c.ru сейчас переделали и что теперь скачивание обновлений идет с https://dl03.1c.ru
46. SERJ_1CC 48 18.11.16 07:37 Сейчас в теме
(45) я же Вас правильно понимаю, конфигурация парсит сайт и вытягивает файлы обновлений updsetup.exe без сторонних исполняемых компонент?
47. qwinter 628 18.11.16 13:55 Сейчас в теме
(46) SERJ_1CC,
а вообще я имел ввиду то что сайт releases.1c.ru сейчас переделали и что теперь скачивание обновлений идет с https://dl03.1c.ru
все работает.
я же Вас правильно понимаю, конфигурация парсит сайт и вытягивает файлы обновлений updsetup.exe без сторонних исполняемых компонент?
исключительно код 1С
42. Aprsoft 14.11.16 13:01 Сейчас в теме
Есть две проблемы в версии 1.0.3.7:
1. У нас не работает обновление справочника версий. Проблема насколько я понял таиться в модуле "UPD_ЗагрузкаОбновленийV8"
Функция ЗагрузитьКонфигурации(ПользовательСайта) Экспорт
	
	ИдентификаторСессии = UPD_ЗагрузкаОбновленийПовтИсп.НайтиИдентификаторСессииV8(ПользовательСайта);
	
	Попытка
		
		Загружено = 0;
		Запрос = Новый HTTPЗапрос;
		Запрос.Заголовки.Вставить("Cookie", ИдентификаторСессии.JSESSIONID);
		Запрос.АдресРесурса = "/total";
		
		Соединение2 = Новый HTTPСоединение("releases.1c.ru",,,,Новый ИнтернетПрокси,,Новый ЗащищенноеСоединениеOpenSSL);
		
		ОтветHTTP = Соединение2.Получить(Запрос);
		
		ЧтениеHTML = Новый ЧтениеHTML;
		ЧтениеHTML.УстановитьСтроку(ОтветHTTP.ПолучитьТелоКакСтроку());
		
		Построитель = Новый ПостроительDOM;
		ДокументHTML = Построитель.Прочитать(ЧтениеHTML);
		
		ИскатьВерсиюПлатформы = Константы.UPD_ИскатьТребуемуюВерсиюПлатформы.Получить();
		
		Если ИскатьВерсиюПлатформы Тогда
			РекурсивныйПарсингСпискаКонфигураций(ДокументHTML, ИскатьВерсиюПлатформы, ПользовательСайта);
		Иначе
			РекурсивныйПарсингСпискаКонфигураций(ДокументHTML); //АС: Здесь наверное не хватает параметра "ПользовательСайта" 
		КонецЕсли;

		ЗагрузитьВерсииV8(ПользовательСайта);
		
	Исключение
		
		UPD_РегламентныеЗадания.ЗаписатьОшибку(ОписаниеОшибки());
		Возврат Ложь;
		
	КонецПопытки;
	
	Возврат Истина;
	
КонецФункции
Показать


2. Если используется несколько пользователей для загрузки с сайта "releases.1c.ru", то выполнение кода падает с ошибкой неуникальности ключа фоновых заданий. Поэтому ключ нужно или генерировать случайный, или в разрезе пользователей сайта. А вообще лучше сначала построить список доступных ПП по разным пользователям, а уже потом парсить версии. У разных пользователей могут быть одинаковые ПП в списке. Проблемы начинаются при параллельной записи в базу новых ПП, доступ к которым есть у двух пользователей.
48. Snork 312 10.04.17 12:15 Сейчас в теме
Что-то не работает последние 20 дней загрузка. Пароли проверил-ок. Использую и https://releases.1c.ru/, и
http://techsupp.1c.ru/ с одинаковыми логинами и паролями
Куда копать?
49. qwinter 628 10.04.17 14:24 Сейчас в теме
(48) пришлите в личку вашу почту, я вам последнюю версию скину.
50. demon3 13.10.17 11:50 Сейчас в теме
Здравствуйте. Не всегда скачивает обновления и список текущих релизов не загружает. Как правильно пользоваться данной конфигурацией?
51. qwinter 628 13.10.17 12:16 Сейчас в теме
(50) Что значить "не всегда"? Доступ к сайту https://releases.1c.ru/ есть?
52. Aprsoft 30.10.17 14:50 Сейчас в теме
Лично я просто сам допилил что не так.
Во-первых, при обновлении справочника версий идёт просмотр информации по всем имеющимся версиям ради того, чтобы узнать отозван релиз или нет. Большая часть выполнения, на мой взгляд, это бесполезная процедура. У нас я ограничил глубокий анализ последними пятью версиями. Мне пофиг, если вдруг релиз полугодовалой давности вдруг станет отозванным. На самом деле такого никогда не будет. А чтобы максимально исключить вероятность установки такого релиза нужно строить цепочку обновления с целевого релиза, а не с текущего.
Во-вторых. В данной разработке не оптимально производится многопоточный парсинг версий в случае, когда есть несколько пользователей к одному и тому же сайту, в нашем случае releases.1c, и список доступных ПП у них пересекается. К автору претензий нет, это наша особенность и здесь нужно ещё хорошо подумать как это сделать. Если автору интересно, могу поделиться опытом в реализации.
В-третьих, иногда получаются слишком длинные полные наименования файлов, особенно у каких-нибудь внешних печатных форм. Жёстко ограничивать длину не совсем правильно, так как не всегда есть в этом необходимость. Не ограничивать тоже нельзя, так как файл просто не запишется на диск.Сделал анализ именно полного имени файла и при необходимости пишу имя файла оригинальное, а не русское.
В-четвёртых. 1С постоянно что-то меняет, Поспеть за всем этим сложно. Например, раньше на странице релиза был такой пункт "Новое в версии", а теперь этот пункт называется "Бухгалтерия предприятия, редакция 3.0. Версия 3.0.53.39. Новое в версии". Следовательно просмотр файла в форме программного продукта сломался. Я вышел из ситуации универсиализировав код. Или имя файла на сайте было "news" а стало "Novoe_v_versii". Ой.. а в коде есть ограничение на эту тему. А бывают более серьёзные изменения на сайте.
Короче итог: то что вообще есть данная разработка это хорошо, это хорошая основа для дальнейшего развития. В простых типовых условиях она работает. Если что-то не работает, то попробуйте понять почему, и если это просто исправить, то лучше сами исправьте, и автору напишите что именно не работает.
Что реально хотелось бы увидеть в разработке:
В какой-то момент были реальные косяки с загрузкой, причину установить удалось только у части ПП. 1С имеет свойство ещё и переименовывать ПП на сайте, объединять разные редакции в одну позицию. В автоматическом режиме отследить это нереально. Но если отследить это не сложно, то вот потом выправлять руками данные в базе как-то не айс. К примеру, была конфигурации "Документооборот 2.0", "Документооборот 2.1", а теперь просто ""Документооборот 2" и всё в одном. В базе наплодились версии на все три программных продукта. Для наведения порядка нужно:
1. Удалить все версии ""Документооборот 2".
2. Сменить владельца у двух старых программных продуктов на новый. На этих версиях уже много чего завязано.
3. Сделать замену всех ссылок старых программных продуктов на ссылку нового программного продукта.
Разделил на 3 этапа, так как делается это универсальными обработками. После этого нужно включить загрузку нового ПП.
Было бы неплохо, если бы эти все действия можно было сделать какой-то специальной обработкой, которая будет это делать в фоновом режиме.
53. Tiger77 69 13.11.17 17:33 Сейчас в теме
1с немного поменяла форму авторизации login.1c.ru и поля Куки на releases.1c.ru
54. DIMon_ru 2 31.01.18 18:43 Сейчас в теме
День добрый.
Почему то версии обновлений в справочнике заканчиваются 2016 годом, нет за 2017 и 2018, версия устаревшая?
Прикрепленные файлы:
55. qwinter 628 01.02.18 09:53 Сейчас в теме
(54) так добавьте пользователя портала и обновите)
56. DIMon_ru 2 06.02.18 13:11 Сейчас в теме
(55) День добрый.
Пользователя конечно что же добавил, под ним на users.v8.1c.ru захожу. Через программу не обновляет версии...
Если же снять галку Использовать фоновые задания то ошибка... как быть, может версия не совсем новая? Установлена Загрузка обновлений 1C 8, 7.7, Айлант ЖКХ (1.0.3.10)
Прикрепленные файлы:
57. qwinter 628 06.02.18 15:08 Сейчас в теме
(56) напишите мне в личку от пользователя под которым скачивали. Я вам пришлю обновленный cf
58. DIMon_ru 2 08.02.18 12:08 Сейчас в теме
(57) Павел, cf получили, обновили конфу, спасибо. Но что то не пойму как получаются даты обновлений, интересует Бухгалтерия 3.0 обычная, по ней почему то на 2016 году все остановилось, а вот по Бухгалтерии КОРП все ОК, свежее 2018 года. В чем может быть дело?
Прикрепленные файлы:
59. DIMon_ru 2 08.02.18 14:10 Сейчас в теме
(58) Похоже долго идут фоновые задания... терпения надо много)))
60. qwinter 628 08.02.18 21:01 Сейчас в теме
(59) первый раз действительно не быстро))
61. Aprsoft 22.02.18 14:20 Сейчас в теме
Загрузка файлов перестала работать. Вместо файлов сохраняется страница авторизации. На сайте что-то поменялось.
62. qwinter 628 07.03.18 16:09 Сейчас в теме
(61) в модуле UPD_СлужебныйКлиентСервер вместо
ИдентификаторСессии = UPD_ЗагрузкаОбновленийКлиентСерверПовтИсп.НайтиИдентификаторСессииV8(Пользователь, Соединение.Сервер);

ИдентификаторСессии = UPD_ЗагрузкаОбновленийКлиентСерверПовтИсп.НайтиИдентификаторСессииV8(Пользователь, Соединение.Сервер, Запрос.АдресРесурса);

в модуле UPD_ЗагрузкаОбновленийКлиентСерверПовтИсп вместо
Функция НайтиИдентификаторСессииV8(ПользовательСайта, АдресСайта = "releases.1c.ru") Экспорт		
	
	ИдентификаторСессии = Новый Структура("Найден, JSESSIONID, onec_security", Ложь);

	Сессии = Новый Соответствие;
	
	Попытка
			
		HTTPЗапрос1 = Новый HTTPЗапрос;
		HTTPЗапрос1.Заголовки.Вставить("Connection", "keep-alive");
Показать

Функция НайтиИдентификаторСессииV8(ПользовательСайта, АдресСайта = "releases.1c.ru", АдресРезурса = "") Экспорт		
	
	ИдентификаторСессии = Новый Структура("Найден, JSESSIONID, onec_security", Ложь);

	Сессии = Новый Соответствие;
	
	Попытка
			
		HTTPЗапрос1 = Новый HTTPЗапрос;
		HTTPЗапрос1.Заголовки.Вставить("Connection", "keep-alive");
		HTTPЗапрос1.АдресРесурса = АдресРезурса;
Показать
71. Solemn 04.05.18 11:47 Сейчас в теме
(62)
торСессииV8(Пользователь, Соедине


Работает 30.03.18

Не работает 04.05.18 :)
63. markovki 19 19.04.18 11:33 Сейчас в теме
Доброе время суток! Заранее прошу прощения, но не могли бы вы помочь?
Использую другую конфигурацию (от автора Alexandr Kuritsyn (hibico)) для скачивания файлов updsetup.exe.
Со скачиванием проблема, немного поправил и сделал так:
HTTPЗапрос1 = Новый HTTPЗапрос;
		HTTPЗапрос1.Заголовки.Вставить("Connection", "keep-alive");
		// определение для POST-запросов
		HTTPЗапрос2 = Новый HTTPЗапрос;
		HTTPЗапрос2.Заголовки.Вставить("Connection", "keep-alive");
		HTTPЗапрос2.Заголовки.Вставить("Content-Type", "application/x-www-form-urlencoded");
		// определим соединения
		Соединение1 = Новый HTTPСоединение("login.1c.ru",,,,Новый ИнтернетПрокси,,Новый ЗащищенноеСоединениеOpenSSL);
		//Соединение2 = Новый HTTPСоединение("portal.1c.ru",,,,Новый ИнтернетПрокси,,Новый ЗащищенноеСоединениеOpenSSL);
		Соединение2 = Новый HTTPСоединение("releases.1c.ru",,,,Новый ИнтернетПрокси,,Новый ЗащищенноеСоединениеOpenSSL);
		//Соединение3 = Новый HTTPСоединение("downloads.v8.1c.ru",,Логин,Пароль,,,);
		Соединение3 = Новый HTTPСоединение("dl03.1c.ru",,,,Новый ИнтернетПрокси,,Новый ЗащищенноеСоединениеOpenSSL);
		//Соединение4 = Новый HTTPСоединение("dl03.1c.ru",,Логин,Пароль,,,);
		// Запрос 1
		HTTPЗапрос1.АдресРесурса = "/total";
		ОтветHTTP1 = Соединение2.Получить(HTTPЗапрос1);  				// =1=  releases.1c.ru
		JSESSIONID = ОтветHTTP1.Заголовки.Получить("Set-Cookie");
		JSESSIONID = Лев(JSESSIONID, Найти(JSESSIONID, ";") - 1);
		LOCATION1 = СтрЗаменить(ОтветHTTP1.Заголовки.Получить("Location"), "https://login.1c.ru", "");
		// Запрос 2
		HTTPЗапрос1.АдресРесурса = LOCATION1;
		ОтветHTTP2 = Соединение1.Получить(HTTPЗапрос1);  				// =2=  login.1c.ru
		JSESSIONID1 = ОтветHTTP2.Заголовки.Получить("Set-Cookie");
		JSESSIONID1 = Прав(JSESSIONID1, СтрДлина(JSESSIONID1) - Найти(JSESSIONID1, "SESSION") + 1);
		JSESSIONID1 = Лев(JSESSIONID1, Найти(JSESSIONID1, ";") - 1);
	    // получим inviteCode
		ЧтениеHTML = Новый ЧтениеHTML;
		ЧтениеHTML.УстановитьСтроку(ОтветHTTP2.ПолучитьТелоКакСтроку());
		Построитель = Новый ПостроительDOM;
		ДокументHTML = Построитель.Прочитать(ЧтениеHTML);
		
		loginForm = ДокументHTML.ПолучитьЭлементПоИдентификатору("loginForm");
		//inviteCode = "inviteCode=<=" 	+ loginForm.Элементы[1].Значение 
		//			+ "&execution=" 	+ loginForm.Элементы[2].Значение 
		//			+ "&_eventId=" 		+ loginForm.Элементы[3].Значение
		// 			+ "&username=" 		+ Логин 
		//			+ "&password=" 		+ Пароль;
		inviteCode = "inviteCode=<=" 	+ loginForm.Элементы[0].Значение 
					+ "&execution=" 	+ loginForm.Элементы[3].Значение 
					+ "&_eventId=" 		+ loginForm.Элементы[4].Значение
					+ "&username=" 		+ Логин 
					+ "&password=" 		+ Пароль;
		//Запрос 3
		//LOCATION1 = СтрЗаменить(LOCATION1, "releases", "portal");
		HTTPЗапрос2.АдресРесурса = LOCATION1;
		HTTPЗапрос2.Заголовки.Вставить("Cookie", JSESSIONID1);
		HTTPЗапрос2.УстановитьТелоИзСтроки(inviteCode);
		ОтветHTTP3 = Соединение1.ОтправитьДляОбработки(HTTPЗапрос2);  	// =3=  login.1c.ru
		LOCATION3 = СтрЗаменить(ОтветHTTP3.Заголовки.Получить("Location"), "https://releases.1c.ru", "");
		//Запрос 4
		HTTPЗапрос1.АдресРесурса = LOCATION3;
		HTTPЗапрос1.Заголовки.Вставить("Cookie", JSESSIONID);
		ОтветHTTP4 = Соединение2.Получить(HTTPЗапрос1);              	// =4=
		// инициируем ссылку на файл
		HTTPЗапрос2.Заголовки.Вставить("Cookie", JSESSIONID);
		HTTPЗапрос2.АдресРесурса = Адрес1;
		ОтветHTTP5 = Соединение2.ОтправитьДляОбработки(HTTPЗапрос2); 	// =5=
		
		Тело = ОтветHTTP5.ПолучитьТелоКакСтроку();
		НАдреса = Найти(Тело,"https://dl03.1c.ru");
		Адрес = Сред(Тело,НАдреса);
		КАдреса = Найти(Адрес,"""")-1;
		Адрес = Лев(Адрес,КАдреса);
		Адрес = СтрЗаменить(Адрес,"https://dl03.1c.ru","");
		
		СоздатьКаталог(ЛокКаталог);
		ОтветHTTP6 = Соединение3.Получить(Адрес,ЛокАдрес);
Показать

где Адрес это ссылка на файл вида "https://dl03.1c.ru/public/file/get/d616d9b8-7e48-11e5-863e-005056910018"
подскажите пожалуйста, как скачать этот файл updsetup.exe?
В ОтветHTTP6: код состояния 302, а в Location:
https://login.1c.ru/login?service=https%3A%2F%2Fdl03.1c.ru%2Fpublic%2Fsecurity_check
Можете подсказать в чем загвоздка, что-то пока плохо получается разобраться в запросах, не могу понять, что надо сделать дальше, чтобы скачать файл?!
Заранее благодарю!
Если есть готовое решение, я конечно не откажусь, но одновременно хочется разобраться, хотя бы в общих принципах работы, в данном случае в принципах скачивания файла обновления updsetup.exe.
Почему например, когда я уже залогинился, вроде как, получил ссылку, а скачать по ссылке не получается.
64. qwinter 628 19.04.18 15:29 Сейчас в теме
(63)
Можете подсказать в чем загвоздка, что-то пока плохо получается разобраться в запросах, не могу понять, что надо сделать дальше, чтобы скачать файл?!
Надо залогиниться на dl03.1c.ru, а вы пытаетесь использовать куки логина на releases.1c.ru. Вам надо JSESSIONID1 получать из соединения с сервером dl03.1c.ru.
65. markovki 19 20.04.18 08:46 Сейчас в теме
(64) как же мне залогиниться на dl03.1c.ru, если на login.1c.ru мы используем форму с логином и паролем и посылаем POST-запрос (Если не ошибаюсь), понимаю, что вам это наверное покажется глупым, но на dl03.1c.ru такой формы то нет...
66. qwinter 628 20.04.18 11:29 Сейчас в теме
(65)
login.1c.ru это login.1c.ru.
releases.1c.ru это releases.1c.ru.

На releases.1c.ru формы ввода логина и пароля тоже нет)))) залогивание на dl03.1c.ru ничем не отличается от ввода логина на releases.1c.ru. Тот же пост запрос к login.1c.ru, только с куками полученными с dl03.1c.ru.
67. markovki 19 20.04.18 11:38 Сейчас в теме
(66) спасибо, сейчас попробую! Т.е. хорошо, здесь пока ясно, пробую запросить файл по ссылке, меня перенаправляет, на login.1c.ru, я беру куки которые были в ответе при попытке получить файл с сайта dl03.1c.ru и передаю их на login.1c.ru, на тот адрес куда меня перенаправили. Дальше мне опять получать форму и логиниться с этими куками от dl03.1c.ru?
Это вопрос номер 1.
А второй вопрос залогинился допустим, дальше как? Сразу пробовать получить файл с куками от dl03.1c.ru? Или какие-то ещё промежуточные действия?!))
68. qwinter 628 20.04.18 11:44 Сейчас в теме
(67) запрашиваешь страницу по ссылке на скачку на dl03.1c.ru, читаешь с нее куки. С этими куками отправляешь пост запрос к login.1c.ru полностью аналогичный как при логине с releases.1c.ru, т.к. сначала обычный запрос, оттуда читаешь форму и параметры, а затем уже пост запрос. А затем с этими куками запрашиваешь с dl03.1c.ru, там он если правильно помню несколько раз перенаправляет, т.е. если код ответа будет перенаправлением, то по реферальной ссылке надо будет еще запрашивать.
69. markovki 19 20.04.18 12:20 Сейчас в теме
(68) ок, с куками понял, попробую по такому алгоритму!
70. markovki 19 20.04.18 13:43 Сейчас в теме
(68) Всё-таки туплю с куками и перенаправлениями, сделал вот так после кода написанного выше:
т.е. пробуем запросить по ссылке, получаем куки, передаем их на страницу перенаправления логин1с, получаем форму, тут уже с разными куками пробовал, после залогинивания нас перенаправляют на https://releases.1c.ru/public/security_check?ticket=ST-605536-vQOOHdjUvBNrbXEGbWB7-login-tomcat1-gpt-msk
и тут опять непонятка, пробовал с полученными куками по перенаправлениям, что-то не то в итоге на главной релизес оказываюсь, а если с этими куками сразу на dl03, тогда опять отправляет на логин1С
// загрузим файл ================================================================================
		//СоздатьКаталог(ЛокКаталог);
		////ОтветHTTP6 = Соединение3.Получить(Адрес,ЛокАдрес);
		
		HTTPЗапрос1.АдресРесурса = Адрес;
		Ответ1 = Соединение3.Получить(HTTPЗапрос1);  				// =1=   https://dl03.1c.ru
		JSESSIONID = Ответ1.Заголовки.Получить("Set-Cookie");
		JSESSIONID = Лев(JSESSIONID, Найти(JSESSIONID, ";") - 1);
		LOCATION = СтрЗаменить(Ответ1.Заголовки.Получить("Location"), "https://login.1c.ru", "");
		
		HTTPЗапрос1.АдресРесурса = LOCATION;
		HTTPЗапрос1.Заголовки.Вставить("Cookie", JSESSIONID);
		Ответ2 = Соединение1.Получить(HTTPЗапрос1);  				// =2=  login.1c.ru
		JSESSIONID1 = Ответ2.Заголовки.Получить("Set-Cookie");
		JSESSIONID1 = Прав(JSESSIONID1, СтрДлина(JSESSIONID1) - Найти(JSESSIONID1, "SESSION") + 1);
		JSESSIONID1 = Лев(JSESSIONID1, Найти(JSESSIONID1, ";") - 1);
		
		//HTTPЗапрос1.АдресРесурса = Адрес;
		//HTTPЗапрос1.Заголовки.Вставить("Cookie", JSESSIONID1);
		//Ответ2 = Соединение3.Получить(HTTPЗапрос1);
		
		// получим inviteCode
		ЧтениеHTML = Новый ЧтениеHTML;
		ЧтениеHTML.УстановитьСтроку(ОтветHTTP2.ПолучитьТелоКакСтроку());
		Построитель = Новый ПостроительDOM;
		ДокументHTML = Построитель.Прочитать(ЧтениеHTML);
		loginForm = ДокументHTML.ПолучитьЭлементПоИдентификатору("loginForm");
		//inviteCode = "inviteCode=<=" 	+ loginForm.Элементы[1].Значение 
		//			+ "&execution=" 	+ loginForm.Элементы[2].Значение 
		//			+ "&_eventId=" 		+ loginForm.Элементы[3].Значение
		// 			+ "&username=" 		+ Логин 
		//			+ "&password=" 		+ Пароль;
					
		inviteCode = "inviteCode=<=" 	+ loginForm.Элементы[0].Значение 
					+ "&execution=" 	+ loginForm.Элементы[3].Значение 
					+ "&_eventId=" 		+ loginForm.Элементы[4].Значение
		 			+ "&username=" 		+ Логин 
					+ "&password=" 		+ Пароль;
					
		HTTPЗапрос2.АдресРесурса = LOCATION;
		HTTPЗапрос2.Заголовки.Вставить("Cookie", JSESSIONID1);
		HTTPЗапрос2.УстановитьТелоИзСтроки(inviteCode);
		ОтветHTTP3 = Соединение1.ОтправитьДляОбработки(HTTPЗапрос2);  	// =3=  login.1c.ru
		LOCATION3 = СтрЗаменить(ОтветHTTP3.Заголовки.Получить("Location"), "https://releases.1c.ru", "");
		//LOCATION3 = СтрЗаменить(ОтветHTTP3.Заголовки.Получить("Location"), "https://dl03.1c.ru", "");
		JSESSIONID2 = ОтветHTTP3.Заголовки.Получить("Set-Cookie");
		JSESSIONID2 = Прав(JSESSIONID2, СтрДлина(JSESSIONID2) - Найти(JSESSIONID2, "SESSION") + 1);
		JSESSIONID2 = Лев(JSESSIONID2, Найти(JSESSIONID2, ";") - 1);
		
		//HTTPЗапрос1.АдресРесурса = LOCATION1;
		HTTPЗапрос1.АдресРесурса = LOCATION3;
		HTTPЗапрос1.Заголовки.Вставить("Cookie", JSESSIONID2);
		//Ответ3 = Соединение3.Получить(HTTPЗапрос1);  				// =3=
		Ответ3 = Соединение2.Получить(HTTPЗапрос1);  				// =3=
		//LOCATION2 = СтрЗаменить(Ответ3.Заголовки.Получить("Location"), "https://dl03.1c.ru", "");
		LOCATION4 = СтрЗаменить(Ответ3.Заголовки.Получить("Location"), "https://releases.1c.ru", "");
		JSESSIONID3 = Ответ3.Заголовки.Получить("Set-Cookie");
		JSESSIONID3 = Прав(JSESSIONID3, СтрДлина(JSESSIONID3) - Найти(JSESSIONID3, "SESSION") + 1);
		JSESSIONID3 = Лев(JSESSIONID3, Найти(JSESSIONID3, ";") - 1);
		
		HTTPЗапрос1.АдресРесурса = Адрес;
		HTTPЗапрос1.Заголовки.Вставить("Cookie", JSESSIONID3);
		Ответ4 = Соединение3.Получить(HTTPЗапрос1);
Показать

Но в итоге он опять меня на логин.1с.ру отправляет
72. enschede 04.07.18 12:29 Сейчас в теме
Я правильно понимаю, что конфигурация умеет скачивать файлы update.exe?
73. qwinter 628 04.07.18 14:10 Сейчас в теме
74. enschede 04.07.18 14:53 Сейчас в теме
(73) А скачивать отдельные файлы, выкладываемые на странице конфигурации? Или насколько реалистично самостоятельно реализовать такой функционал на основе имеющегося?
75. qwinter 628 04.07.18 15:00 Сейчас в теме
(74) со странице конфигурации ничего не качается, со странице версии качаются файлы описанные в процедуре в одном из общих модулей.

Реализовать загрузку дополнительных материалов со страницы конфигурации не думаю, что будет очень сложно.
76. enschede 20.08.18 11:14 Сейчас в теме
Конфигурация не находит релизы, которые вышли в августе при выполнении команды "Обновить версии конфигураций". Для конфигурации БП 3.0 текущий релиз 3.0.64.48 от 15.08.18. В конфигурации только 3.0.64.34 от 24.07.2018. Для конфигурации БГУ 2.0 текущий релиз 2.0.57.26 от 10.08.18, в конфигурации 2.0.57.8 от 09.07.2018.
В базе указал пользователя для проверки и скачивания обновление и каталог обновлений в настройках. Больше ничего не делал.
77. enschede 20.08.18 12:28 Сейчас в теме
Скачивание релизов тоже не работает. В настройках указал дату начала скачивания обновлений "01.08.2999", чтобы не скачивались релизы всех конфигураций. Указал каталог обновлений. Добавил пользователя для проверки и скачивания обновлений. Уставонил значение "Загружать полные дистрибутивы" в Истина.
Для одной конфигурации указал свою дату загрузки обновлений "01.01.2018", чтобы скачались обновления только этой конфигурации. Также поставил галочку "Скачивать обновления". Выполняю команду "Загрузить", где-то на десять секунд запускается фоновое задание, выключается, никаких файлов не появляется.
78. qwinter 628 20.08.18 15:47 Сейчас в теме
(77) Одно из двух: или у пользователя нет доступа к обновлениям, или у 1С нет доступа в интернет.

P.S. Если база серверная, то пользователь у службы должен быть с доступом в инет.
79. enschede 20.08.18 21:46 Сейчас в теме
(78) Права точно есть, постоянно скачиваю под этим пользователем обновления. База файловая. Доступ в интернет должен быть, список релизов в конфигурациях же появился, хоть и не совсем актуальный. Я так понимаю, он скачивается с интернета.
80. qwinter 628 21.08.18 08:42 Сейчас в теме
(79) список релизов по конец июля входит в текущую конфигурацию.
81. qwinter 628 21.08.18 08:51 Сейчас в теме
(79) Если нет основного пользователя, то обновление версий идет только по конфигурациям где выставлен пользователь.
104. gedd 3 27.09.19 18:19 Сейчас в теме
Не работает

{ОбщийМодуль.UPD_ЗагрузкаОбновленийКлиентСервер.Модуль(81)}: Значение не является значением объектного типа (Сервер)
105. qwinter 628 27.09.19 19:00 Сейчас в теме
(104) работает. Вопросы по не работающей конфигурации задавайте там где вы ее скачали.
82. enschede 27.08.18 16:32 Сейчас в теме
Вот что смог выяснить, к сожалению, знания не позволяют мне выяснить больше.
Выполнение кода добирается до функции "ЗагрузитьВерсииV8ПоСсылке". Соединение выполняется (см. скриншот), ответ получен (см. скриншот), что говорит о наличии доступа в интернет.
Из функции "ЗагрузитьВерсииV8ПоСсылке" попадаем в процедуру "РекурсивныйПарсингСпискаВерсий". И здесь происходит что-то подозрительное. Выполняется получение первого элемента:
Для Каждого ЭлДок Из ДокументHTML.ДочерниеУзлы Цикл
Первое условие не выполняется:
Если СокрЛП(ЭлДок.ТекстовоеСодержимое) = "Номер версии" Тогда
Выполнение цикла тут же прекращается. Условие, которое идет следом за циклом, тоже не выполняется:
Если ЭлДок.ЕстьДочерниеУзлы() Тогда 
Выполнение процедуры "РекурсивныйПарсингСпискаВерсий" заканчивается безрезультатно. Насколько я понимаю произошла неудачная попытка получения списка версий конфигурации.
Прикрепленные файлы:
83. qwinter 628 27.08.18 17:00 Сейчас в теме
(82) Код состояния ответа неверный. Запрос возвращает на страницу авторизации. Проверьте еще раз правильность логина и пароля.
84. enschede 27.08.18 19:14 Сейчас в теме
(83) Проверил. Логин и пароль набираю не с клавиатуры, а копированием/вставкой. Самостоятельно на сайт по этому логину и паролю я зайти могу. А попытка обновить версии конфигурации неудачная.

Посмотрел функцию "НайтиИдентификаторСессииV8". В ней четыре раза встречается переменная ОтветHTTP. Посмотрел коды состояния в этой переменной: 302, 200, 401, 401. Я так понимаю, что в третий раз как раз происходит неудачная авторизация.
86. qwinter 628 27.08.18 21:03 Сейчас в теме
(84) может с лишним пробелом копируется?
88. enschede 28.08.18 11:42 Сейчас в теме
(86) Если бы все так просто было. Я проверял переменную InviteCode, на всякий случай. В ней логин и пароль правильные. Но пока отложим эту проблему, выявились новые.
Запускаю скачивание файлов обновлений. Иногда скачиваются нужные файлы, но чаще получаются файлы с одинаковым размеров 10КБ. Если это файл htm, то его можно открыть. В нем будет приблизительно следующее:

1C:Обновление программ
Главная Новости Личный кабинет О сервисе
Указанный файл не найден
Внимание!
Выбранный файл не найден

С помощью отладчика прошелся, для файлов самих обновлений получается точно такой же результат, просто он сохраняется в файл с расширением exe.
В результате ни разу все нужные файлы не скачались, сколько бы я не запускал загрузку. Либо какая-то часть скачивается, либо ни одного.
89. qwinter 628 28.08.18 14:15 Сейчас в теме
(88) какая то совсем ерунда. Вас опять кидает на страницу авторизации видать при скачивании почему то.
90. qwinter 628 28.08.18 14:16 Сейчас в теме
(88) а что пишет в регистре Ошибки при загрузке обновлений?
92. enschede 28.08.18 14:20 Сейчас в теме
(90) Ничего не пишет. Случайно нашел этот регистр, сразу полез смотреть. Журнал регистрации смотрел, тоже ничего нет интересного.
А как можно решить, отследить проблему? На стороне 1С я могу самостоятельно разбирать проблемы, но как только дело доходит до взаимодействия с сайтом 1С, тут я ничего не могу сделать. HTTP и внутренности 1совского сайта я не знаю.
91. qwinter 628 28.08.18 14:18 Сейчас в теме
(88) а у второго пользователя права на эти конфигурации есть?
93. enschede 28.08.18 14:21 Сейчас в теме
(91) Да, конечно. Через сайт без проблем могу скачивать. Плюс, как я уже писал выше, иногда файлы удачно скачиваются. ПРи этом никакой логики не вижу. Совсем необязательно, что скачаются первые два файла, а остальные не скачаются. Я запускал несколько раз, каждый раз разные файлы закачивались удачно. Я установил количество потоков равное нулю, чтобы все в одном потоке выполнялось и чтобы было проще отслеживать выполнение. Поэтому имел возможность наблюдать в режиме реального времени появления файлов.
У пользователя наблюдается внезапное кратковременное пропадание прав)
94. enschede 28.08.18 14:37 Сейчас в теме
(86) Похоже определил причину проблемы. Изменил пароль у первого пользователя, оставив только латинские буквы и цифры. Стало работать. До этого в пароле использовались спецсимволы и скобки.
На мысль навели попытки с помощью инструментов разработчика браузера посмотреть как происходит работа с сайтом. Там заметил, что в InviteCode, написание пароля отличается от самого пароля. Некоторые символы заменены. Замена похожа на замену слеша на "%2F", или замену русских букв в адресной строке не похожие наборы символов. По-видимому, из-за отсутствия подобной замены у меня и не происходила авторизация.
Но проблема, что указанный файл не найден осталась. По-прежнему вместо нужных файлов закачиваются 10Кб страницы, как описывал выше.
87. qwinter 628 27.08.18 21:06 Сейчас в теме
(84)или с символом переноса.
85. enschede 27.08.18 19:50 Сейчас в теме
(83) Попробовал под другим логином и паролем. Заработало. Причина непонятна.
95. enschede 28.08.18 15:34 Сейчас в теме
Не знаю имеет ли это значение, но обратил внимание, что значение возвращаемое функцией "НайтиИдентификаторСессииV8" не кэшируется, а каждый раз вычисляется заново.
96. qwinter 628 28.08.18 15:58 Сейчас в теме
(95) серьезно? Он же в модуле с повторным использованием на время сеанса? Не чаще чем раз в 20 минут должен вычисляться.
97. enschede 28.08.18 16:01 Сейчас в теме
(96) Абсолютно. Насколько я понимаю, каждый раз когда приходит новая комбинация параметров, выполняется вычисление функции. А новая комбинация получается каждый раз, как меняется значение параметра "АдресРезурса". Задуманное это поведение или нет, я оценить не могу.
Оставьте свое сообщение

См. также

Интеграция с бонусной программой лояльности ManyBonus Промо

Управление взаимоотношениями с клиентами (СRM) Розничная торговля WEB v8 Розница УУ Абонемент ($m)

ManyBonus.com - бонусная программа лояльности на базе мессенджеров. Позволяет регистрировать клиента в программе лояльности через Telegram, Viber, VK, отправлять коды скидок в мессенджеры, получать уведомления при списании/начислении бонусных баллов, альтернатива сообщениям СМС.

3 стартмани

07.01.2021    1919    2    Anton64    0    

BIM: взаимодействие с платформой Autodesk Forge

WEB v8 Строительство Абонемент ($m)

Предлагаемый пример демонстрирует широкие возможности для взаимодействия «1С:Предприятие» с платформой Autodesk Forge и позволяет вам получить базовые представления о применения технологий информационного моделирования в строительстве. Поддерживаются все версии платформы от 8.3.12 и выше до 8.3.18.

1 стартмани

25.11.2020    12304    4    kandr    0    

"Учет штрафов ГИБДД" с возможной загрузкой из открытых источников в интернет Расширение конфигурации 1С: Предприятие 8.3

Обработка документов WEB v8 v8::УФ 1cv8.cf Россия БУ УУ Абонемент ($m)

Расширение конфигурации Бухгалтерия предприятия, редакция 3.0 (при минимальных изменениях любой типовой конфигурации), позволяющее вести историю данных по штрафам ГИБДД для справочника транспортных средств компании. Бонусом поставляется внешняя обработка, способная загружать эти данные из открытых источников в интернет.

4 стартмани

30.12.2019    10584    17    capitan    11    

Пакетное пробитие чеков на Онлайн-кассе при оплатах от физических лиц на расчетный счет

Банковские операции Кассовые операции Обработка документов v8 v8::БУ БП3.0 Россия БУ Абонемент ($m)

Автоматизация процесса пробития чеков онлайн при поступлениях на расчетный счет от физических лиц. Помогает сократить трудозатраты таким организациям, как МФЦ, Управляющие компании и т.д. Подходит для 1С:Бухгалтерия 3.0 любой версии (базовая, ПРОФ, КОРП). Не изменяет конфигурацию. Конфигурация остается на поддержке (типовая).

2 стартмани

24.09.2019    14412    4    r.resh39    6    

Групповая установка даты выплаты в документах "Отпуск" и "Командировка" на заданную дату и перерасчет отобранных документов Промо

Обработка документов Зарплата Управление персоналом (HRM) Зарплата v8 v8::СПР ЗУП3.x БУ Абонемент ($m)

Обработка позволяет расчетчикам сократить время, затрачиваемое на расчет отпусков и командировок.

2 стартмани

15.02.2017    13651    82    ser6702    18    

Работа с релизами 1С и договорами ИТС

WEB БСП (Библиотека стандартных подсистем) v8 1cv8.cf Абонемент ($m)

Работа с релизами 1С и партнерским кабинетом.

2 стартмани

15.08.2019    16022    51    RocKeR_13    34    

Списание (корректировка) задолженности контрагентов УНФ 1.6

Закрытие периода Дебиторская и кредиторская задолженность Обработка документов Дебиторская и кредиторская задолженность v8 УНФ Украина БУ Абонемент ($m)

Обнуление задолженности контрагентов в конфигурации "Управление небольшой (нашей) фирмой" версии 1.6 с помощью документа "Корректировка регистров".

1 стартмани

24.07.2019    25427    17    DMon    1    

Регистрация документов с измененной суммой

Обработка документов v8 1cv8.cf Абонемент ($m)

Обработка берет информацию из истории изменения документов. Удобна для администраторов, когда документы с измененной суммой по какой-то причине не регистрируются в плане обменов. Можно регистрировать не все документы, а только те, которые были изменены.

1 стартмани

20.04.2019    20868    5    ryan    0    

StartManager 1.4 - Развитие альтернативного стартера Промо

Стартеры 1С v7.7 v8 Абонемент ($m)

Очередная редакция альтернативного стартера, являющегося продолжением StartManager 1.3. Спасибо всем, кто присылал свои замечания и пожелания, и тем, кто перечислял финансы на поддержку проекта. С учетом накопленного опыта, стартер был достаточно сильно переработан в плане архитектуры. В основном сделан упор на масштабируемость, для способности программы быстро адаптироваться к расширению предъявляемых требований (т.к. довольно часто просят добавить ту или иную хотелку). Было пересмотрено внешнее оформление, переработан существующий и добавлен новый функционал. В общем можно сказать, что стартер эволюционировал, по сравнению с предыдущей редакцией. Однако пока не всё реализовано, что планировалось, поэтому еще есть куда развиваться в плане функциональности.

1 стартмани

23.04.2014    132792    1728    Alexoniq    1562    

Блин, мы забыли включить регламентные задания…

Сервисные утилиты v8 Абонемент ($m)

Привет, Инфостарт! Сегодня расскажу, как я решил проблему с выключенными регламентными заданиями в рабочих базах. Желая исключить человеческий фактор и минимизировать количество ошибок, я написал небольшую конфигурацию.  В конфигурации два регламентных задания. Первое периодически подключается к кластеру и сохраняет текущие параметры: имя, Сервер БД, базу СУДБ, блокировки входа и регламентных заданий и т.д. Второе задание периодически проверяет эти параметры на ошибки.

1 стартмани

08.04.2019    19756    18    slozhenikin_com    37    

Валовая прибыль для УПП 1.3, КА 1.1 в режиме РАУЗ (работа типового отчета без доработок конфигурации)

Обработка документов v8 КА1 УПП1 УУ Абонемент ($m)

Простое и мгновенное решение для использования типового отчета "Валовая прибыль" в конфигурациях "Управление производственным предприятием 1.3", "Комплексная автоматизация 1.1" (а также отраслевых решений на их базе) при включенном режиме РАУЗ (расширенная аналитика учета затрат). Не требует настройки или изменения конфигурации, либо может быть, для дополнительного удобства, интегрировано в нее с минимальными доработками.

2 стартмани

21.01.2019    21481    27    stvorl    12    

Легкое и гибкое управление списком доступных баз 1С у пользователей

Стартеры 1С Сервисные утилиты Администрирование СУБД v8 1cv8.cf Россия Абонемент ($m)

Когда в локальной сети много пользователей, а еще большое количество различных баз и при этом каждому нужны свои, то администрирование этого зоопарка превращается в АД! Этот комплекс позволяет централизованно управлять списком доступных баз в разрезе пользователей. За пару кликов можно добавить или убрать базу у всех пользователей.

7 стартмани

05.12.2018    17606    19    RomikR    9    

Правильные аналоги номенклатуры (кроссы запчастей) для 1С / Управляемые формы Промо

Обработка справочников Оптовая торговля Учет ТМЦ Оптовая торговля Учет ТМЦ v8 v8::УФ 1cv8.cf УУ Абонемент ($m)

По опыту работы с запчастями много раз сталкивался с проблемой организации кроссов в разных 1С - от записи артикулов через запятую в текстовом поле до хранения кроссов в документах. Предлагаю одну из простейших и функциональных на мой взгляд схем "одноуровневого" хранения кроссов.

5 стартмани

29.07.2015    38229    3    taurus__    22    

Проверка VAT номеров

WEB v8 1cv8.cf Абонемент ($m)

Обработка для вызова сервиса проверка VAT номера.

1 стартмани

26.11.2018    14165    3    wtlz    1    

Многопоточная обработка данных

Производительность и оптимизация (HighLoad) Администрирование данных 1С v8 v8::УФ 1cv8.cf Абонемент ($m)

Конфигурация "Универсальные механизмы: пакеты данных". Набор инструментов для быстрой организации отказоустойчивой многопоточной обработки данных.

1 стартмани

23.11.2018    23930    79    _ASZ_    15    

Обнуление остатков регистров бухгалтерии и накопления

Универсальные обработки Чистка базы v8 v8::БУ v8::ОУ v8::УФ КА1 БП2.0 ЗУП2.5 УТ10 УПП1 УНФ БГУ ERP2 БП3.0 УТ11 УХ КА2 ЗУП3.x Россия Абонемент ($m)

Обработка позволяет обнулить остатки по регистру накопления или бухгалтерии на определенную дату. Поддерживается большинство типовых конфигураций (БП 3, БП 2, УТ 11, УТ 10, ЗУП 3, ЗУП 2, БГУ 2, БГУ 1, ERP, УПП, КА 2, КА 1, УХ 3, УХ 1, УНФ). Гибкая настройка (отборы, заполнение реквизитов и любых полей корр. счета, возможность обнулять ресурсы выборочно). Несколько режимов работы. Два интерфейса: простой и с расширенным набором настроек.

2 стартмани

19.11.2018    26563    351    morozov.sv    52    

Внешняя компонента для работы по Web-socket протоколу x32 x64 Промо

Разработка внешних компонент WEB v8 Абонемент ($m)

Кто когда-нибудь сталкивался с обменом данными по Web-Socket (wss) протоколу из 1С, тому известно, что в платформе отсутствуют данные механизмы (не путать с HTTP запросами и WebServices). Предлагается использовать внешнюю компоненту, написанную по технологии NativeAPI, для подключения и обмена с серверами из 1С-Предприятия, работающими по протоколу Web-Socket.

1 стартмани

30.03.2018    29278    36    Ditron    86    

Очистка кэша 1С 8 (8.0, 8.1, 8.2, 8.3). Грамотная чистка кэша 1С с сохранением настроек.

Чистка базы Сервисные утилиты Администрирование данных 1С v8 1cv8.cf Россия Абонемент ($m)

Эффективное средство для устранения ошибок, возникающих в локальном кэше 1С на клиенте, которым легко сможет воспользоваться пользователь с любым уровнем знаний. Wsf-скрипт, созданный на стандартном языке автоматизации Windows - "WSH JScript", очищает кэш 1С просто, быстро и безопасно. Кроме варианта, очищающего кэш текущего пользователя, имеется также вариант для чистки кэша 1С всех пользователей терминального-сервера.

1 стартмани

04.11.2018    43397    434    Eugen-S    34    

Универсальный инструмент для переноса данных через табличный документ (УФ)

Обработка документов Универсальные обработки Обработка справочников v8 v8::УФ 1cv8.cf Абонемент ($m)

Для опытных пользователей, разработчиков, администраторов, консультантов

5 стартмани

15.10.2018    37118    139    json    42    

TextRadar - нечеткий поиск в тексте

Разработка внешних компонент Поиск данных v8 1cv8.cf Абонемент ($m)

В отличие от нечеткого сравнения строк, когда обе сравниваемых строки равнозначны, в задаче нечеткого поиска выделяются строка поиска и строка данных, а вычислить необходимо не степень похожести двух строк, а степень присутствия строки поиска в строке данных. Нормированный коэффициент, находящийся между 0 и 1 позволяет отсечь заведомо низкие результаты, организовать поиск по синонимам и т.д. Наглядное отображение результатов в кратком и детальном виде поможет быстро найти интересующий фрагмент.

1 стартмани

19.09.2018    19266    30    TSSV    19    

Очистка регистрации обмена Промо

Чистка базы v8 v8::ОУ УТ10 Абонемент ($m)

Данная обработка предназначена для очистки узла. Для очистки необходимо указать период,организацию.

1 стартмани

19.09.2017    18516    9    serg-lom89    0    

Работа с публикациями "Инфостарт"

Практика программирования О сообществе WEB v8 УУ Абонемент ($m)

Работа с рублевыми публикациями на сайте "Инфостарт": ведение клиентов, заказов, обновление файлов публикации, рассылка обновлений.

1 стартмани

13.09.2018    23476    13    RocKeR_13    16    

Помощник корректировки остатков ЕГАИС в небольшом магазине. Розница 2.2

Розничная торговля Обработка документов Розничная торговля v8 Розница Розничная и сетевая торговля (FMCG) Рестораны, кафе и фаст-фуд Россия УУ Абонемент ($m)

Данная обработка упрощает корректировку остатков алкогольной продукции небольшого магазина, где предполагается передача всей продукции в торговый зал сразу после приемки.

5 стартмани

08.09.2018    35829    83    asdfgcom    47    

Расширение резервов отпусков

Обработка документов Зарплата Зарплата v8 v8::СПР ERP2 ЗКГУ3.0 ЗУП3.x Россия БУ Абонемент ($m)

Произвольная настройка базы для расчета резервов отпусков.

2 стартмани

10.08.2018    29629    57    СергейКа    21    

Пример использования REST API Яндекс Диска

WEB v8 1cv8.cf Абонемент ($m)

Пример использования REST API Яндекс Диска: чтение диска, добавление каталога, загрузка файла, скачивание файлов или каталогов, удаление файлов или каталогов.

1 стартмани

26.06.2018    27882    43    MKFreeUser    15    

Очистка периодических регистров посредством T-SQL (удаление записей, кроме среза последних)

Чистка базы v8 Абонемент ($m)

Обработка для ленивых. Составит вместо Вас запрос для SQL, который удалит все не актуальные записи (т.е все, кроме среза последних)

5 стартмани

22.06.2018    17466    20    Alexander.Shvets    9    

Обмен файловыми базами данных через Yandex диск

WEB v8 Россия Абонемент ($m)

Выполнение операций обмена с Yandex диском для файловых БД, по протоколу WebDav, в автоматическом или ручном режимах.

1 стартмани

11.06.2018    18464    7    slimper    1    

Конфигурация для просмотра публичных телеграм каналов

WEB v8 Абонемент ($m)

Просмотр и каталогизация в более удобном виде публичных телеграм каналов, групп и чатов.

1 стартмани

02.06.2018    19311    11    DO_WHILE_LOOP    7    

Автоматическое заполнение графиков в ЗУП 3.1

Зарплата Учет рабочего времени Обработка справочников Зарплата Учет рабочего времени v8 v8::СПР ЗУП3.x Россия БУ Абонемент ($m)

Данная разработка будет актуальна для организаций с большим количеством графиков (несколько десятков/сотен).

1 стартмани

05.05.2018    26001    18    notserioussam    2    

Добавление возможности в конфигурации ЗУП 3.1 работать с фотографиями сотрудников (Зарплата и Управление Персоналом, редакция 3.1)

Обработка справочников Управление персоналом (HRM) Управление персоналом (HRM) v8 v8::СПР ЗУП3.x БУ Абонемент ($m)

Добавление возможности в ЗУП 3.1 работать с фотографиями сотрудников (физических лиц). Расширение тестировалось на релизе ЗУП 3.1.5.129.

1 стартмани

09.04.2018    32667    77    charivnick    4    

Построение маршрута доставки с расчётом расстояния для любой базы УФ

Универсальные обработки WEB Оптовая торговля Оптовая торговля v8 v8::УФ 1cv8.cf Абонемент ($m)

Графическое изображение маршрутного листа по картам гугл. Работает на любой конфигурации с управляемыми формами. Использует новую версию api google-карт от 13.02.2018 года под IE11.

10 стартмани

24.02.2018    37839    45    KorotkovRV    16    

Корректировка остатков ЕГАИС, возврат из регистра 2, загрузка ТТН из файлов, другое для УТ10.3

Розничная торговля Обработка документов Розничная торговля v8 v8::ОУ УТ10 Россия БУ Абонемент ($m)

Набор обработок для автоматизации работы с ЕГАИС: Обработка корректировки остатков ЕГАИС для УТ 10.3, аналогичная имеющимся в УТ 11, Рознице 2.2. Автоматически формирует документы "Передача в торговый зал", "Акт постановки на баланс в торговом зале", "Акт списания в торговом зале". Обработка возврата из регистра 2 с подбором справок Б. Обработка формирования ТТН из файлов xml.

1 стартмани

24.01.2018    38189    18    biz-intel    6    

Расчет начисления зарплаты со сложной формулой, по данным из внешнего источника. ЗУП 3.1

Обработка документов Загрузка и выгрузка в Excel Зарплата Зарплата v8 v8::СПР ЗКГУ3.0 ЗУП3.x БУ Абонемент ($m)

Расчет начисления зарплаты со сложной формулой, по данным из внешнего источника по данным экономического отдела. ЗУП 3.1.

3 стартмани

20.12.2017    52069    32    mvv1975    7    

Сервер push сообщений “Push0k“ 18.05

WEB v8 1cv8.cf Абонемент ($m)

Аналог других “мессенджеров“. Позволяет практически все то же самое, что и другие решения. За исключением смайлов, эмодзи, голосовой и видео связи. Основное отличие от других решений, открыта и доступна для изменения серверная и клиентская часть месенджера. Общедоступной серверной части нет, за серверную часть отвечаете вы сами.

1 стартмани

19.12.2017    19789    12    PloAl    20    

Копирование меню в Трактир Management

Обработка документов Производство готовой продукции (работ, услуг) Производство готовой продукции (работ, услуг) v8 1cv8.cf Рестораны, кафе и фаст-фуд Россия УУ Абонемент ($m)

Механизм копирования меню в Трактир Management. Данная обработка расширяет функционал типового решения Трактир Management, позволяя быстро вводить в эксплуатацию новую точку путём создания нового меню на основании имеющегося.

1 стартмани

28.11.2017    30027    2    integrator1983    0    

Быстрое удаление неиспользуемых версий 1С:Предприятие 8, кэша метаданных и информационных баз

Сервисные утилиты v8 Абонемент ($m)

При обновлении платформы 1С:Предприятие 8 предыдущие версии не удаляются. Со временем количество неиспользуемых версий платформы растет. Они занимают место на диске. Для решения этой проблемы предназначена программа OneCleaner. Она позволяет быстро удалить неиспользуемые версии платформы, а также почистить кэш метаданных и удалить ненужные информационные базы данных.

1 стартмани

14.11.2017    23581    91    bonv    15    

Помощник по закрытию месяца для УТ 11.3

Закрытие периода Обработка документов Закрытие периода Закрытие периода v8 v8::ОУ УТ11 Россия УУ Абонемент ($m)

Помощник по закрытию месяца для УТ 11.3. Имеет две функции: обнуление товаров "К оформлению" в интеркампани и обнуление отрицательных остатков в регистре "Себестоимость товаров".

5 стартмани

10.11.2017    25761    9    Zalipaka    1    

Подсистема Вики - интеграция 1С и сайта под управлением MediaWiki

WEB v8 Абонемент ($m)

Редактирование статей сайта Mediawiki из 1С. Формирование функционального описания конфигурации на сайте Вики.

1 стартмани

19.09.2017    30301    35    shmalevoz    20    

Работа с картой. Кадастровый учет (Росреестр). Тематические карты

WEB Рабочее место v8 v8::УФ 1cv8.cf Абонемент ($m)

Внешняя обработка для работы с картами в 1С. Получения изображения с публичной кадастровой карты России, построения тематических карт

5 стартмани

31.08.2017    20215    7    vipchep    0    

Загрузка дополнительных реквизитов и сведений справочника Номенклатура из Excel и таблиц УТ 11, ERP 2

Обработка справочников Загрузка и выгрузка в Excel Учет ТМЦ Учет ТМЦ v8 v8::ОУ ERP2 УТ11 Россия УУ Абонемент ($m)

Внешняя обработка "Загрузка дополнительных реквизитов и сведений справочника Номенклатура"

1 стартмани

07.08.2017    44251    286    Windyhead    42    

Упрощение работы с актами сверки в УТ/КА/УПП - вывод номеров счетов в документе и печатной форме

Обработка документов Печатные формы документов Дебиторская и кредиторская задолженность Дебиторская и кредиторская задолженность v8 КА1 УТ10 УПП1 БУ УУ Абонемент ($m)

Обычно акт сверки с клиентами содержат информацию о документах реализации товаров (накладных) и выполненных платежах. Но платежи делаются на основании счетов, номера которых отсутствуют в актах, что затрудняет собственно сверку. Данная обработка находит соответствующие расходным накладным счета/заказы, показывает их в форме документа и выводит в печатную форму акта.

2 стартмани

12.05.2017    32586    4    denmax    7