Настройка обмена с любой устаревшей конфигурацией на базе 8.2 через обработку "Универсальный обмен данными в формате XML" и "Конвертацию данных 2.0"

Публикация № 1322060

Разработка - Системная интеграция - Обмен через XML

настройка обмена данными конвертация данных универсальный обмен

Разберем кейс, как настроить простенький обмен с любой устаревшей конфигурацией на базе 8.2 через обработку "Универсальный обмен данными в формате XML" и Конвертацию данных 2.0 с возможностью настройки гибких отборов по периоду, организации и списку документов.

Вступление

Несмотря на бурное развитие 1С и на огромное количество технологий обмена данными в среде 1С, обработка "Универсальный обмен данными в формате XML"  по-моему мнению до сих пор остается очень мощным инструментом, позволяющим настроить обмен данными между различными конфигурациями, за достаточно короткий срок. Одним из ее основных преимуществ, это возможность полностью "программной" настройки.  Не всегда же бизнесу требуются сложные обмены, иногда достаточно одностороннего обмена с 1С:Бухгалтерия 3.0, но при этом источником данных может быть любая конфигурация "динозавр". Так же потребуется выполнить определенные манипуляции с правилами конвертации в 1С:Конвертации данных 2.0.

Постановка задачи

Необходимо настроить односторонний обмен между устаревшей конфигурацией (например УНФ 1.4) и 1С:Бухгалтерия 3.0. Прежде всего у нас уже должны быть разработаны правила конвертации в Конвертации данных 2.0. Некоторые лайфхаки для настройки правил будут разобраны чуть ниже по тексту.

Основная задача реализовать удобный интерфейс обмена, понятный не только программисту, но и бухгалтеру с гибкими отборами по организации, периоду и видам документов. 

Реализация

1. Создание обработки и подключение макета с правилами 

Создаем внешнюю обработку, добавляем к ней макет с типом двоичные данные, загружаем наши правила, разработанные в КД 2.0 в формате XML. Во вложениях к публикации есть примерные правила, которые можно использовать как заготовку.

 

2. Накидаем простенький интерфейс на форме

Тут просто пример как это можно сделать.

 

3. Реализуем основную логику выгрузки данных

Программный код для кнопки выгрузить данные:

//Инициализируем обработку
Обработка = Обработки.УниверсальныйОбменДаннымиXMLОбмен.Создать();    
Обработка.РежимОбмена="Выгрузка";

//Указваем наши правила обмена    
ВремФайл = ПолучитьИмяВременногоФайла("xml");    
МакетПравилОбмена = РеквизитФормыВЗначение("Объект").ПолучитьМакет("ПравилаВыгрузкиВБухгалтерию");        
МакетПравилОбмена.Записать(ВремФайл);
Обработка.ИмяФайлаПравилОбмена = ВремФайл;

//Заполняем всякие разные параметры
Обработка.НеВыводитьНикакихИнформационныхСообщенийПользователю = Истина;
Обработка.ЗагружатьДанныеВРежимеОбмена = Истина;
Обработка.ЗаписыватьРегистрыНаборамиЗаписей = Истина;
Обработка.ЗапоминатьЗагруженныеОбъекты = Истина;
Обработка.ИспользоватьОтборПоДатеДляВсехОбъектов = Истина;
Обработка.ФлагКомментироватьОбработкуОбъектов = Истина;    
Обработка.ВыгружатьТолькоРазрешенные = Истина;      
Обработка.ТипУдаленияРегистрацииИзмененийДляУзловОбменаПослеВыгрузки=0;
// 0 - не снимать регистрацию, 1 - снимать регистрацию  
Обработка.НеВыводитьНикакихИнформационныхСообщенийПользователю = ложь;    
Обработка.ЭтоИнтерактивныйРежим     = Истина;
Обработка.ПараметрыИнициализированы = Истина;

//Указываем период выгрузки данных    
Обработка.ДатаНачала = ПериодВыгрузки.ДатаНачала;
Обработка.ДатаОкончания = ПериодВыгрузки.ДатаОкончания;

//Указываем выходной файл с данными
Обработка.ИмяФайлаОбмена = ИмяФайла;        
Обработка.ЗагрузитьПравилаОбмена();

 

4. Настраиваем отбор по организациям с использованием Конвертации данных 2.0

Для того чтобы можно было использовать отбор по организации в обработке, нужно в правилах Конвертации данных 2.0 добавить параметр. 

 

Далее этот параметр нужно задействовать в правилах выгрузки данных (ПВД) в событии "Перед выгрузкой" Например вот так:

Если Объект.Метаданные().Реквизиты.Найти("Организация") <> Неопределено Тогда
    Если (Параметры.Организация <> Объект.Организация) Тогда
        Отказ = Истина;
    КонецЕсли;
КонецЕсли;

 

И в правилах конвертации объектов (ПКО) в событии "Перед выгрузкой", например вот так:

Если Справочники.ТипВсеСсылки().СодержитТип(ТипЗнч(Источник)) Тогда
    Если Источник.Метаданные().Реквизиты.Найти("Организация") <> Неопределено Тогда
        Если (Параметры.Организация <> Источник.Организация) Тогда
            Отказ = Истина;
        КонецЕсли;
    КонецЕсли;
    Если Источник.Метаданные().Реквизиты.Найти("Владелец") <> Неопределено Тогда
        Если Источник.Владелец.Метаданные().Имя = "Организации" Тогда
            Если (Параметры.Организация <> Источник.Владелец) Тогда
                Отказ = Истина;
            КонецЕсли;
        КонецЕсли;
    ИначеЕсли Источник.Метаданные().Владельцы.Содержит(Параметры.Организация.Метаданные()) Тогда 
        Если Источник.Владелец <> Параметры.Организация Тогда
            Отказ = Истина;
        КонецЕсли; 
    КонецЕсли;
КонецЕсли;

Для выгрузки данных с отбором по организации программно заполняем значение нашего параметра в обработке

Обработка.Параметры.Организация = Объект.Организация;

Для каждого СтрокаТаблицыПараметров ИЗ Обработка.ТаблицаНастройкиПараметров Цикл
        Если СтрокаТаблицыПараметров.Имя = "Организация" Тогда 
            СтрокаТаблицыПараметров.Значение =     Объект.Организация;
        КонецЕсли;    
КонецЦикла;


//Отключим текущие правила, чтобы лишнего не выгружалось
//Обработка.ТаблицаПравилВыгрузки.Строки[0] - Справочники

Для Каждого СтрокаУровня Из Обработка.ТаблицаПравилВыгрузки.Строки[0].Строки Цикл  
        СтрокаУровня.Включить = 0; 
КонецЦикла;

//Обработка.ТаблицаПравилВыгрузки.Строки[1] - Документы
Для Каждого СтрокаУровня Из Обработка.ТаблицаПравилВыгрузки.Строки[1].Строки Цикл
        СтрокаУровня.Включить = 0; 
КонецЦикла;

//Определим список документов по которым нужно выгружать данные
СписокАктивныхОбъектовКВыгрузке = ОпределитьСписокАктивных();  

Реализуем дополнительную функцию для определения активных документов

Функция ОпределитьСписокАктивных()
    СписокАктивныхОбъектовКВыгрузке = Новый СписокЗначений;
    СписокАктивныхОбъектовКВыгрузке.Добавить(?(Объект.ПриходнаяНакладная=Истина,"ПриходнаяНакладная",""));
    СписокАктивныхОбъектовКВыгрузке.Добавить(?(Объект.РасходнаяНакладная=Истина,"РасходнаяНакладная",""));
    СписокАктивныхОбъектовКВыгрузке.Добавить(?(Объект.СчетФактура=Истина,"СчетФактура",""));
    СписокАктивныхОбъектовКВыгрузке.Добавить(?(Объект.СчетФактураПолученный=Истина,"СчетФактураПолученный",""));
    СписокАктивныхОбъектовКВыгрузке.Добавить(?(Объект.СчетНаОплату=Истина,"СчетНаОплату",""));
    СписокАктивныхОбъектовКВыгрузке.Добавить(?(Объект.РасходИзКассы=Истина,"РасходИзКассы",""));
    СписокАктивныхОбъектовКВыгрузке.Добавить(?(Объект.ПоступлениеВКассу=Истина,"ПоступлениеВКассу",""));
    СписокАктивныхОбъектовКВыгрузке.Добавить(?(Объект.РасходСоСчета=Истина,"РасходСоСчета",""));
    СписокАктивныхОбъектовКВыгрузке.Добавить(?(Объект.ПоступлениеНаСчет=Истина,"ПоступлениеНаСчет",""));
    СписокАктивныхОбъектовКВыгрузке.Добавить(?(Объект.ОприходованиеЗапасов=Истина,"ОприходованиеЗапасов",""));
    СписокАктивныхОбъектовКВыгрузке.Добавить(?(Объект.СписаниеЗапасов=Истина,"СписаниеЗапасов",""));

    Возврат СписокАктивныхОбъектовКВыгрузке;    
КонецФункции

Реализуем заполнение настроек отбора по документам. Основная идея в том, чтобы заполнить для каждого ПВД настройки отбора с помощью построителя отчетов.

Для Каждого ТекущееПВД Из Обработка.ТаблицаПравилВыгрузки.Строки[1].Строки Цикл
	
	НаименованиеОбъектаДляВыгрузки = ТекущееПВД.Имя;
	
	Если СписокАктивныхОбъектовКВыгрузке.НайтиПоЗначению(НаименованиеОбъектаДляВыгрузки) <> Неопределено Тогда
		
		Построитель = Новый ПостроительОтчета;
		Построитель.Текст = 
		"ВЫБРАТЬ Разрешенные Объект.Ссылка КАК Ссылка ИЗ Документ."
		+НаименованиеОбъектаДляВыгрузки+
		" КАК Объект {ГДЕ Объект.Ссылка.* КАК Документ_"
		+НаименованиеОбъектаДляВыгрузки+
		"}";
		
		Построитель.ЗаполнитьНастройки();
		Построитель.Отбор.Добавить("Документ_"+НаименованиеОбъектаДляВыгрузки+".Ссылка");
		
		Построитель.Отбор[0].ВидСравнения = ВидСравнения.ВСписке;
		Построитель.Отбор[0].Значение = ОпределитьСписокСсылокПоТипуДокумента(НаименованиеОбъектаДляВыгрузки);
		Построитель.Отбор[0].Использование = Истина;
		
		ДоступностьПостроителя = Истина;
		
		Если Построитель.Отбор.Количество() > 0 Тогда
			
			ТекущееПВД.Включить = 1;
			ТекущееПВД.НастройкиПостроителя = Построитель.ПолучитьНастройки();
			ТекущееПВД.ИспользоватьОтбор    = ИСТИНА;
			
		КонецЕсли;
		
	КонецЕсли;
	
КонецЦикла;

Обходим табличную часть "Список документов" на форме, для формирования списка документов к выгрузке

Функция ОпределитьСписокСсылокПоТипуДокумента(ТипДокумента)
    СписокДок = Новый СписокЗначений;    
    Для каждого Стр Из СписокДокументов Цикл
        Если не Стр.Метка Тогда
            продолжить;
        КонецЕсли;
        ТекОб = Стр.Ссылка.ПолучитьОбъект(); 
        ТипДокументаПоСсылке = ТекОб.Метаданные().имя;
        Если ТипДокументаПоСсылке = ТипДокумента Тогда 
            СписокДок.Добавить(Стр.Ссылка);
        КонецЕсли;
    КонецЦикла;        
    Возврат СписокДок;    
КонецФункции

Непосредственно выгрузка.

Обработка.ВыполнитьВыгрузку();
Обработка = Неопределено;    

Для удобства пользователя можно реализовать универсальную процедуру для заполнения списка документов с отбором по организации и периоду при переключения флажков на форме. 

&НаСервере
Процедура ОбновитьСписокДокументовНаСервереСкладской(ТипДокумента)
    Н = "";
    
    Запрос = Новый запрос();
    Запрос.Текст = "ВЫБРАТЬ " + Н + "
    |    "+ТипДокумента+".ссылка,
    |    "+ТипДокумента+".Организация
    
    |ИЗ
    |    Документ."+ТипДокумента+" КАК "+ТипДокумента+"
    |ГДЕ
    |    "+ТипДокумента+".Дата МЕЖДУ &Начало И &Конец
    |  И "+ТипДокумента+".Организация = &Организация
    |  И "+ТипДокумента+".Проведен" ;
        
    Запрос.УстановитьПараметр("Начало",  ПериодВыгрузки.ДатаНачала);
    Запрос.УстановитьПараметр("Конец",  ПериодВыгрузки.ДатаОкончания);
    Запрос.УстановитьПараметр("Организация",  Объект.Организация);
    
    Результат = Запрос.Выполнить().Выбрать();
    Пока Результат.Следующий() Цикл
         НовСтрока = СписокДокументов.Добавить();
         НовСтрока.Метка = Истина;
         НовСтрока.ссылка =  Результат.Ссылка;
         НовСтрока.Организация =  Результат.Организация;
    КонецЦикла;    

КонецПроцедуры

После выгрузки данных полученный XML файл можно легко загрузить обработкой "Универсальный обмен данными в формате XML"  в конфигурации-приемнике.

При желании данный обмен можно реализовать в регламентом задании.

Проверено на УНФ 1.4.1.19 - Бухгалтерия 3.0.81.30.

Скачать файлы

Наименование Файл Версия Размер
Шаблон обработки выгрузки данных УНФ 1.4.1.19 - Бухгалтерия 3.0.81.30

.epf 193,40Kb
2
.epf 193,40Kb 2 Скачать
Правила обмена данными УНФ 1.4.1.19 - Бухгалтерия 3.0.81.30

.xml 795,40Kb
1
.xml 795,40Kb 1 Скачать

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. quazare 728 24.11.20 04:27 Сейчас в теме
такие вещи нужно делать на события самих правил, например "перед выгрузкой данных"
triviumfan; zqzq; orfos; +3 Ответить
2. orfos 83 24.11.20 09:31 Сейчас в теме
(1) вы имеете ввиду глобальное событие "перед выгрузкой данных"? А там есть доступ к выгружаемому объекту, чтобы отсечь ссылки с ненужной организацией, если да то так будет еще интереснее.
3. quazare 728 24.11.20 09:35 Сейчас в теме
(2) совершенно верно! не только с ненужной организацией, но это позволяет даже выбрать источник выгрузки, а не только сами объекты.
4. orfos 83 24.11.20 10:05 Сейчас в теме
(3)все таки есть сомнения, в справке написано глобальное событие выполняется 1 раз, да и подходящего примера так и не нашел. В глобальном событии в основном просто параметры заполняются. Поделитесь примером? ))
5. maks_20 134 25.11.20 10:43 Сейчас в теме
Почему сразу с устаревшей конфигурацией? Данную методологию можно на любой конфигурации применить.
6. orfos 83 25.11.20 11:06 Сейчас в теме
(5) согласен))), мне гораздо комфортней использовать КД 2.0 и универсальный обмен, а устаревшей потому что, 1с выпилила правила конвертации и заменило их на технологию Конвертации 3.0.
7. maks_20 134 25.11.20 11:15 Сейчас в теме
(6) это да, но еще остались решения типовые, где до сих пор синхронизация на кд 2.0 сделана.
texnic79; +1 Ответить
8. RocKeR_13 872 26.11.20 09:45 Сейчас в теме
Название публикации вводит в заблуждение. Скорее подойдет название "Использование обработки "Универсальный обмен данными в формате XML" для настройки постоянного обмена с возможностью настройки отборов". А "Настройка обмена с любой устаревшей конфигурацией" навевает на мысль о ранее невиданном чуде) К тому же в этой схеме есть один минус: без использования плана обмена нам придется каждый раз ограничивать выгрузку отборами либо повторно выгружать данные, которые не были изменены.
texnic79; Drivingblind; +2 Ответить
9. orfos 83 26.11.20 11:53 Сейчас в теме
(8) кликбэйт что-ли? это точно не специально, название раз 5 менял. На самом деле в универсальном обмене можно и план обмена указать , с последующей очисткой после выгрузки и будет совсем красиво. Пожалуй надо будет дополнить статью
10. RocKeR_13 872 26.11.20 12:17 Сейчас в теме
(9)
кликбэйт что-ли?

Ох уже эти новомодные термины. Наверное в моем сообщении все-таки не хватает "на мой взгляд")
Drivingblind; orfos; +2 Ответить
11. orfos 83 26.11.20 12:32 Сейчас в теме
(10) да это точно, сам их не люблю, если честно
12. lvictor58 130 27.11.20 09:42 Сейчас в теме
Я делал подобные выгрузки. Правило выгрузки данных нужно создать одно, установить признак "Произвольный алгоритм".
В обработчик "Перед обработкой" запихнуть запрос аналогичный описанному в процедуре ОбновитьСписокДокументовНаСервереСкладской только его надо собрать обходом списка выгружаемых видов документов через ОБЪЕДИНИТЬ ВСЕ с фильтрами по дате и организации.
И добавить в выборку кроме ссылки еще "ТипДокумента" (организация в общем-то и не нужна),
а при обходе выборки использовать метод ВыгрузитьПоПравилу(Выборка.Ссылка, , , , Выборка.ТипДокумента); Ест-но правила конвертации должны называться как и ТипДокумента.
13. orfos 83 27.11.20 10:41 Сейчас в теме
(12) да тоже интересный способ, правда мне кажется немного сложноватый
14. AneJIbcuH 28 30.12.20 11:31 Сейчас в теме
(13) выигрышный по скорости
Оставьте свое сообщение

См. также

Выгрузка документов из ЗУП в БП (1С 8.2-8.3) Промо

Перенос данных из 1C8 в 1C8 Зарплата Зарплата v8 БП2.0 ЗУП2.5 Абонемент ($m)

Обработка для выгрузки документов из конфигурации "Зарплата и управление персоналом" 8.2 в конфигурацию "Бухгалтерия предприятия" 8.2. Использует правила обмена. В обработке создан удобный интерфейс для гибкого формирования списка документов кадрового учета и начисления ЗП.

1 стартмани

18.12.2012    16270    138    d.zhukov    20    

Улучшенная обработка универсального обмена данными в формате XML (УФ)

Универсальные обработки Внешние источники данных Обмен через XML v8 v8::УФ 1cv8.cf Абонемент ($m)

Улучшенная обработка "Универсальный обмен данными" с полноценными возможностями СКД для выборки данных (не только для отборов).

1 стартмани

23.06.2020    5830    80    Lem0n    1    

Загрузка из XML файла ЭДО в документ поступления для конфигураций 1С: Розница 2.2/2.3, Управление торговлей 10.3/11.4

Розничная торговля Обработка документов Документооборот и делопроизводство Обмен через XML v8 УТ10 Розница Розничная и сетевая торговля (FMCG) Россия УУ Абонемент ($m)

Внешние обработки загрузки данных из XML файлов формата ON_NSCHFDOPPRMARK ЭДО в документы поступления 1С Розница версия 2.2.10.19 и выше, Управление торговлей 10.3.52.2 и выше, Управление торговлей 11.4.5.63 и выше

1 стартмани

04.06.2020    15977    204    independ    113    

Универсальный обмен данными между идентичными конфигурациями, версия 2020.3.1

Перенос данных из 1C8 в 1C8 v8 1cv8.cf Абонемент ($m)

Обработка «Универсальная выгрузка и загрузка» предназначена для оперативного переноса объектов между двумя идентичными или похожими конфигурациями. Быстрая, надежная и очень простая в использовании обработка.

1 стартмани

29.01.2020    13767    219    vladnet    32    

Универсальная выгрузка/загрузка данных для отличающихся конфигураций (JSON, Такси+ОФ) Промо

Перенос данных из 1C8 в 1C8 Универсальные обработки Распределенная БД (УРИБ, УРБД) v8 1cv8.cf Абонемент ($m)

Простой перенос через JSON данных между двумя базами 1С (документов, справочников, ПВХ, ПВР, счетов). Аналогична произвольной выгрузке в типовой "Выгрузка/загрузка XML", но может использоваться для отличающихся конфигураций. Подходит для любых пар баз с любым интерфейсом (управляемый + обычный). Без настроек. Не требует идентичности конфигураций и платформ. При переносе типы данных сопоставляются по наименованиям метаданных, объекты и ссылки по UID.

1 стартмани

22.10.2014    211231    4243    ekaruk    184    

Преобразование XML файла в переменную структура, Загрузка в дерево значений

Обмен через XML v8 1cv8.cf Абонемент ($m)

Обработка, демонстрирующая работу процедур и функций по преобразованию XML файла в дерево значений, а также в переменную типа структура.

1 стартмани

14.09.2019    10736    18    vik070777    19    

Документы и Справочники в JSON

Обмен через XML v8 1cv8.cf Абонемент ($m)

Пример выгрузки всех данных Документа или Справочника в JSON

1 стартмани

20.06.2019    15236    17    Teut_Vlad    15    

Универсальный обмен данными XML (с гибкими отборами и сохранением вариантов настроек)

Обмен через XML v8 v8::УФ 1cv8.cf Абонемент ($m)

Обработка предназначена для загрузки и выгрузки данных по правилам обмена в любых конфигурациях, реализованных на платформе 1С:Предприятие 8.3. Преимуществом перед типовой обработкой является добавленный функционал: #1. Установка произвольных фильтров на выгружаемые объекты при помощи механизма системы компоновки данных #2. Сохранение различных вариантов настроек (сохраняются правила обмена, фильтры выгрузки, параметры, настройки обработки) - что позволяет гибко настроить в базе-источнике фильтры для выгрузки объектов по различным правилам обмена для различных баз-приемников, сохранить выполненные настройки и в будущем уже пользоваться этими вариантами настроек. Проверялась на 1С:ERP Управление предприятием 2.4.7.141.

1 стартмани

29.04.2019    19388    354    sapervodichka    20    

Перенос объектов 1С Промо

Перенос данных из 1C8 в 1C8 v8 v8::УФ 1cv8.cf Абонемент ($m)

Простой и наглядный перенос объектов между любыми базами 1С 8 с предварительным анализом на возможные различия в данных (через файл, через интернет, через буфер обмена). Интерактивная настройка правил обмена на стороне источника и получателя. В обработке есть удобный обзор по подсистемам, поиск и обработка данных по заданному фильтру. Сравнение объектов, поиск ссылок. Конструктор кода по созданию объектов, написание скриптов и отладка мини-функций в УФ. Отключение/включение регламентных заданий. Регистрация/снятие с регистрации объектов в планах обмена. И многое другое. Инструменты администратора в одной обработке.

1 стартмани

16.03.2015    93458    2032    moolex    199    

Выгрузка и загрузка данных XML с гибкими отборами

Обмен через XML Перенос данных из 1C8 в 1C8 v8 1cv8.cf Абонемент ($m)

Обработка выгрузки и загрузки данных через XML между идентичными конфигурациями с возможностью установки произвольных отборов на выгружаемые объекты.

1 стартмани

07.04.2019    22448    583    sapervodichka    7    

Перенос данных КА 1.1 -> КА 2

Перенос данных из 1C8 в 1C8 Обмен через XML v8 КА1 КА2 Россия Абонемент ($m)

Перенос данных КА 1.1 => КА 2 с помощью правил обмена данными в формате XML КД 2 (переносятся остатки, документы, справочная информация).

5 стартмани

20.03.2019    18750    283    gudogu    143    

1С: Розница/УТ 10.3. ЕГАИС, загрузка акцизных марок в справочник Штрихкоды и Упаковки, регистр Акцизные марки из XML-сообщений входящих ТТН ЕГАИС + Печать акцизных марок

Розничная торговля Обработка справочников Обмен через XML Ценники Розничная торговля v8 Розница Розничная и сетевая торговля (FMCG) Россия Абонемент ($m)

Пакетная загрузка/обновление списка акцизных марок ЕГАИС из входящих ТТН ЕГАИС. Для 1С Розница 2.2.9.ХХХ/2.2.10.ХХХ//2.2.11.ХХХ/2.2.12.ХХХ/Управление торговлей 10.3.49.ХХХХ и выше с возможностью печати

1 стартмани

31.01.2019    24826    185    independ    124    

Соответствия объектов обмена Промо

Распределенная БД (УРИБ, УРБД) Перенос данных из 1C8 в 1C8 v8 КА1 Россия Абонемент ($m)

Обработка позволяет проверять, исправлять ошибки, добавлять и удалять соответствия объектов в обменах данными между конфигурациями на основе «Комплексной автоматизации 1.1» или похожими конфигурациям. Подходит для обменов с использованием регистра сведений «СоответствиеОбъектовДляОбмена».

1 стартмани

26.08.2016    23274    8    xxxelaaa    1    

Редактор объектов информационной базы 8.3

Универсальные обработки Обмен через XML v8 v8::УФ 1cv8.cf Россия Абонемент ($m)

Универсальная внешняя обработка для редактирования реквизитов и табличных частей объектов информационной базы, редактирование движений документов. Доступ ко всем реквизитам объектов, есть возможность выгрузки и загрузки данных (объекты и движения документов) через XML. Платформа 8.3, управляемые формы. Версия 1.1.0.51 от 31.08.2020

2 стартмани

23.01.2019    32879    355    ROL32    39    

Ручная выгрузка и загрузка данных через универсальный обмен данными с настройками (расширение, платформа 8.3+)

Обработка документов Обработка справочников Обмен через XML Перенос данных из 1C8 в 1C8 v8 Розница УНФ ERP2 БП3.0 УТ11 КА2 ЗУП3.x Абонемент ($m)

Данное расширение (не требует изменения конфигураций) служит как надстройка для конфигураций, у которых обмен между базами происходит через универсальный формат (EnterpriseData), с использованием стандартных правил конвертации, которые уже есть в конфигурации. Интерфейс адаптирован для простых пользователей, сделан общий отбор по Организации для всех документов, имеется пару настроек для передачи в параметры конвертации, которые расположены в общем модуле конфигураций, а так же есть возможность выбора запуска - в фоне или в текущем сеансе. Теперь не нужно настраивать обмен между базами, для того чтоб просто перенести нужные документы. Подходит точно для УТ 11.4, БП 3.0.67, КА 2.4.5, Розница 2.2.9 (Обновление 1.2 от 02.03.2019)

2 стартмани

19.01.2019    25257    154    hakerxp    10    

Выгрузка данных из УТ 10.3 в БП 3.0 (своими руками) Промо

Перенос данных из 1C8 в 1C8 v8 УТ10 БП3.0 Россия Абонемент ($m)

Старая добрая, позабытая многими выгрузка из УТ 10.3 в БП 1.6. Ее еще можно оживить, и она послужит на благо всем желающим, всем уставшим от автоматических обменов.

2 стартмани

30.10.2014    43073    319    TESL    40    

Выполнение запроса в другой базе 1С без com-соединения. HTTP-сервис

Перенос данных из 1C8 в 1C8 v8 1cv8.cf Абонемент ($m)

Выполнение любого запроса с параметрами из одной базы 1С в другую. Используя HTTP-сервис. Посредством POST-запроса и JSON.

1 стартмани

30.11.2018    24799    26    John_d    23    

Пример получения данных из другой базы 1С через Web-сервис

Перенос данных из 1C8 в 1C8 v8 Россия Абонемент ($m)

В данной статье описан пример получения данных справочника из другой базы 1С через Web-сервис.

1 стартмани

11.11.2018    33777    28    flyDrag    29    

Интерфейс сопоставления объектов для обмена (для типового регистра СоответствиеОбъектовДляОбмена) Промо

Инструментарий разработчика Универсальные обработки Перенос данных из 1C8 в 1C8 v8 КА1 БП2.0 ЗУП2.5 УТ10 УПП1 Абонемент ($m)

Вы внедряете обмен данными между двумя типовыми или основанными на типовых БД и вам необходим инструмент, чтобы сопоставить между собой справочники этих конфигураций? Вы хотите навести порядок в обмене данными, потому что вам надоело вылавливать дублирующиеся объекты? Вам очень хочется перепоручить сопоставление объектов обменивающихся баз пользователям, но нет подходящего и понятного пользователям интерфейса? Тогда вам нужна именно эта обработка!

4 стартмани

11.11.2015    41259    108    catsam    8    

SOAP для чайников

Обмен через XML WEB v8 1cv8.cf Абонемент ($m)

Немножко про SOAP сервис. И пример работы с подключением и получением данных по SOAP за 5 минут.

1 стартмани

05.09.2018    56788    48    dusha0020    19    

Правила переноса документов из ЗУП 2.5 в ЗУП 3.1

Обмен через XML Перенос данных из 1C8 в 1C8 Зарплата Управление персоналом (HRM) Зарплата Управление персоналом (HRM) v8 v8::СПР ЗУП2.5 ЗУП3.x Россия БУ Абонемент ($m)

Перенос документов, справочников и планов видов расчета из конфигурации 1С ЗУП 2.5 в ЗУП 3.1.

3 стартмани

28.03.2018    31096    417    Cobranet123    64    

Выгрузка - загрузка данных в XML с отбором по организации Промо

Обмен через XML Перенос данных из 1C8 в 1C8 v8 1cv8.cf Абонемент ($m)

Выгрузка - загрузка данных в XML с отбором по организации (УФ)

1 стартмани

25.05.2014    48446    476    buganov    42    

Синхронизация (выгрузка) данных ЗУП 3.1 - БП 2.0, УПП 1.3

Перенос данных из 1C8 в 1C8 Зарплата Управление персоналом (HRM) Зарплата Управление персоналом (HRM) v8 v8::БУ v8::СПР БП2.0 ЗУП3.x Россия БУ Абонемент ($m)

Подобная выгрузка не была предусмотрена разработчиками 1С, поэтому и существует эта публикация. Поддерживается выгрузка оценочных обязательств и резервов отпусков. Непосредственная выгрузка в базу Бухгалтерии. Решение проблем с COM-соединением одной кнопкой.

3 стартмани

22.03.2018    45573    674    diso    190    

Правила конвертации документов ЗУП 2.5 - ЗУП 3.1

Обмен через XML Зарплата Перенос данных из 1C8 в 1C8 Зарплата v8 v8::СПР ЗУП2.5 ЗУП3.x Россия БУ Абонемент ($m)

Правила конвертации документов ЗУП 2.5 - ЗУП 3.1. Позволяют вести параллельную работу в базах ЗУП редакций 2,5 и 3.1.

10 стартмани

06.03.2018    41475    140    kostya_whiskas    24    

Создание в 1С 7.7 XML в формате EnterpriseData (универсальный формат обмена), версия 1.5. Инструкции и примеры переноса данных из устаревшей конфигурации 1С 7.7 в любую современную 1С 8.3, поддерживающую EnterpriseData, через Конвертацию данных 3

Перенос данных из 1С7.7 в 1C8.X Обмен через XML v7.7 v8 1cv7.md Россия Абонемент ($m)

Воспользоваться современным средством переноса данных "Конвертация данных 3.0.5.3" можно только выгрузив из системы - источника данных XML в формате обмена данными EnterpriseData. В этой публикации можно скачать приемы выгрузки из 1С 7.7 универсального формата обмена для Конвертации данных 3. Выполняем перенос данных из «1С:Предприятие 7.7» в «1С:Предприятие 8.3». Используем Конвертацию данных КД 3.0 из 1c 7.7 --> 1С 8.3. На первой стадии еще не опубликовано иного способа подложить файл для Конвертации данных 3 кроме как сформировать его вручную, постараемся решить данную проблему.

1 стартмани

26.02.2018    41453    56    ksnik    3    

[УТ 11][БП 3.0] Перенос данных из БП 3.0 в УТ 11 (начальное заполнение УТ 11 по данным БП 3.0)

Перенос данных из 1C8 в 1C8 v8 БП3.0 УТ11 Россия УУ Абонемент ($m)

Перенос данных из БП 3.0 в Ут 11 для первоначального заполнения УТ данными из БП. 31.01.2020 Версия 2.8.7.3 БП 3.0.84.35 платформа 8.3.18.1128.

1 стартмани

29.01.2018    43168    525    Alex_E    159    

Правила переноса документов из ЗУП 2.5 в ЗУП 3.1

Перенос данных из 1C8 в 1C8 Обмен через XML Зарплата Управление персоналом (HRM) Зарплата Управление персоналом (HRM) v8 v8::СПР ЗУП3.x Россия БУ Абонемент ($m)

Перенос документов из ЗУП 2.5 в ЗУП 3.1 - позволяет снизить объем работ при опытной эксплуатации ЗУП 3.1 параллельно с ЗУП 2.5.

1 стартмани

04.12.2017    34558    498    AntonH851    38    

1С:Конвертация данных 2.0. Анализ состава выгруженных данных из базы источника до загрузки в базу-приемник

Перенос данных из 1C8 в 1C8 Перенос данных из 1С7.7 в 1C8.X v8 КД БП3.0 ЗУП3.x Россия Абонемент ($m)

Обработка анализирует файл выгрузки данных конвертации и формирует дерево выгруженных объектов по категориям с возможностью просмотра выгруженных реквизитов (свойств). Идеально подходит для анализа выгруженных данных при переходе на ЗУП 3.1 или Бухгалтерия 3.0 с ранних версий.

1 стартмани

16.11.2017    17167    86    leosoft    4    

Синхронизация данных по правилам КД2.0

Перенос данных из 1C8 в 1C8 v8 1cv8.cf Абонемент ($m)

Новый инструмент для сравнения и загрузки данных, сочетающий в себе: гибкость запросов (используются для сопоставления объектов); наглядный вывод отличий; удобный отбор загружаемых данных; возможность пообъектной синхронизации двух баз по правилам КД2 с помощью вызова обработки "Универсальный обмен XML" в базе-источнике через COM-соединение.

1 стартмани

27.08.2017    26110    115    vikad    36    

Правила обмена ЗУП 3.1 - БП 2.0 и ЗУП 3.1 - УПП 1.3 (отражение, ведомости и справочники)

Перенос данных из 1C8 в 1C8 Обмен через XML Зарплата Управление персоналом (HRM) Зарплата Управление персоналом (HRM) v8 v8::БУ v8::СПР БП2.0 БП3.0 ЗУП3.x Россия БУ Абонемент ($m)

Правила обмена для выгрузки документов "Отражение зарплаты в бухучете", "Ведомость в банк", "Ведомость в кассу", справочников "Сотрудники" и "Физические лица"

1 стартмани

01.08.2017    81606    1569    forseil    209    

Перенос справочников и документов из УТ 10.3 в БП 3.0

Перенос данных из 1C8 в 1C8 v8 УТ10 БП3.0 Россия БУ НУ УУ Абонемент ($m)

Синхронизация справочников и документов из Управление торговлей 10.3 в Бухгалтерию предприятия 3.0. Обработка не затрагивает штатный механизм. Подключение и перенос документов происходит посредством OLE. Без ввода начальных остатков.

10 стартмани

25.07.2017    24240    15    2casp    6    

«Горыныч - то НЕ НАСТОЯЩИЙ!» … или О Конвертации Данных ред.3 (КД 3) и обменах в универсальном формате Enterprise Data… доступным русско-народным языком

Внешние источники данных Обмен через XML Перенос данных из 1C8 в 1C8 v8 КД Абонемент ($m)

Тем, кто хочет быстро разобраться с темой инструмента Конвертация данных 3.0 и технологией обмена по новому формату 1С, активно применяемому во всех новых конфигурациях от 1С на БСП, расширяющем возможности интеграции, пакет полезных материалов.

1 стартмани

13.06.2017    23077    143    Davlad_A    16    

"Конвертация данных" + Git. Решение проблемы различий в файлах

Инструментарий разработчика Обмен через XML v8 КД Абонемент ($m)

Как известно, типовая конфигурация «Конвертация данных» обладает одним недостатком, мешающим работать с ней в Git-е. Если выгруженные из нее правила обмена загрузить в другую КД, а потом снова выгрузить, то полученные два файла будут очень сильно отличаться друг от друга, и при сравнении (diff) доработок будет невозможно провести код-ревью, равно как найти сами изменения, которые закоммитил разработчик.

1 стартмани

08.06.2017    26220    42    stas_ganiev    13    

XMPP(jabber) на чистом 1С

Обмен через XML v8 1cv8.cf Абонемент ($m)

На сайте infostart, есть несколько реализаций работы 1С с протоколом XMPP (jabber), но в основном они на использование сторонних библиотек (нативных), которые надо регистрировать в операционке (и только в винде), или на основе других систем - php, python и т.п. Предлагаю пример реализации отправки сообщения через этот протокол только средствами 1С.

1 стартмани

26.12.2016    17314    16    kodnik    10    

Загрузка XML в дерево значений

Обмен через XML v8 1cv8.cf Абонемент ($m)

Случайно наткнулся на статью с алгоритмом загрузки XML-строки в дерево значений и подумал, а не проще ли сделать это через механизм XDTO рекурсивно. На мой взгляд, решение получилось неплохое - даже атрибуты грузит..

1 стартмани

17.11.2016    26347    55    starik-2005    26    

Обмен данными онлайн через Веб-сервис с использованием обработки "Универсальный обмен данными XML"

Обмен через XML v8 1cv8.cf Абонемент ($m)

Доработка позволяет организовать двухсторонний обмен данными в режиме реального времени между любыми конфигурациями (типовые, самописные, обычные формы, управляемые формы). Также предлагается вариант в виде расширения конфигурации (.cfe) для конфигураций стоящих на поддержке без возможности изменения. В обмене может участвовать любое количество баз. Правила обмена подготавливаются с использованием конфигурации "Конвертация данных".

2 стартмани

28.10.2016    45963    255    linkov    55    

Использование SoapUi для работы с веб-сервисами. Часть 2

Практика программирования Обмен через XML v8 Абонемент ($m)

Сложные примеры работы с xml в веб-сервисах 1С.

1 стартмани

04.10.2016    22644    20    kiv1c    6    

Редактор движений документа. Сохранение в XML, обмен между базами, замена регистратора.

Обработка документов Универсальные обработки Обмен через XML v8 Абонемент ($m)

Редактор набора записей движений документа. Позволяет сохранить набор записей в XML, в настройки пользователя, прочитать сохраненный XML в другой идентичной базе, заменить регистратор. Можно изменять порядок записей, менять активность, как массово, так и по одной и др. Тонкий клиент, управляемые формы.

1 стартмани

07.09.2016    43326    158    Aphanas    4    

Перенос объектов по OLE из идентичной конфигурации

Перенос данных из 1C8 в 1C8 v8 1cv8.cf Россия Абонемент ($m)

Перенос по OLE справочников, документов и пользователей из базы источника с идентичной конфигурацией без использования правил обмена, поиск по реквизитам, замена ГУИД, сохранение настроек в файл

1 стартмани

10.07.2016    16526    127    slava_1c    8    

Перенос данных из ЗУП 2.5 в ЗУП 3.1

Перенос данных из 1C8 в 1C8 Зарплата Управление персоналом (HRM) Зарплата Управление персоналом (HRM) v8 v8::СПР ЗУП2.5 ЗУП3.x БУ Абонемент ($m)

Обработка предназначена для переноса некоторых данных из ЗУП 2.5 в ЗУП 3.1 через COM-соединения. Обработка была написана потому, что типовые правила переноса не предоставляют возможности переносить данные по отдельности, а некоторые данные не переносят вовсе. Тестировалась на версии 3.1.14.129 (8.3.15.1830).

1 стартмани

26.05.2016    46175    765    yojeeg    100    

Генерация кода 1С:8 для создания XML файла

Инструментарий разработчика Обмен через XML v8 1cv8.cf Абонемент ($m)

Внешняя обработка для генерации кода 1С:8, создающего XML файл.

1 стартмани

22.02.2016    12760    74    ily.fomin    5