Фоновое задание с произвольной выборкой и произвольной обработкой

Публикация № 1130127

Разработка - Обработки - Универсальные обработки

21
Данная обработка позволяет производить любые манипуляции с базой, не трогая конфигурацию (за исключением только первого раза, когда мы вносим код самого фонового задания в любой неглобальный общий модуль).

Метод не уникален, есть несколько подобных публикаций, как например //infostart.it-titan.ru/public/437160/, но там многопоточность и все такое. Для обычной же работы требуются более простые вещи - дать фоновому заданию некую выборку и сказать, что с ней следует сделать. Даже проще - выборку оно сделает само, мы лишь подсунем ему текст запроса с параметрами, а требуемые действия также передадим в виде строки. Итак, текст процедур, которые нужно поместить в любой неглобальный общий модуль (или создать свой):


Процедура ГрупповаяОбработка(ПараметрыДлительногоЗадания, АдресХранилища) Экспорт
	
	НачалоОбработки = ТекущаяДата();
	РезультатОбработки = Новый Структура("ОбработаноДокументов, НеУдалосьОбработать, ЗаданиеВыполнено, ТекстСообщения", 0, 0, Ложь, "");
	Запрос = Новый Запрос(ПараметрыДлительногоЗадания.ТекстЗапроса);
	Для Каждого Запись Из ПараметрыДлительногоЗадания.ПараметрыЗапроса Цикл
		Запрос.УстановитьПараметр(Запись.Ключ, Запись.Значение);
	КонецЦикла;
	Выборка = Запрос.Выполнить().Выбрать();
	Действие = ПараметрыДлительногоЗадания.Действие;
	КоличествоСтрок = Выборка.Количество();
	НомерСтроки = 0;
	НачалоСообщения = "Найдено "+КоличествоСтрок+" объектов";
	Пока Выборка.Следующий() Цикл
		НомерСтроки = НомерСтроки + 1;
		ПредставлениеДокумента = Строка(Выборка.Документ);
		Осталось = ПолучитьХодВыполнения(НачалоОбработки, НомерСтроки, КоличествоСтрок);
		Проценты = ""+Окр(НомерСтроки * 100 / КоличествоСтрок, 2)+"%  ";
		ТекстСообщения = НачалоСообщения + Символы.ПС + Проценты + Осталось + Символы.ПС + ПредставлениеДокумента;
		СообщитьХодВыполнения(ТекстСообщения);
		Попытка
			Выполнить(Действие);
			РезультатОбработки.ОбработаноДокументов = РезультатОбработки.ОбработаноДокументов + 1;
			РезультатОбработки.ТекстСообщения = ТекстСообщения;
		Исключение
			РезультатОбработки.НеУдалосьОбработать = РезультатОбработки.НеУдалосьОбработать + 1;
		КонецПопытки;
	КонецЦикла;
	РезультатОбработки.ЗаданиеВыполнено = Истина;
	ПоместитьВоВременноеХранилище(РезультатОбработки, АдресХранилища);
	
КонецПроцедуры

Функция ПолучитьХодВыполнения(НачалоОбработки, НомерСтроки, Количество)
	Затрачено = ТекущаяДата() - НачалоОбработки;
	фч = "ЧЦ=2;ЧН=;ЧВН="; // формат числа
	Осталось = Затрачено * Количество / НомерСтроки - Затрачено; // осталось секунд
	Осталось_текст = "(осталось: "+Строка(Формат(Осталось/3600, фч) + ":"+ Формат(Осталось%3600/60, фч) + ":"+ Формат(Осталось%60, фч))+")";
	Возврат Осталось_текст;
КонецФункции

Процедура СообщитьХодВыполнения(ТекстСообщения) Экспорт
 	Сообщение = Новый СообщениеПользователю;
	Сообщение.Текст = ТекстСообщения;
	Сообщение.Сообщить();
КонецПроцедуры

Самая главная процедура - первая, в ней указаны все наши необходимые параметры - текст запроса, его параметры, и действия с отдельным объектом. Две следующие процедуры служат для отображения прогресса.

Запускается все это добро из внешней обработки, через процедуру

&НаСервере
Функция ОбработкаНаСервере()
	
	ИБФайловая = ОбщегоНазначения.ИнформационнаяБазаФайловая();
	ДлительныеОперации.ОтменитьВыполнениеЗадания(УИДЗаданиеПроведение);
	УИДЗаданиеПроведение = Неопределено;
	
	ПараметрыДлительногоЗадания = ПолучитьПараметрыЗадания();
	
	Если ИБФайловая Тогда
		ДополнительныйОбщийМодуль.ГрупповаяОбработка(ПараметрыДлительногоЗадания, АдресВоВременномХранилище);
		РезультатВыполнения = Новый Структура("ЗаданиеВыполнено", Истина);
	Иначе
		РезультатВыполнения = ДлительныеОперации.ЗапуститьВыполнениеВФоне(УникальныйИдентификатор,
			"ДополнительныйОбщийМодуль.ГрупповаяОбработка", ПараметрыДлительногоЗадания, НСтр("ru = 'Групповая обработка объектов'"));
		АдресВоВременномХранилище = РезультатВыполнения.АдресХранилища;
		УИДЗаданиеПроведение = РезультатВыполнения.ИдентификаторЗадания;
	КонецЕсли;
	
	Возврат РезультатВыполнения;
	
КонецФункции

Результат можно увидеть на приложенной картинке.

В качестве ДополнительныйОбщийМодуль в этой процедуре может выступать любой, куда вы поместите фоновое задание.

Какие преимущества? Текст запроса задаем на клиенте, параметры тоже, действия тоже. Сегодня перепроводим счета-фактуры и перенумеруем ПКО, завтра обрабатываем справочник "Контрагенты", послезавтра обрабатываем поступления, у которых БУ и НУ по 90 счету совпадает - в фоновом задании ничего не требуется переделывать, только во внешней обработке.

Недостатки - не подходит пользователям: чтобы править запрос, нужен конфигуратор, то есть обработка предназначена для программистов. Можно, конечно, вынести текст запроса на форму и задавать там, но и здесь потребуются знания, которые есть только у программиста.

Да, понимаю, что по сути это дыра в безопасности (по крайней мере можно много чего нехорошего сделать), но таких дыр там и без меня навалом (любая внешняя обработка, с обращением к некоторым методам типовой кофигурации, тоже может натворить тех еще делов). То есть с действиями типа Объект.Удалить нужно обращаться очень аккуратно. В общем, на свой страх и риск.

Разрабатывалось все под слегка измененную БП 3.0 (релиз 3.0.55.14, платформа 8.3.10.2299), но на типовой тоже пойдет. На других типовых вроде УТ или УПП тоже должно, по крайней мере если у вас есть модуль ДлительныеОперации.

Обработка приложена к публикации, модуль фонового задания (который приведен выше) лежит в макетах, его потребуется закинуть в один из неглобальных общих модулей (и в обработке указать путь к нему) или же создать свой.

21

Скачать файлы

Наименование Файл Версия Размер
Фоновое задание с произвольной выборкой и произвольной обработкой:
.epf 10,81Kb
02.10.19
2
.epf 10,81Kb 2 Скачать

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо
1. AlexandrSmith 47 03.10.19 22:34 Сейчас в теме
Хорошо что вы текст печатаете можно самому попробовать, поиграться. Без покупки, но лайк, я поставил.
2. dmalyshev 22 09.10.19 10:20 Сейчас в теме
Почему механизм дополнительных внешних обработок не подошел, которые запускаются по расписанию?
user774630; +1 Ответить
3. warden 101 09.10.19 14:57 Сейчас в теме
(2) Здесь речь не про работу по расписанию, а про возможность любой код выполнить в фоне, к любой выборке, и еще следить за прогрессом.
4. bulldog 11.10.19 14:25 Сейчас в теме
можно подробнее о процедурах в обработке? как получать сообщения с фонового задания?
5. warden 101 17.10.19 15:59 Сейчас в теме
(4)Легко. За это отвечают 2 процедуры:

&НаКлиенте
Процедура Подключаемый_ПроверитьВыполнение()
	
	Попытка
		Если ЗаданиеВыполнено(УИДЗаданиеПроведение) Тогда
			ВывестиРезультатФоновогоЗадания();
			Элементы.ТабДок.ОтображениеСостояния.ДополнительныйРежимОтображения = ДополнительныйРежимОтображения.НеИспользовать;
			Элементы.ТабДок.ОтображениеСостояния.Текст = ТекстПоследнегоСообщения;
			Элементы.ТабДок.ОтображениеСостояния.Картинка = БиблиотекаКартинок.ЗеленаяГалка;
		Иначе
			ДлительныеОперацииКлиент.ОбновитьПараметрыОбработчикаОжидания(ПараметрыОбработчикаОжидания);
			ПодключитьОбработчикОжидания("Подключаемый_ПроверитьВыполнение", ПараметрыОбработчикаОжидания.ТекущийИнтервал, Истина);
			ПолучитьПоследнееСообщениеФоновогоЗадания(УИДЗаданиеПроведение);
			Элементы.ТабДок.ОтображениеСостояния.Видимость = Истина;
			Элементы.ТабДок.ОтображениеСостояния.ДополнительныйРежимОтображения = ДополнительныйРежимОтображения.Неактуальность;
			Элементы.ТабДок.ОтображениеСостояния.Текст = ТекстПоследнегоСообщения;
			Элементы.ТабДок.ОтображениеСостояния.Картинка = БиблиотекаКартинок.ДлительнаяОперация48;
		КонецЕсли;
	Исключение
		ВызватьИсключение;
	КонецПопытки;
	
КонецПроцедуры

&НаСервере
Процедура ПолучитьПоследнееСообщениеФоновогоЗадания(УИДЗадания)
	
	Задание = ФоновыеЗадания.НайтиПоУникальномуИдентификатору(УИДЗадания);
	Если Задание = Неопределено Тогда
		Возврат;
	КонецЕсли;
	МассивСообщений = Задание.ПолучитьСообщенияПользователю(Ложь);
	Если МассивСообщений = Неопределено Тогда
		Возврат;
	КонецЕсли;
	Для Каждого Сообщение Из МассивСообщений Цикл
		ТекстПоследнегоСообщения = Сообщение.Текст;
	КонецЦикла;
	
КонецПроцедуры
Показать


Здесь ТекстПоследнегоСообщения - реквизит формы, из него берутся данные для отображения на табличном документе. Сама работа с табдоком тоже здесь.
Оставьте свое сообщение

См. также

Распознавание сканов паспортов 1

Инструменты и обработки Программист Пользователь Архив с данными v8 v8::УФ 1cv8.cf Windows Абонемент ($m) Универсальные обработки

Распознавание сканов паспортов с использованием API Гугла для распознавания текста сканов и API DaData для некоторых дополнительных функций. На выходе получается список формализованных полей (серия, номер, дата выдачи, код и наименование подразделения, выдавшего паспорт, ФИО владельца и его дата рождения). Паспорт распознается независимо от наличия машино-читаемой строки, однако при её наличии вероятность ошибок распознавания резко снижается

10 стартмани

вчера в 00:00    329    Torin99    2       

Подборка решений для взаимодействия со ФГИС «Меркурий» Промо

С 1 июля 2019 года все компании, участвующие в обороте товаров животного происхождения, должны перейти на электронную ветеринарную сертификацию (ЭВС) через ФГИС «Меркурий». Инфостарт предлагает подборку программ, связанных с этим изменением.

Поиск ячеек по заданной сумме 4

Инструменты и обработки Бухгалтер Пользователь Внешняя обработка (ert,epf) v8 v8::УФ 1cv8.cf Windows Абонемент ($m) Универсальные обработки

Внешняя обработка для поиска ячеек, сумма которых равна заданной сумме. Бывает, когда отчет расходится на некую сумму и невозможно её найти, так как она состоит из нескольких сумм. Данная обработка проверят все ячейки на сумму и если их сумма равна искомой сумме, обработка выводит имена этих ячеек в таблицу ниже и выделят их зеленым цветом. Работает на любой конфигурации на управляемых формах.

1 стартмани

04.12.2019    290    APTEM_SLV    0       

1СПАРК РИСКИ. Сервис оценки благонадежности контрагентов. Промо

СПАРК помогает предотвратить мошенничество со стороны компаний и предпринимателей, благодаря актуальным сведениям о компаниях и системе выявления факторов риска.Сервис позволяет управлять налоговыми рисками и комплексно оценивать благонадежность контрагентов.

Универсальная обработка (УФ) для работы с журналом регистрации в формате SQLite через ODBC 6

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 v8::УФ 1cv8.cf Абонемент ($m) Универсальные обработки Журнал регистрации

Обработка позволяет подключиться к журналу регистрации в формате SQLite (.lgd) через ODBC и прочитать его события в привычном виде, как в стандартном журнале.

1 стартмани

27.11.2019    523    1    Spartacus    2       

Ссылка по ГУИДам 1

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 v8::УФ 1cv8.cf Россия Windows Абонемент ($m) Поиск данных Универсальные обработки

Универсальная обработка для получения ссылки по различным уникальным идентификаторам (UID для sql, GUID, ...) и обратно.

1 стартмани

07.11.2019    1997    2    alfir70    9       

Онлайн-интенсив "Бизнес-процессы для подготовки к экзамену 1С:Специалист по платформе" 12 декабря 2019 г. Промо

На интенсиве будут рассмотрены все теоретические вопросы, связанные с устройством механизма бизнес-процессов – это необходимо для успешной сдачи экзамена 1С:Специалист по платформе. Также, в качестве практического примера, будет решена задача, аналогичная экзаменационной.

777 рублей

"Все функции" с плюшками 16

Отчеты и формы Программист Пользователь Внешняя обработка (ert,epf) v8 v8::УФ 1cv8.cf Абонемент ($m) Универсальные обработки Работа с интерфейсом

Замена штатному меню для тех, кто хочет открывать "Все функции" быстро и кто скучает по быстрому позиционированию по первым символам как было раньше

1 стартмани

06.11.2019    2204    14    codejs    6       

Вакансия Автор новостных обзоров на тему 1С и бухучета, По совместительству Промо

Редакция Infostart.ru будет рада сотрудничеству с 1С-специалистом, умеющим и любящим излагать свои мысли в письменной форме. Если вы работали в IT-изданиях или имеете опыт ведения технологического блога/канала/группы, если сможете сделать обзор обработок из каталога infostart.ru/public/all/, то у вас большое преимущество.

Генерация QR кода для любых конфигураций 1С (обычные и управляемые формы) 8

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 v8::УФ 1cv8.cf Абонемент ($m) Универсальные обработки Универсальные функции

Для генерации используется компонента типовой конфигурации УТ11, встроенная в общий макет "КомпонентаПечатиQRКода". Ниже приведены процедуры, чтобы сделать обработку самостоятельно (только для УФ).

1 стартмани

11.10.2019    1701    12    dm1try    0       

Перенос данных КА 1.1 / УПП 1.3 => БП 3.0 (перенос остатков, документов и справочников из "1С:Комплексная автоматизация 1.1" / УПП 1.3 в "1С:Бухгалтерия 3.0"). Обновлен до версий КА 1.1.115.х, УПП 1.3.127.х! Промо

Разработка позволяет перенести остатки по всем счетам бух.учета в программу "1С:Бухгалтерия предприятия 8", ред. 3.0 на выбранную дату начала ведения учета. Также переносятся документы за период и вся необходимая справочная информация. Правила оперативно обновляю при выходе новых релизов. Рассылка обновлений правил бесплатно в течение 12 месяцев. Есть видеодемонстрация проведения переноса данных. Конфигурации при использовании обмена остаются полностью типовыми. Перенос данных возможен в Бухгалтерию 3.0 версии ПРОФ, КОРП или базовую.

24700 руб.

Универсальный шаблон многопоточной обработки (на примере проверки работы Web-сервисов) 8

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 v8::УФ 1cv8.cf Абонемент ($m) Универсальные обработки

Работает в обычных и управляемых формах, в фоновом многопоточном режиме, отображает прогресс выполнения по каждому потоку пользователю. Из этого шаблона можно создать многопоточную обработку любой сложности и вида для обработки массива данных по заданному алгоритму.

3 стартмани

17.09.2019    1242    3    1C_Casual    4       

Универсальная выгрузка, загрузка зарегистрированных объектов по узлу 2

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 v8::УФ 1cv8.cf Россия Windows Абонемент ($m) Универсальные обработки

Набор обработок дает возможность выгружать и загружать регистрацию по узлу справочников и документов.

1 стартмани

16.09.2019    989    2    байт    2       

Перенос данных УПП 1.3 => ERP 2 (ЕРП) / УТ 11 / КА 2.х (обработка переноса документов, остатков и справочников из "1С:Управление производственным предприятием, ред. 1.3" в ERP / УТ 11 / КА 2). Обновлен до УПП 1.3.127.х, КА 2.4.10.х и ERP 2.4.10.х! Промо

Обработка позволяет переносить из УПП 1.3 в ERP 2 документы за выбранный период и остатки. Типовая обработка от фирмы 1С документы не переносит. Также исправлены ошибки типовой обработки. При выходе новых релизов обновление высылается бесплатно в течение года. Разработка будет полезна фирмам-франчайзи, которые периодически выполняют такой перенос данных для заказчиков. Вы можете один раз приобрести обработку переноса, и потом бесплатно получать обновления при выходе новых релизов конфигураций 1С.

29700 руб.

Управление информационной базой на кластере (управляемые формы): просмотр сеансов, отключение сеансов, блокировка / разблокировка подключений 3

Инструменты и обработки Системный администратор Программист Внешняя обработка (ert,epf) v8 v8::УФ 1cv8.cf Абонемент ($m) Сервисные утилиты Администрирование данных 1С Универсальные обработки

Обработка предназначена для управления информационной базой на кластере 1С. Может применяться для автоматизированного выполнения регламентных процедур, когда требуется выгнать пользователей, заблокировать вход в базу.

1 стартмани

11.09.2019    1239    4    Spartacus    0       

Универсальная форма объектов (для УФ) 4

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 v8::УФ 1cv8.cf Россия Абонемент ($m) Универсальные обработки

Обработка позволяет открывать любые документы или справочники, игнорируя логику, заданную в конфигурации.

1 стартмани

29.08.2019    1438    2    Ihty    0       

С 2020 года сервис «Продление поддержки конфигурации 1С:УПП» подорожает вдвое Промо

Успейте продлить поддержку УПП до повышения цен! Фирма «1С» предупредила об изменении цен на сервис «Продление поддержки конфигурации "1С:Управление производственным предприятием"». С 1 января 2020 года сервис подорожает в два раза.

Преобразование ссылки управляемой формы во внутренний уникальный идентификатор и обратно 2

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 v8::УФ 1cv8.cf Абонемент ($m) Универсальные обработки

Обработка позволяет быстро получить ссылку управляемой формы или уникальный идентификатор через ссылку на объект (справочник, документ). Или в обратном порядке через ссылку управляемой формы или уникальный идентификатор.

1 стартмани

12.08.2019    1061    1    infostartchel    0       

Пометка требуемого количества помеченных объектов для удаления при выборочном варианте удаления 1

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 v8::УФ УНФ ЗКГУ3.0 БП3.0 УТ11 ЗУП3.x Россия Абонемент ($m) Универсальные обработки

Данная обработка выполняет установку требуемого количества галочек помеченных на удаление объектов в направлении вверх / вниз от текущего объекта в форме "Удаление помеченных объектов" с целью их дальнейшего удаления.

1 стартмани

05.08.2019    1189    1    its_33    0       

Подборка программ для взаимодействия с ЕГАИС Промо

ЕГАИС (Единая государственная автоматизированная информационная система) - автоматизированная система, предназначенная для государственного контроля за объёмом производства и оборота этилового спирта, алкогольной и спиртосодержащей продукции. Инфостарт рекомендует подборку проверенных решений для взаимодействия с системой.

Обнуление регистров 2

Инструменты и обработки Программист Пользователь Внешняя обработка (ert,epf) v8::БУ v8::ОУ v8::УФ 1cv8.cf Россия БУ УУ Абонемент ($m) Универсальные обработки

Внешняя обработка для сторнирования остатков регистра Бухгалтерии (Хозрасчетный) и Накопления; очистка регистров сведений.

2 стартмани

02.08.2019    1250    3    powar    0       

Сравнение функциональных опций 2

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 v8::УФ 1cv8.cf Россия Абонемент ($m) Универсальные обработки

Обработка позволяет сравнить значения функциональных опций через файл табличного документа (mxl). Сравниваются значения, хранимые константах, справочниках и регистрах сведений.

1 стартмани

26.07.2019    1123    boris.danilin    1       

Очный семинар по регулярному менеджменту Александра Фридмана "Вы или Хаос", 12 декабря 2019 г. , Санкт-Петербург Промо

Семинар по регулярному менеджменту от Александра Фридмана для собственников, первых лиц и топов. Технология управленческого планирования, комплексного управления временем и другими ресурсами, выполнением поручений, делами, информацией, контактами (встречи-звонки-почта).

от 11000 до 29000 рублей

Загрузка дополнительных реквизитов и сведений 6

Инструменты и обработки no Внешняя обработка (ert,epf) v8::УФ 1cv8.cf Россия Абонемент ($m) Обработка документов Универсальные обработки Обработка справочников

Обработка по загрузке произвольных значений в произвольные дополнительные реквизиты и сведения объектов системы с возможностью настраиваемого поиска объектов для загрузки. (Управляемые формы)

2 стартмани

17.07.2019    1613    7    navic    0       

Редактирование объектов и движений документов 4

Инструменты и обработки Программист Пользователь Внешняя обработка (ert,epf) v8 v8::УФ 1cv8.cf Абонемент ($m) Обработка документов Универсальные обработки Обработка справочников

Редактирование реквизитов и табличных частей объектов (справочники, документы, пвх, планы счетов, пвр, бизнес-процессы, задачи) и движений документов (управляемая форма)

1 стартмани

17.07.2019    1596    14    anreko    5       

Перенос данных БП 2.0 => УТ 11 / КА 2 / ERP 2 (перенос остатков, документов и справочников из "1С:Бухгалтерия предприятия 8", ред. 2.0 в "1С:Управление торговлей 8", ред.11 / КА 2 / ERP 2). Обновлено до УТ 11.4.10.х, КА 2.4.10.х, ERP 2.4.10.х! Промо

Перенос позволяет загрузить в УТ 11 / КА 2 / ERP 2 документы за выбранный период, справочную информацию и остатки по счетам бух. учета. Переносятся остатки денежных средств, взаиморасчетов, остатки товаров и материалов на складах. Переносятся девятнадцать основных видов документов за выбранный период и вся нормативно-справочная информация. Есть фильтр по организации. Если нужно переносить что-то дополнительно, то обычно бесплатно дорабатываю правила (перед покупкой согласуйте необходимые доработки).

29700 руб.

Markdown-editor в 1С (с сохранением в HTML) 44

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8::УФ 1cv8.cf Абонемент ($m) Универсальные обработки

В этой обработке вы пишете свой текст, используя синтаксис Markdown, а на выходе получаете чистый HTML-код, избавленный от JS-библиотеки, которая его сформировала.

1 стартмани

04.07.2019    3444    12    riposte    3       

Разбор маркировки табачной продукции 6

Инструменты и обработки Программист Пользователь Внешняя обработка (ert,epf) v8 v8::УФ 1cv8.cf Розничная и сетевая торговля (FMCG) Оптовая торговля, дистрибуция, логистика Россия Windows Оптовая торговля Розничная торговля Абонемент ($m) Универсальные обработки

Вытаскиваем максимум информации из маркировки сигарет. Максимум включает: признак групповой упаковки, GTIN, код идентификации упаковки, МРЦ, признак тестовой маркировки.

3 стартмани

02.07.2019    2176    2    philya    3       

Онлайн-курс "Технология выполнения проектов ERP-класса – процессный подход". Третий поток. Курс проходит с 21 января по 18 марта 2020 года. Промо

Курс разработан Внедренческим центром «Раздолье». Курс предназначен для подготовки аналитиков, архитекторов и руководителей проектов автоматизации процессов управления с использованием комплексных ИТ-систем (1С:ERP, 1С:УХ, 1С:КА, 1С:УТ). В основе курса лежит методика применения процессного подхода.

9000 рублей

Чат (мессенджер) для управляемых форм 1С 8.3 (Расширение) 14

Инструменты и обработки no Расширение (cfe) v8 v8::УФ 1cv8.cf Абонемент ($m) Универсальные обработки

Представляю вам чат для управляемых форм платформы 8.3. Давно сталкивался с тем, что просят открыть какой-нибудь документ или справочник, тебе скидывают его номер или название, а ты потом ищешь его по базе. Вам это знакомо? Тогда этот чат для вас. Подробности ниже.

4 стартмани

27.06.2019    4500    8    Isa816    23       

Сравнение объектов между собой (справочников и документов) и вывод в табличный документ (управляемые формы) 3

Инструменты и обработки Программист Пользователь Внешняя обработка (ert,epf) v8 v8::УФ ERP2 УТ11 КА2 Абонемент ($m) Универсальные обработки

Данная обработка позволяет сравнить между собой любые справочники и документы как одного вида, так и разных и вывести в табличный документ для дальнейшего анализа.

1 стартмани

25.06.2019    1617    4    Dadriel619960    0       

Новый раздел на Инфостарте - Electronic Software Distribution Промо

Инфостарт напоминает: на нашем сайте можно купить не только ПО, связанное с 1С. В нашем арсенале – ESD-лицензии на ПО от ведущих вендоров: Microsoft, Kaspersky, ESET, Dr.Web, Аскон и другие.

  • Низкие цены, без скрытых платежей и наценок
  • Оперативная отгрузка
  • Возможность оплаты с личного счета (кешбек, обмен стартмани на рубли и т.п.)
  • Покупки идут в накопления для получения скидочных карт лояльности Silver (5%) и Gold (10%)

Инвентаризация остатков ЕГАИС по регистру № 1 4

Инструменты и обработки Бухгалтер Пользователь Внешняя обработка (ert,epf) v8::УФ Розница Розничная и сетевая торговля (FMCG) Рестораны, кафе и фаст-фуд Россия БУ УУ Учет ТМЦ Абонемент ($m) Универсальные обработки

Обработка предназначена для удобной инвентаризации остатков ЕГАИС по регистру № 1 с возможностью сканирования марок с бутылки. Розница 2.2 (8.3.13.1644) релиз 2.2.11.29 (а так же 2.2.12.30, 2.2.13.12).

2 стартмани

11.06.2019    2046    8    user952874    8       

Работа с файлами (обычная и управляемая форма) 88

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 v8::УФ 1cv8.cf Абонемент ($m) Универсальные обработки

Нужно загрузить файл с клиента на сервер или же, наоборот, файл загрузить с сервера на клиент, а впридачу все это на web-клиенте, да еще и асинхронно? Нет ничего проще, читай далее, как это сделать!

1 стартмани

10.06.2019    7895    58    Xershi    40