Фоновое задание с произвольной выборкой и произвольной обработкой

Публикация № 1130127

Разработка - Обработки - Универсальные обработки

Данная обработка позволяет производить любые манипуляции с базой, не трогая конфигурацию (за исключением только первого раза, когда мы вносим код самого фонового задания в любой неглобальный общий модуль).

Метод не уникален, есть несколько подобных публикаций, как например //infostart.it-titan.ru/public/437160/, но там многопоточность и все такое. Для обычной же работы требуются более простые вещи - дать фоновому заданию некую выборку и сказать, что с ней следует сделать. Даже проще - выборку оно сделает само, мы лишь подсунем ему текст запроса с параметрами, а требуемые действия также передадим в виде строки. Итак, текст процедур, которые нужно поместить в любой неглобальный общий модуль (или создать свой):


Процедура ГрупповаяОбработка(ПараметрыДлительногоЗадания, АдресХранилища) Экспорт
	
	НачалоОбработки = ТекущаяДата();
	РезультатОбработки = Новый Структура("ОбработаноДокументов, НеУдалосьОбработать, ЗаданиеВыполнено, ТекстСообщения", 0, 0, Ложь, "");
	Запрос = Новый Запрос(ПараметрыДлительногоЗадания.ТекстЗапроса);
	Для Каждого Запись Из ПараметрыДлительногоЗадания.ПараметрыЗапроса Цикл
		Запрос.УстановитьПараметр(Запись.Ключ, Запись.Значение);
	КонецЦикла;
	Выборка = Запрос.Выполнить().Выбрать();
	Действие = ПараметрыДлительногоЗадания.Действие;
	КоличествоСтрок = Выборка.Количество();
	НомерСтроки = 0;
	НачалоСообщения = "Найдено "+КоличествоСтрок+" объектов";
	Пока Выборка.Следующий() Цикл
		НомерСтроки = НомерСтроки + 1;
		ПредставлениеДокумента = Строка(Выборка.Документ);
		Осталось = ПолучитьХодВыполнения(НачалоОбработки, НомерСтроки, КоличествоСтрок);
		Проценты = ""+Окр(НомерСтроки * 100 / КоличествоСтрок, 2)+"%  ";
		ТекстСообщения = НачалоСообщения + Символы.ПС + Проценты + Осталось + Символы.ПС + ПредставлениеДокумента;
		СообщитьХодВыполнения(ТекстСообщения);
		Попытка
			Выполнить(Действие);
			РезультатОбработки.ОбработаноДокументов = РезультатОбработки.ОбработаноДокументов + 1;
			РезультатОбработки.ТекстСообщения = ТекстСообщения;
		Исключение
			РезультатОбработки.НеУдалосьОбработать = РезультатОбработки.НеУдалосьОбработать + 1;
		КонецПопытки;
	КонецЦикла;
	РезультатОбработки.ЗаданиеВыполнено = Истина;
	ПоместитьВоВременноеХранилище(РезультатОбработки, АдресХранилища);
	
КонецПроцедуры

Функция ПолучитьХодВыполнения(НачалоОбработки, НомерСтроки, Количество)
	Затрачено = ТекущаяДата() - НачалоОбработки;
	фч = "ЧЦ=2;ЧН=;ЧВН="; // формат числа
	Осталось = Затрачено * Количество / НомерСтроки - Затрачено; // осталось секунд
	Осталось_текст = "(осталось: "+Строка(Формат(Осталось/3600, фч) + ":"+ Формат(Осталось%3600/60, фч) + ":"+ Формат(Осталось%60, фч))+")";
	Возврат Осталось_текст;
КонецФункции

Процедура СообщитьХодВыполнения(ТекстСообщения) Экспорт
 	Сообщение = Новый СообщениеПользователю;
	Сообщение.Текст = ТекстСообщения;
	Сообщение.Сообщить();
КонецПроцедуры

Самая главная процедура - первая, в ней указаны все наши необходимые параметры - текст запроса, его параметры, и действия с отдельным объектом. Две следующие процедуры служат для отображения прогресса.

Запускается все это добро из внешней обработки, через процедуру

&НаСервере
Функция ОбработкаНаСервере()
	
	ИБФайловая = ОбщегоНазначения.ИнформационнаяБазаФайловая();
	ДлительныеОперации.ОтменитьВыполнениеЗадания(УИДЗаданиеПроведение);
	УИДЗаданиеПроведение = Неопределено;
	
	ПараметрыДлительногоЗадания = ПолучитьПараметрыЗадания();
	
	Если ИБФайловая Тогда
		ДополнительныйОбщийМодуль.ГрупповаяОбработка(ПараметрыДлительногоЗадания, АдресВоВременномХранилище);
		РезультатВыполнения = Новый Структура("ЗаданиеВыполнено", Истина);
	Иначе
		РезультатВыполнения = ДлительныеОперации.ЗапуститьВыполнениеВФоне(УникальныйИдентификатор,
			"ДополнительныйОбщийМодуль.ГрупповаяОбработка", ПараметрыДлительногоЗадания, НСтр("ru = 'Групповая обработка объектов'"));
		АдресВоВременномХранилище = РезультатВыполнения.АдресХранилища;
		УИДЗаданиеПроведение = РезультатВыполнения.ИдентификаторЗадания;
	КонецЕсли;
	
	Возврат РезультатВыполнения;
	
КонецФункции

Результат можно увидеть на приложенной картинке.

В качестве ДополнительныйОбщийМодуль в этой процедуре может выступать любой, куда вы поместите фоновое задание.

Какие преимущества? Текст запроса задаем на клиенте, параметры тоже, действия тоже. Сегодня перепроводим счета-фактуры и перенумеруем ПКО, завтра обрабатываем справочник "Контрагенты", послезавтра обрабатываем поступления, у которых БУ и НУ по 90 счету совпадает - в фоновом задании ничего не требуется переделывать, только во внешней обработке.

Недостатки - не подходит пользователям: чтобы править запрос, нужен конфигуратор, то есть обработка предназначена для программистов. Можно, конечно, вынести текст запроса на форму и задавать там, но и здесь потребуются знания, которые есть только у программиста.

Да, понимаю, что по сути это дыра в безопасности (по крайней мере можно много чего нехорошего сделать), но таких дыр там и без меня навалом (любая внешняя обработка, с обращением к некоторым методам типовой кофигурации, тоже может натворить тех еще делов). То есть с действиями типа Объект.Удалить нужно обращаться очень аккуратно. В общем, на свой страх и риск.

Разрабатывалось все под слегка измененную БП 3.0 (релиз 3.0.55.14, платформа 8.3.10.2299), но на типовой тоже пойдет. На других типовых вроде УТ или УПП тоже должно, по крайней мере если у вас есть модуль ДлительныеОперации.

Обработка приложена к публикации, модуль фонового задания (который приведен выше) лежит в макетах, его потребуется закинуть в один из неглобальных общих модулей (и в обработке указать путь к нему) или же создать свой.

Скачать файлы

Наименование Файл Версия Размер
Фоновое задание с произвольной выборкой и произвольной обработкой:
.epf 10,81Kb
02.10.19
2
.epf 10,81Kb 2 Скачать

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо
1. AlexandrSmith 54 03.10.19 22:34 Сейчас в теме
Хорошо что вы текст печатаете можно самому попробовать, поиграться. Без покупки, но лайк, я поставил.
2. dmalyshev 22 09.10.19 10:20 Сейчас в теме
Почему механизм дополнительных внешних обработок не подошел, которые запускаются по расписанию?
user774630; +1 Ответить
3. warden 101 09.10.19 14:57 Сейчас в теме
(2) Здесь речь не про работу по расписанию, а про возможность любой код выполнить в фоне, к любой выборке, и еще следить за прогрессом.
4. bulldog 11.10.19 14:25 Сейчас в теме
можно подробнее о процедурах в обработке? как получать сообщения с фонового задания?
5. warden 101 17.10.19 15:59 Сейчас в теме
(4)Легко. За это отвечают 2 процедуры:

&НаКлиенте
Процедура Подключаемый_ПроверитьВыполнение()
	
	Попытка
		Если ЗаданиеВыполнено(УИДЗаданиеПроведение) Тогда
			ВывестиРезультатФоновогоЗадания();
			Элементы.ТабДок.ОтображениеСостояния.ДополнительныйРежимОтображения = ДополнительныйРежимОтображения.НеИспользовать;
			Элементы.ТабДок.ОтображениеСостояния.Текст = ТекстПоследнегоСообщения;
			Элементы.ТабДок.ОтображениеСостояния.Картинка = БиблиотекаКартинок.ЗеленаяГалка;
		Иначе
			ДлительныеОперацииКлиент.ОбновитьПараметрыОбработчикаОжидания(ПараметрыОбработчикаОжидания);
			ПодключитьОбработчикОжидания("Подключаемый_ПроверитьВыполнение", ПараметрыОбработчикаОжидания.ТекущийИнтервал, Истина);
			ПолучитьПоследнееСообщениеФоновогоЗадания(УИДЗаданиеПроведение);
			Элементы.ТабДок.ОтображениеСостояния.Видимость = Истина;
			Элементы.ТабДок.ОтображениеСостояния.ДополнительныйРежимОтображения = ДополнительныйРежимОтображения.Неактуальность;
			Элементы.ТабДок.ОтображениеСостояния.Текст = ТекстПоследнегоСообщения;
			Элементы.ТабДок.ОтображениеСостояния.Картинка = БиблиотекаКартинок.ДлительнаяОперация48;
		КонецЕсли;
	Исключение
		ВызватьИсключение;
	КонецПопытки;
	
КонецПроцедуры

&НаСервере
Процедура ПолучитьПоследнееСообщениеФоновогоЗадания(УИДЗадания)
	
	Задание = ФоновыеЗадания.НайтиПоУникальномуИдентификатору(УИДЗадания);
	Если Задание = Неопределено Тогда
		Возврат;
	КонецЕсли;
	МассивСообщений = Задание.ПолучитьСообщенияПользователю(Ложь);
	Если МассивСообщений = Неопределено Тогда
		Возврат;
	КонецЕсли;
	Для Каждого Сообщение Из МассивСообщений Цикл
		ТекстПоследнегоСообщения = Сообщение.Текст;
	КонецЦикла;
	
КонецПроцедуры
Показать


Здесь ТекстПоследнегоСообщения - реквизит формы, из него берутся данные для отображения на табличном документе. Сама работа с табдоком тоже здесь.
Оставьте свое сообщение

См. также

Просмотр данных объекта

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 v8::УФ 1cv8.cf Абонемент ($m) Структура метаданных Универсальные обработки

Просмотр данных объектов ссылочного типа: элементов справочников, документов, бизнес-процессов, задач.

1 стартмани

18.02.2020    302    armeec    1       

Базовый курс по обмену данными в системе 1С:Предприятие. Онлайн-интенсив с 12 по 28 мая 2020 г. Промо

Данный онлайн-курс предусматривает изучение механизмов платформы “1С:Предприятие”, обеспечивающих обмен данными между различными прикладными 1С-решениями и взаимодействие с другими информационными системами. Курс предназначен для тех, кто уже имеет определенные навыки конфигурирования и программирования в системе “1С:Предприятие”.

5500 рублей

Универсальный отчет по документам "Документы в разрезе"

Отчеты и формы Бухгалтер Пользователь Внешний отчет (ert,erf) v8 v8::УФ 1cv8.cf Россия Абонемент ($m) Универсальные обработки

Универсальный отчет по документам, для платформы 1С8.3.хх УФ, позволяет получить отчет в виде двумерной таблицы в почти произвольных разрезах. В некоторых случаях очень удобен. Реинкарнация моего отчета для 1С7.7 - https://infostart.ru/public/59594/

1 стартмани

28.01.2020    577    3    pophmail    3       

Копирование настроек констант между ИБ (COM-соединение) (обычные и управляемые формы)

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 v8::УФ 1cv8.cf Абонемент ($m) Универсальные обработки Перенос данных из 1C8 в 1C8

Обработка (универсальная) предназначена для просмотра и копирования значений констант между ИБ через COM-соединение.

1 стартмани

27.01.2020    541    Diana.dedov.91    0       

Онлайн-курс "Подготовка к экзамену 1С:Эксперт и 1С:Профессионал по технологическим вопросам" с 7 по 24 апреля 2020 г. Промо

На курсе вы получите практические навыки решения задач производительности 1С, в том числе характерных для высоконагруженных информационных систем (более 1000 пользователей). Подготовка к экзамену – только одна из составляющих курса. 70% слушателей приходят за знаниями, которые позволят расти и зарабатывать, делать сложные задачи на крупных проектах.

16450 рублей

Сохранение в каталог дополнительных обработок, отчетов, печатных форм и т.д.

Инструменты и обработки no Внешняя обработка (ert,epf) v8 v8::УФ 1cv8.cf Россия Windows Абонемент ($m) Универсальные обработки

Все дополнительные обработки, отчеты, печатные формы сохраняются в каталоге при нажатии одной кнопки.

1 стартмани

20.01.2020    682    Margo462    0       

Редактор независимых регистров сведений 8.3

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 v8::УФ 1cv8.cf Россия Windows Абонемент ($m) Инструментарий разработчика Универсальные обработки

Универсальная внешняя обработка для редактирования независимых регистров сведений. Работа с отдельными записями и с наборами записей. Выгрузка отдельных записей, наборов и всего регистра в формате XML. Платформа 8.3, управляемые формы. Версия 1.003 от 12.01.2020.

2 стартмани

13.01.2020    991    12    ROL32    0       

Голосование за доклады на INFOSTART MEETUP Kazan - до 25 февраля. Промо

Выбирайте и голосуйте за самые интересные доклады! Лучшие из лучших попадут в окончательную программу казанского митапа. Оставить свой голос можно до 25 февраля 2020 года.

Удаленное администрирование (AmmyAdmin)

Инструменты и обработки no Внешняя обработка (ert,epf) v8 v8::УФ 1cv8.cf Windows Абонемент ($m) Универсальные обработки Удаленное управление

Разрабатывалась для "малоопытных пользователей", которым сложно понять/найти программу, которую их просят запустить. Данную обработку легко интегрировать в любую конфигурацию и вывести кнопку запуска в удобное место. Либо просто запустить через меню: Файл -> Открыть.

1 стартмани

09.01.2020    3966    4    impulse_1010    18       

Новый раздел на Инфостарте - Electronic Software Distribution Промо

Инфостарт напоминает: на нашем сайте можно купить не только ПО, связанное с 1С. В нашем арсенале – ESD-лицензии на ПО от ведущих вендоров: Microsoft, Kaspersky, ESET, Dr.Web, Аскон и другие.

  • Низкие цены, без скрытых платежей и наценок
  • Оперативная отгрузка
  • Возможность оплаты с личного счета (кешбек, обмен стартмани на рубли и т.п.)
  • Покупки идут в накопления для получения скидочных карт лояльности Silver (5%) и Gold (10%)

Просмотр значений реквизитов объекта

Отчеты и формы Программист Внешняя обработка (ert,epf) v8 v8::УФ 1cv8.cf Абонемент ($m) Универсальные обработки

Позволяет просматривать значения всех реквизитов и табличных частей любого объекта конфигурации.

1 стартмани

16.12.2019    822    gorevg    0       

Программы для исполнения 488-ФЗ: Маркировка товаров Промо

1 января 2019 года вступил в силу ФЗ от 25.12.2018 № 488-ФЗ о единой информационной системе маркировки товаров с использованием контрольных (идентификационных) знаков, который позволяет проследить движение товара от производителя до конечного потребителя. Инфостарт предлагает подборку программ, связанных с применением 488-ФЗ и маркировкой товаров.

Распознавание сканов паспортов

Инструменты и обработки Программист Пользователь Архив с данными v8 v8::УФ 1cv8.cf Windows Абонемент ($m) Универсальные обработки

Распознавание сканов паспортов с использованием API Гугла для распознавания текста сканов и API DaData для некоторых дополнительных функций. На выходе получается список формализованных полей (серия, номер, дата выдачи, код и наименование подразделения, выдавшего паспорт, ФИО владельца и его дата рождения). Паспорт распознается независимо от наличия машино-читаемой строки, однако при её наличии вероятность ошибок распознавания резко снижается

10 стартмани

07.12.2019    2047    1    Torin99    43       

Поиск ячеек по заданной сумме

Инструменты и обработки Бухгалтер Пользователь Внешняя обработка (ert,epf) v8 v8::УФ 1cv8.cf Windows Абонемент ($m) Универсальные обработки

Внешняя обработка для поиска ячеек, сумма которых равна заданной сумме. Бывает, когда отчет расходится на некую сумму и невозможно её найти, так как она состоит из нескольких сумм. Данная обработка проверят все ячейки на сумму и если их сумма равна искомой сумме, обработка выводит имена этих ячеек в таблицу ниже и выделят их зеленым цветом. Работает на любой конфигурации на управляемых формах.

1 стартмани

04.12.2019    1013    1    APTEM_SLV    4       

1C:Предприятие для программистов: Расчетные задачи (зарплата). Онлайн-интенсив с 01 по 17 июня 2020 г. Промо

Данный онлайн-курс предусматривает изучение механизмов платформы “1С:Предприятие”, которые предназначены для автоматизации периодических расчетов, а именно - для расчета зарплаты. Курс предназначен для тех, кто уже имеет определенные навыки конфигурирования и программирования в системе “1С:Предприятие”, а также для опытных пользователей прикладного решения “1С:Зарплата и управление персоналом” и прочих прикладных решений, в которых реализован функционал расчета зарплаты.

4900 рублей

Универсальная обработка (УФ) для работы с журналом регистрации в формате SQLite через ODBC

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 v8::УФ 1cv8.cf Абонемент ($m) Универсальные обработки Журнал регистрации

Обработка позволяет подключиться к журналу регистрации в формате SQLite (.lgd) через ODBC и прочитать его события в привычном виде, как в стандартном журнале.

1 стартмани

27.11.2019    1444    4    Spartacus    5       

Управление ИТ-проектами. Модуль 2: продвинутый онлайн-курс по классическим методам управления проектами. Вебинары проходят с 12 марта по 11 июня 2020 года. Промо

Продвинутый онлайн-курс по классическому управлению ИТ-проектами позволит слушателям освоить инструменты из PMBoK® и 1С:Технологии корпоративного внедрения и научиться их применять для проектов любого масштаба. Курс включает в себя 12 вебинаров и 12 видеолекции, разбор кейсов и рекомендации экспертов по проектам слушателей. Ведущая курса - Мария Темчина.

от 13000 рублей

Ссылка по ГУИДам

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 v8::УФ 1cv8.cf Россия Windows Абонемент ($m) Поиск данных Универсальные обработки

Универсальная обработка для получения ссылки по различным уникальным идентификаторам (UID для sql, GUID, ...) и обратно.

1 стартмани

07.11.2019    3353    2    alfir70    9       

"Все функции" с плюшками

Отчеты и формы Программист Пользователь Внешняя обработка (ert,epf) v8 v8::УФ 1cv8.cf Абонемент ($m) Универсальные обработки Работа с интерфейсом

Замена штатному меню для тех, кто хочет открывать "Все функции" быстро и кто скучает по быстрому позиционированию по первым символам как было раньше

1 стартмани

06.11.2019    3247    16    codejs    6       

Готовые переносы данных из различных конфигураций 1C Промо

Рекомендуем готовые решения для переноса данных из различных конфигураций 1C. C техподдержкой от разработчиков и гарантией от Инфостарт.

Генерация QR кода для любых конфигураций 1С (обычные и управляемые формы)

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 v8::УФ 1cv8.cf Абонемент ($m) Универсальные обработки Универсальные функции

Для генерации используется компонента типовой конфигурации УТ11, встроенная в общий макет "КомпонентаПечатиQRКода". Ниже приведены процедуры, чтобы сделать обработку самостоятельно (только для УФ).

1 стартмани

11.10.2019    3028    12    dm1try    0       

INFOSTART MEETUP Kazan. 13 марта 2020 г. Промо

Инфостарт продолжает путешествие по России. Следующая остановка - Казань. Тема мероприятия - управление и технологии автоматизации учета на платформе "1С: Предприятие". Ждем всех: докладчиков и участников! Стоимость участия - 5 500 рублей. Цена действительна до 30.01.2020

5 500

Универсальный шаблон многопоточной обработки (на примере проверки работы Web-сервисов)

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 v8::УФ 1cv8.cf Абонемент ($m) Универсальные обработки

Работает в обычных и управляемых формах, в фоновом многопоточном режиме, отображает прогресс выполнения по каждому потоку пользователю. Из этого шаблона можно создать многопоточную обработку любой сложности и вида для обработки массива данных по заданному алгоритму.

3 стартмани

17.09.2019    1836    3    1C_Casual    4       

​​​​​​​CorelDRAW Graphics Suite 2019 Промо

CorelDRAW – пакет профессиональных инструментов для редактирования фотографий, разработки дизайна, создания макетов страниц и векторных иллюстраций

Универсальная выгрузка, загрузка зарегистрированных объектов по узлу

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 v8::УФ 1cv8.cf Россия Windows Абонемент ($m) Универсальные обработки

Набор обработок дает возможность выгружать и загружать регистрацию по узлу справочников и документов.

1 стартмани

16.09.2019    1411    2    байт    2       

Управление информационной базой на кластере (управляемые формы): просмотр сеансов, отключение сеансов, блокировка / разблокировка подключений

Инструменты и обработки Системный администратор Программист Внешняя обработка (ert,epf) v8 v8::УФ 1cv8.cf Абонемент ($m) Сервисные утилиты Администрирование данных 1С Универсальные обработки

Обработка предназначена для управления информационной базой на кластере 1С. Может применяться для автоматизированного выполнения регламентных процедур, когда требуется выгнать пользователей, заблокировать вход в базу.

1 стартмани

11.09.2019    1823    4    Spartacus    0       

1C:Предприятие для программистов: Запросы и отчеты. Второй поток. Онлайн-интенсив с 17 марта по 16 апреля 2020 г. Промо

Данный онлайн-курс предусматривает углубленное изучение языка запросов и возможностей системы компоновки данных, которые понадобятся при разработке отчетов, работающих на платформе “1С:Предприятие” в рамках различных прикладных решений. Курс предназначен для тех, кто уже имеет определенные навыки конфигурирования и программирования в системе “1С:Предприятие”, а также для опытных пользователей различных прикладных решений, которые используют в своей работе отчеты разного назначения.

6500 рублей

Универсальная форма объектов (для УФ)

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 v8::УФ 1cv8.cf Россия Абонемент ($m) Универсальные обработки

Обработка позволяет открывать любые документы или справочники, игнорируя логику, заданную в конфигурации.

1 стартмани

29.08.2019    1826    2    Ihty    0       

Преобразование ссылки управляемой формы во внутренний уникальный идентификатор и обратно

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 v8::УФ 1cv8.cf Абонемент ($m) Универсальные обработки

Обработка позволяет быстро получить ссылку управляемой формы или уникальный идентификатор через ссылку на объект (справочник, документ). Или в обратном порядке через ссылку управляемой формы или уникальный идентификатор.

1 стартмани

12.08.2019    1589    1    infostartchel    0       

Подборка решений для взаимодействия со ФГИС «Меркурий» Промо

С 1 июля 2019 года все компании, участвующие в обороте товаров животного происхождения, должны перейти на электронную ветеринарную сертификацию (ЭВС) через ФГИС «Меркурий». Инфостарт предлагает подборку программ, связанных с этим изменением.

Пометка требуемого количества помеченных объектов для удаления при выборочном варианте удаления

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 v8::УФ УНФ ЗКГУ3.0 БП3.0 УТ11 ЗУП3.x Россия Абонемент ($m) Универсальные обработки

Данная обработка выполняет установку требуемого количества галочек помеченных на удаление объектов в направлении вверх / вниз от текущего объекта в форме "Удаление помеченных объектов" с целью их дальнейшего удаления.

1 стартмани

05.08.2019    1650    3    its_33    0       

Обнуление регистров

Инструменты и обработки Программист Пользователь Внешняя обработка (ert,epf) v8::БУ v8::ОУ v8::УФ 1cv8.cf Россия БУ УУ Абонемент ($m) Универсальные обработки

Внешняя обработка для сторнирования остатков регистра Бухгалтерии (Хозрасчетный) и Накопления; очистка регистров сведений.

2 стартмани

02.08.2019    1879    3    powar    0