Универсальная обработка заполнения колонки табличной части документа. Обычная форма

Публикация № 1095920

Обработки - Обработка документов

Универсальная обработка заполнения табличной части

0
Универсальная обработка для установки произвольного значения выбранной колонки всей табличной части типом значения указанной ячейки.
Процедура Инициализировать(Объект, ИмяТабличнойЧасти, ТабличноеПоле) Экспорт;
	Попытка
		нЗначение = Объект[ИмяТабличнойЧасти][0][ТабличноеПоле.ТекущаяКолонка.Имя]; 
		ВвестиЗначение(нЗначение,"Введите значение для заполнения колонки "+ТипЗнч(Объект[ИмяТабличнойЧасти][0][ТабличноеПоле.ТекущаяКолонка.Имя]),ТипЗнч(Объект[ИмяТабличнойЧасти][0][ТабличноеПоле.ТекущаяКолонка.Имя]));
	Исключение
		нЗначение = Неопределено;
	КонецПопытки;	
	Если нЗначение<>Неопределено Тогда
		Для Каждого СтрокаТЧ ИЗ Объект[ИмяТабличнойЧасти] Цикл
			СтрокаТЧ[ТабличноеПоле.ТекущаяКолонка.Имя] = нЗначение;
		КонецЦикла;
	КонецЕсли;	
КонецПроцедуры

Быстрая и предельно простая в использовании универсальная обработка заполнения любой колонки (ссылочного либо примитивного вида).

Сама определяет тип значения колонки (число / строка / дата / план счетов / справочник / документ и т.д.). В зависимости от типа открывает формы выбора нужного значения.

При выборе элемент заполняет текущую колонку этим значением.

При регистрации обработки заполнения табличной части указываете объект и табличную часть, где хотели бы использовать эту обработку.

Весь код модуля обработки заполнения вместе с "Процедура() / Конец процедуры - 13 строк. 

 

Тестировалось на конфигурациях:

1) Управление производственным предприятием, редакция 1.3 (1.3.123.3)

2) Бухгалтерия предприятия, редакция 2.0 (2.0.66.82) 

 

Работает на любых типовых и нетиповых конфигурациях (при наличии механизма подключения обработок заполнения табличной части) на обычной форме.

0

Скачать файлы

Наименование Файл Версия Размер
Универсальная обработка заполнения колонки табличной части документа. Обычная форма.:
.epf 5,57Kb
19.07.19
5
.epf 5,57Kb 5 Скачать

См. также

Специальные предложения

Избранное Подписка Сортировка: Древо
В этой теме еще нет сообщений.
Оставьте свое сообщение